diff options
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-networking/recipes-extended/iscsitarget/files/0001-kernel-event-netlink_ack-now-requires-4-arguments.patch b/meta-networking/recipes-extended/iscsitarget/files/0001-kernel-event-netlink_ack-now-requires-4-arguments.patch new file mode 100644 index 0000000000..4426d3552d --- /dev/null +++ b/meta-networking/recipes-extended/iscsitarget/files/0001-kernel-event-netlink_ack-now-requires-4-arguments.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From cbc5f8151017f45231b75a826f18354a81c287c4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 26 Aug 2017 07:52:59 -0700 | ||
4 | Subject: [PATCH] kernel/event: netlink_ack() now requires 4 arguments | ||
5 | |||
6 | see https://patchwork.kernel.org/patch/9670181/ | ||
7 | |||
8 | event.c:32:4: error: too few arguments to function 'netlink_ack' | ||
9 | | netlink_ack(skb, nlh, 0); | ||
10 | | ^~~~~~~~~~~ | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | kernel/event.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | Index: iscsitarget-1.4.20.3+svn502/kernel/event.c | ||
18 | =================================================================== | ||
19 | --- iscsitarget-1.4.20.3+svn502.orig/kernel/event.c | ||
20 | +++ iscsitarget-1.4.20.3+svn502/kernel/event.c | ||
21 | @@ -6,6 +6,7 @@ | ||
22 | * Some functions are based on audit code. | ||
23 | */ | ||
24 | |||
25 | +#include <linux/version.h> | ||
26 | #include <linux/module.h> | ||
27 | #include <net/tcp.h> | ||
28 | #include "iet_u.h" | ||
29 | @@ -29,7 +30,11 @@ static void event_recv_skb(struct sk_buf | ||
30 | ietd_pid = NETLINK_CB(skb).portid; | ||
31 | WARN_ON(ietd_pid == 0); | ||
32 | if (nlh->nlmsg_flags & NLM_F_ACK) | ||
33 | +#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 12, 0) | ||
34 | + netlink_ack(skb, nlh, 0, NULL); | ||
35 | +#else | ||
36 | netlink_ack(skb, nlh, 0); | ||
37 | +#endif | ||
38 | skb_pull(skb, rlen); | ||
39 | } | ||
40 | } | ||
diff --git a/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb b/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb index 5c1e38e172..6593661075 100644 --- a/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb +++ b/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb | |||
@@ -14,7 +14,9 @@ SRC_URI = "http://ftp.heanet.ie/mirrors/ubuntu/pool/universe/i/${BPN}/${BPN}_${P | |||
14 | file://access-sk_v6_daddr-iff-IPV6-defined.patch \ | 14 | file://access-sk_v6_daddr-iff-IPV6-defined.patch \ |
15 | file://build_with_updated_bio_struct_of_linux_v4.3_and_above.patch \ | 15 | file://build_with_updated_bio_struct_of_linux_v4.3_and_above.patch \ |
16 | file://build_with_updated_interfaces_of_linux_v4.8_and_above.patch \ | 16 | file://build_with_updated_interfaces_of_linux_v4.8_and_above.patch \ |
17 | file://fix-call-trace-of-ahash-API-calling.patch" | 17 | file://fix-call-trace-of-ahash-API-calling.patch \ |
18 | file://0001-kernel-event-netlink_ack-now-requires-4-arguments.patch \ | ||
19 | " | ||
18 | 20 | ||
19 | SRC_URI[md5sum] = "ef9bc823bbabd3c772208c00d5f2d089" | 21 | SRC_URI[md5sum] = "ef9bc823bbabd3c772208c00d5f2d089" |
20 | SRC_URI[sha256sum] = "d3196ccb78a43266dce28587bfe30d8ab4db7566d7bce96057dfbb84100babb5" | 22 | SRC_URI[sha256sum] = "d3196ccb78a43266dce28587bfe30d8ab4db7566d7bce96057dfbb84100babb5" |