diff options
17 files changed, 127 insertions, 127 deletions
diff --git a/meta-efl/recipes-efl/efl/evas.inc b/meta-efl/recipes-efl/efl/evas.inc index 99ec3f31c..b0a42ea6a 100644 --- a/meta-efl/recipes-efl/efl/evas.inc +++ b/meta-efl/recipes-efl/efl/evas.inc | |||
@@ -12,14 +12,14 @@ INC_PR = "r0" | |||
12 | FILESPATHPKG =. "${BPN}-${PV}:${BPN}:" | 12 | FILESPATHPKG =. "${BPN}-${PV}:${BPN}:" |
13 | 13 | ||
14 | python populate_packages_prepend () { | 14 | python populate_packages_prepend () { |
15 | for plugin_type in "engines loaders savers".split(): | 15 | for plugin_type in "engines loaders savers".split(): |
16 | bb.note( "splitting packages for evas %s..." % plugin_type ) | 16 | bb.note( "splitting packages for evas %s..." % plugin_type ) |
17 | basedir = bb.data.expand( '${libdir}/evas/modules/%s' % plugin_type, d ) | 17 | basedir = bb.data.expand( '${libdir}/evas/modules/%s' % plugin_type, d ) |
18 | 18 | ||
19 | do_split_packages(d, basedir, '^(.*)', | 19 | do_split_packages(d, basedir, '^(.*)', |
20 | output_pattern = 'evas-' + plugin_type[:-1] + "-%s", | 20 | output_pattern = 'evas-' + plugin_type[:-1] + "-%s", |
21 | description = 'Evas module %s', | 21 | description = 'Evas module %s', |
22 | allow_dirs=True, recursive=False, extra_depends="" ) | 22 | allow_dirs=True, recursive=False, extra_depends="" ) |
23 | } | 23 | } |
24 | 24 | ||
25 | do_install_append() { | 25 | do_install_append() { |
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb index 6e1dc4ef0..75c10aeb0 100644 --- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb +++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb | |||
@@ -102,21 +102,21 @@ FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates" | |||
102 | PACKAGES_DYNAMIC = "${PN}-meta ${PN}-plugin-*" | 102 | PACKAGES_DYNAMIC = "${PN}-meta ${PN}-plugin-*" |
103 | 103 | ||
104 | python populate_packages_prepend () { | 104 | python populate_packages_prepend () { |
105 | abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d) | 105 | abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d) |
106 | do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='') | 106 | do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='') |
107 | 107 | ||
108 | metapkg = "abiword-meta" | 108 | metapkg = "abiword-meta" |
109 | bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) | 109 | bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) |
110 | bb.data.setVar('FILES_' + metapkg, "", d) | 110 | bb.data.setVar('FILES_' + metapkg, "", d) |
111 | blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ] | 111 | blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ] |
112 | metapkg_rdepends = [] | 112 | metapkg_rdepends = [] |
113 | packages = bb.data.getVar('PACKAGES', d, 1).split() | 113 | packages = bb.data.getVar('PACKAGES', d, 1).split() |
114 | for pkg in packages[1:]: | 114 | for pkg in packages[1:]: |
115 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): | 115 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): |
116 | print "Modifying ", pkg | 116 | print "Modifying ", pkg |
117 | metapkg_rdepends.append(pkg) | 117 | metapkg_rdepends.append(pkg) |
118 | bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d) | 118 | bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d) |
119 | bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d) | 119 | bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d) |
120 | packages.append(metapkg) | 120 | packages.append(metapkg) |
121 | bb.data.setVar('PACKAGES', ' '.join(packages), d) | 121 | bb.data.setVar('PACKAGES', ' '.join(packages), d) |
122 | } | 122 | } |
diff --git a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb index 0b39f1b56..586eed84f 100644 --- a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb +++ b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb | |||
@@ -43,8 +43,8 @@ FILES_${PN}-doc += " ${datadir}/gtk-doc" | |||
43 | PACKAGES_DYNAMIC = "gnome-vfs-plugin-*" | 43 | PACKAGES_DYNAMIC = "gnome-vfs-plugin-*" |
44 | 44 | ||
45 | python populate_packages_prepend () { | 45 | python populate_packages_prepend () { |
46 | print bb.data.getVar('FILES_gnome-vfs', d, 1) | 46 | print bb.data.getVar('FILES_gnome-vfs', d, 1) |
47 | 47 | ||
48 | plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d) | 48 | plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d) |
49 | do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s') | 49 | do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s') |
50 | } | 50 | } |
diff --git a/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb b/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb index 8553eb881..b6df81b8d 100644 --- a/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb +++ b/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb | |||
@@ -75,19 +75,19 @@ FILES_${PN}-dbg += " \ | |||
75 | PACKAGES_DYNAMIC += "gtk3-immodule-* gtk3-printbackend-*" | 75 | PACKAGES_DYNAMIC += "gtk3-immodule-* gtk3-printbackend-*" |
76 | 76 | ||
77 | python populate_packages_prepend () { | 77 | python populate_packages_prepend () { |
78 | import os.path | 78 | import os.path |
79 | 79 | ||
80 | prologue = bb.data.getVar("postinst_prologue", d, 1) | 80 | prologue = bb.data.getVar("postinst_prologue", d, 1) |
81 | 81 | ||
82 | gtk_libdir = bb.data.expand('${libdir}/gtk-3.0/${LIBV}', d) | 82 | gtk_libdir = bb.data.expand('${libdir}/gtk-3.0/${LIBV}', d) |
83 | immodules_root = os.path.join(gtk_libdir, 'immodules') | 83 | immodules_root = os.path.join(gtk_libdir, 'immodules') |
84 | printmodules_root = os.path.join(gtk_libdir, 'printbackends'); | 84 | printmodules_root = os.path.join(gtk_libdir, 'printbackends'); |
85 | 85 | ||
86 | do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk3-immodule-%s', 'GTK input module for %s', prologue + 'gtk-query-immodules-3.0 > /etc/gtk-3.0/gtk.immodules') | 86 | do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk3-immodule-%s', 'GTK input module for %s', prologue + 'gtk-query-immodules-3.0 > /etc/gtk-3.0/gtk.immodules') |
87 | do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk3-printbackend-%s', 'GTK printbackend module for %s') | 87 | do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk3-printbackend-%s', 'GTK printbackend module for %s') |
88 | 88 | ||
89 | if (bb.data.getVar('DEBIAN_NAMES', d, 1)): | 89 | if (bb.data.getVar('DEBIAN_NAMES', d, 1)): |
90 | bb.data.setVar('PKG_${PN}', 'libgtk-3.0', d) | 90 | bb.data.setVar('PKG_${PN}', 'libgtk-3.0', d) |
91 | } | 91 | } |
92 | 92 | ||
93 | postinst_prologue() { | 93 | postinst_prologue() { |
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb index 9988c4120..c55a8acf6 100644 --- a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb +++ b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb | |||
@@ -39,8 +39,8 @@ FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} | |||
39 | PACKAGES_DYNAMIC = "goffice-plugin-*" | 39 | PACKAGES_DYNAMIC = "goffice-plugin-*" |
40 | 40 | ||
41 | python populate_packages_prepend () { | 41 | python populate_packages_prepend () { |
42 | goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d) | 42 | goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d) |
43 | 43 | ||
44 | do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True) | 44 | do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True) |
45 | } | 45 | } |
46 | 46 | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc b/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc index 0f195a3f3..8ce3d7760 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc +++ b/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc | |||
@@ -62,9 +62,9 @@ PACKAGES_DYNAMIC = "${KLIBC_UTILS_PKGNAME}-*" | |||
62 | 62 | ||
63 | python populate_packages_prepend () { | 63 | python populate_packages_prepend () { |
64 | 64 | ||
65 | base_bin_dir = bb.data.expand('${base_bindir}', d) | 65 | base_bin_dir = bb.data.expand('${base_bindir}', d) |
66 | do_split_packages(d, base_bin_dir, '(.*)', '${KLIBC_UTILS_PKGNAME}-%s', 'Klibc util for %s', allow_links=True, allow_dirs=True) | 66 | do_split_packages(d, base_bin_dir, '(.*)', '${KLIBC_UTILS_PKGNAME}-%s', 'Klibc util for %s', allow_links=True, allow_dirs=True) |
67 | 67 | ||
68 | base_sbin_dir = bb.data.expand('${base_sbindir}', d) | 68 | base_sbin_dir = bb.data.expand('${base_sbindir}', d) |
69 | do_split_packages(d, base_sbin_dir, '(.*)', '${KLIBC_UTILS_PKGNAME}-%s', 'Klibc util for %s', allow_dirs=True) | 69 | do_split_packages(d, base_sbin_dir, '(.*)', '${KLIBC_UTILS_PKGNAME}-%s', 'Klibc util for %s', allow_dirs=True) |
70 | } | 70 | } |
diff --git a/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb b/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb index 09e11f997..00030d3b2 100644 --- a/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb +++ b/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb | |||
@@ -29,8 +29,8 @@ EXTRA_OECONF = "\ | |||
29 | # enable pulse again when pulseaudio >= 0.9.11 is the default in OE | 29 | # enable pulse again when pulseaudio >= 0.9.11 is the default in OE |
30 | 30 | ||
31 | python populate_packages_prepend() { | 31 | python populate_packages_prepend() { |
32 | plugindir = bb.data.expand('${libdir}/${P}/', d) | 32 | plugindir = bb.data.expand('${libdir}/${P}/', d) |
33 | do_split_packages(d, plugindir, '^libcanberra-(.*)\.so$', 'libcanberra-%s', '%s support library', extra_depends='' ) | 33 | do_split_packages(d, plugindir, '^libcanberra-(.*)\.so$', 'libcanberra-%s', '%s support library', extra_depends='' ) |
34 | } | 34 | } |
35 | 35 | ||
36 | PACKAGES =+ "${PN}-gtk" | 36 | PACKAGES =+ "${PN}-gtk" |
diff --git a/meta-oe/recipes-devtools/orc/orc.inc b/meta-oe/recipes-devtools/orc/orc.inc index c599126e3..6efe02564 100644 --- a/meta-oe/recipes-devtools/orc/orc.inc +++ b/meta-oe/recipes-devtools/orc/orc.inc | |||
@@ -16,8 +16,8 @@ FILES_orc-examples = "${libdir}/orc/*" | |||
16 | FILES_${PN} = "${bindir}/*" | 16 | FILES_${PN} = "${bindir}/*" |
17 | 17 | ||
18 | python populate_packages_prepend () { | 18 | python populate_packages_prepend () { |
19 | libdir = bb.data.expand('${libdir}', d) | 19 | libdir = bb.data.expand('${libdir}', d) |
20 | do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True) | 20 | do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True) |
21 | } | 21 | } |
22 | 22 | ||
23 | do_compile_prepend_virtclass-native () { | 23 | do_compile_prepend_virtclass-native () { |
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb index ac00046b4..0d0388988 100644 --- a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb +++ b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb | |||
@@ -23,9 +23,9 @@ PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome" | |||
23 | PACKAGES_DYNAMIC += "${PN}-theme-*" | 23 | PACKAGES_DYNAMIC += "${PN}-theme-*" |
24 | 24 | ||
25 | python populate_packages_prepend() { | 25 | python populate_packages_prepend() { |
26 | theme_dir = bb.data.expand('${datadir}/themes/', d) | 26 | theme_dir = bb.data.expand('${datadir}/themes/', d) |
27 | theme_name = bb.data.expand('${PN}-theme-%s', d) | 27 | theme_name = bb.data.expand('${PN}-theme-%s', d) |
28 | do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True) | 28 | do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True) |
29 | } | 29 | } |
30 | 30 | ||
31 | RDEPENDS_${PN} += "${PN}-core" | 31 | RDEPENDS_${PN} += "${PN}-core" |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb index ab9be352b..79920ce1f 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb | |||
@@ -9,8 +9,8 @@ SRC_URI = "http://osdn.dl.sourceforge.jp/mplus-fonts/6650/mplus-TESTFLIGHT-${PV} | |||
9 | S = "${WORKDIR}/mplus-TESTFLIGHT-${PV}" | 9 | S = "${WORKDIR}/mplus-TESTFLIGHT-${PV}" |
10 | 10 | ||
11 | python populate_packages_prepend() { | 11 | python populate_packages_prepend() { |
12 | plugindir = bb.data.expand('${datadir}/fonts/ttf-mplus/', d) | 12 | plugindir = bb.data.expand('${datadir}/fonts/ttf-mplus/', d) |
13 | do_split_packages(d, plugindir, '^(.*)\.ttf$', 'ttf-%s', 'TTF Font %s', extra_depends = "ttf-common") | 13 | do_split_packages(d, plugindir, '^(.*)\.ttf$', 'ttf-%s', 'TTF Font %s', extra_depends = "ttf-common") |
14 | } | 14 | } |
15 | 15 | ||
16 | do_install() { | 16 | do_install() { |
diff --git a/meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb b/meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb index 3d231e0f1..bff53124a 100644 --- a/meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb +++ b/meta-oe/recipes-multimedia/libcdio/libcdio_0.82.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | DESCRIPTION = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access." | 1 | ESCRIPTION = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access." |
2 | HOMEPAGE = "http://www.gnu.org/software/libcdio/" | 2 | HOMEPAGE = "http://www.gnu.org/software/libcdio/" |
3 | SECTION = "libs" | 3 | SECTION = "libs" |
4 | 4 | ||
@@ -22,7 +22,7 @@ FILES_${PN} = "${libdir}/${PN}${SOLIB}" | |||
22 | FILES_${PN}-utils = "${bindir}/*" | 22 | FILES_${PN}-utils = "${bindir}/*" |
23 | 23 | ||
24 | python populate_packages_prepend () { | 24 | python populate_packages_prepend () { |
25 | glibdir = bb.data.expand('${libdir}', d) | 25 | glibdir = bb.data.expand('${libdir}', d) |
26 | do_split_packages(d, glibdir, '^lib(.*)\.so\..*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True) | 26 | do_split_packages(d, glibdir, '^lib(.*)\.so\..*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True) |
27 | } | 27 | } |
28 | 28 | ||
diff --git a/meta-oe/recipes-support/freerdp/freerdp.inc b/meta-oe/recipes-support/freerdp/freerdp.inc index ec7d36059..46aecf613 100644 --- a/meta-oe/recipes-support/freerdp/freerdp.inc +++ b/meta-oe/recipes-support/freerdp/freerdp.inc | |||
@@ -26,25 +26,25 @@ FILES_libfreerdp = "${libdir}/lib*${SOLIBS}" | |||
26 | PACKAGES_DYNAMIC = "libfreerdp-plugin-*" | 26 | PACKAGES_DYNAMIC = "libfreerdp-plugin-*" |
27 | 27 | ||
28 | python populate_packages_prepend () { | 28 | python populate_packages_prepend () { |
29 | freerdp_root = bb.data.expand('${libdir}/freerdp', d) | 29 | freerdp_root = bb.data.expand('${libdir}/freerdp', d) |
30 | 30 | ||
31 | do_split_packages(d, freerdp_root, '^(audin_.*)\.so$', | 31 | do_split_packages(d, freerdp_root, '^(audin_.*)\.so$', |
32 | output_pattern='libfreerdp-plugin-%s', | 32 | output_pattern='libfreerdp-plugin-%s', |
33 | description='FreeRDP plugin %s', | 33 | description='FreeRDP plugin %s', |
34 | prepend=True, extra_depends='libfreerdp-plugin-audin') | 34 | prepend=True, extra_depends='libfreerdp-plugin-audin') |
35 | 35 | ||
36 | do_split_packages(d, freerdp_root, '^(rdpsnd_.*)\.so$', | 36 | do_split_packages(d, freerdp_root, '^(rdpsnd_.*)\.so$', |
37 | output_pattern='libfreerdp-plugin-%s', | 37 | output_pattern='libfreerdp-plugin-%s', |
38 | description='FreeRDP plugin %s', | 38 | description='FreeRDP plugin %s', |
39 | prepend=True, extra_depends='libfreerdp-plugin-rdpsnd') | 39 | prepend=True, extra_depends='libfreerdp-plugin-rdpsnd') |
40 | 40 | ||
41 | do_split_packages(d, freerdp_root, '^(tsmf_.*)\.so$', | 41 | do_split_packages(d, freerdp_root, '^(tsmf_.*)\.so$', |
42 | output_pattern='libfreerdp-plugin-%s', | 42 | output_pattern='libfreerdp-plugin-%s', |
43 | description='FreeRDP plugin %s', | 43 | description='FreeRDP plugin %s', |
44 | prepend=True, extra_depends='libfreerdp-plugin-tsmf') | 44 | prepend=True, extra_depends='libfreerdp-plugin-tsmf') |
45 | 45 | ||
46 | do_split_packages(d, freerdp_root, '^([^-]*)\.so$', | 46 | do_split_packages(d, freerdp_root, '^([^-]*)\.so$', |
47 | output_pattern='libfreerdp-plugin-%s', | 47 | output_pattern='libfreerdp-plugin-%s', |
48 | description='FreeRDP plugin %s', | 48 | description='FreeRDP plugin %s', |
49 | prepend=True, extra_depends='') | 49 | prepend=True, extra_depends='') |
50 | } | 50 | } |
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb index 942e89a66..9cd454109 100644 --- a/meta-oe/recipes-support/opencv/opencv_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb | |||
@@ -39,23 +39,23 @@ TARGET_CC_ARCH += "-I${S}/include " | |||
39 | PACKAGES += "${PN}-apps python-opencv" | 39 | PACKAGES += "${PN}-apps python-opencv" |
40 | 40 | ||
41 | python populate_packages_prepend () { | 41 | python populate_packages_prepend () { |
42 | cv_libdir = bb.data.expand('${libdir}', d) | 42 | cv_libdir = bb.data.expand('${libdir}', d) |
43 | cv_libdir_dbg = bb.data.expand('${libdir}/.debug', d) | 43 | cv_libdir_dbg = bb.data.expand('${libdir}/.debug', d) |
44 | do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev', allow_links=True) | 44 | do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev', allow_links=True) |
45 | do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') | 45 | do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') |
46 | do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') | 46 | do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') |
47 | do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'OpenCV %s library', extra_depends='', allow_links=True) | 47 | do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'OpenCV %s library', extra_depends='', allow_links=True) |
48 | 48 | ||
49 | pn = bb.data.getVar('PN', d, 1) | 49 | pn = bb.data.getVar('PN', d, 1) |
50 | metapkg = pn + '-dev' | 50 | metapkg = pn + '-dev' |
51 | bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) | 51 | bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d) |
52 | blacklist = [ metapkg ] | 52 | blacklist = [ metapkg ] |
53 | metapkg_rdepends = [ ] | 53 | metapkg_rdepends = [ ] |
54 | packages = bb.data.getVar('PACKAGES', d, 1).split() | 54 | packages = bb.data.getVar('PACKAGES', d, 1).split() |
55 | for pkg in packages[1:]: | 55 | for pkg in packages[1:]: |
56 | if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'): | 56 | if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'): |
57 | metapkg_rdepends.append(pkg) | 57 | metapkg_rdepends.append(pkg) |
58 | bb.data.setVar('RRECOMMENDS_' + metapkg, ' '.join(metapkg_rdepends), d) | 58 | bb.data.setVar('RRECOMMENDS_' + metapkg, ' '.join(metapkg_rdepends), d) |
59 | } | 59 | } |
60 | 60 | ||
61 | FILES_${PN} = "" | 61 | FILES_${PN} = "" |
diff --git a/meta-oe/recipes-support/pidgin/pidgin.inc b/meta-oe/recipes-support/pidgin/pidgin.inc index db4753ed3..90e2fd4b6 100644 --- a/meta-oe/recipes-support/pidgin/pidgin.inc +++ b/meta-oe/recipes-support/pidgin/pidgin.inc | |||
@@ -59,32 +59,32 @@ FILES_${PN}-dev += "${libdir}/${PN}/*.la" | |||
59 | PACKAGES_DYNAMIC = "libpurple-protocol-* libpurple-plugin-* pidgin-plugin-* finch-plugin-*" | 59 | PACKAGES_DYNAMIC = "libpurple-protocol-* libpurple-plugin-* pidgin-plugin-* finch-plugin-*" |
60 | 60 | ||
61 | python populate_packages_prepend () { | 61 | python populate_packages_prepend () { |
62 | pidgroot = bb.data.expand('${libdir}/pidgin', d) | 62 | pidgroot = bb.data.expand('${libdir}/pidgin', d) |
63 | purple = bb.data.expand('${libdir}/purple-2', d) | 63 | purple = bb.data.expand('${libdir}/purple-2', d) |
64 | finch = bb.data.expand('${libdir}/finch', d) | 64 | finch = bb.data.expand('${libdir}/finch', d) |
65 | 65 | ||
66 | do_split_packages(d, pidgroot, '^([^l][^i][^b].*)\.so$', | 66 | do_split_packages(d, pidgroot, '^([^l][^i][^b].*)\.so$', |
67 | output_pattern='pidgin-plugin-%s', | 67 | output_pattern='pidgin-plugin-%s', |
68 | description='Pidgin plugin %s', | 68 | description='Pidgin plugin %s', |
69 | prepend=True, extra_depends='') | 69 | prepend=True, extra_depends='') |
70 | 70 | ||
71 | do_split_packages(d, purple, '^lib(.*)\.so$', | 71 | do_split_packages(d, purple, '^lib(.*)\.so$', |
72 | output_pattern='libpurple-protocol-%s', | 72 | output_pattern='libpurple-protocol-%s', |
73 | description='Libpurple protocol plugin for %s', | 73 | description='Libpurple protocol plugin for %s', |
74 | prepend=True, extra_depends='') | 74 | prepend=True, extra_depends='') |
75 | 75 | ||
76 | do_split_packages(d, purple, '^(ssl-.*)\.so$', | 76 | do_split_packages(d, purple, '^(ssl-.*)\.so$', |
77 | output_pattern='libpurple-plugin-%s', | 77 | output_pattern='libpurple-plugin-%s', |
78 | description='libpurple plugin %s', | 78 | description='libpurple plugin %s', |
79 | prepend=True, extra_depends='libpurple-plugin-ssl') | 79 | prepend=True, extra_depends='libpurple-plugin-ssl') |
80 | 80 | ||
81 | do_split_packages(d, purple, '^([^l][^i][^b].*)\.so$', | 81 | do_split_packages(d, purple, '^([^l][^i][^b].*)\.so$', |
82 | output_pattern='libpurple-plugin-%s', | 82 | output_pattern='libpurple-plugin-%s', |
83 | description='libpurple plugin %s', | 83 | description='libpurple plugin %s', |
84 | prepend=True, extra_depends='') | 84 | prepend=True, extra_depends='') |
85 | 85 | ||
86 | do_split_packages(d, finch, '^([^l][^i][^b].*)\.so$', | 86 | do_split_packages(d, finch, '^([^l][^i][^b].*)\.so$', |
87 | output_pattern='finch-plugin-%s', | 87 | output_pattern='finch-plugin-%s', |
88 | description='Finch plugin %s', | 88 | description='Finch plugin %s', |
89 | prepend=True, extra_depends='') | 89 | prepend=True, extra_depends='') |
90 | } | 90 | } |
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb index 8af1aa571..6b9fc8c24 100644 --- a/meta-systemd/recipes-core/systemd/systemd_git.bb +++ b/meta-systemd/recipes-core/systemd/systemd_git.bb | |||
@@ -85,8 +85,8 @@ do_install() { | |||
85 | } | 85 | } |
86 | 86 | ||
87 | python populate_packages_prepend (){ | 87 | python populate_packages_prepend (){ |
88 | systemdlibdir = d.getVar("base_libdir", True) | 88 | systemdlibdir = d.getVar("base_libdir", True) |
89 | do_split_packages(d, systemdlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Systemd %s library', extra_depends='', allow_links=True) | 89 | do_split_packages(d, systemdlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Systemd %s library', extra_depends='', allow_links=True) |
90 | } | 90 | } |
91 | 91 | ||
92 | PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze" | 92 | PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze" |
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.6.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.6.bb index 94bb7fd59..b59fde0a1 100644 --- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.6.bb +++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.6.bb | |||
@@ -9,14 +9,14 @@ PR = "r3" | |||
9 | inherit xfce | 9 | inherit xfce |
10 | 10 | ||
11 | python populate_packages_prepend() { | 11 | python populate_packages_prepend() { |
12 | plugin_dir = bb.data.expand('${libdir}/xfce4/panel/plugins/', d) | 12 | plugin_dir = bb.data.expand('${libdir}/xfce4/panel/plugins/', d) |
13 | plugin_name = bb.data.expand('${PN}-plugin-%s', d) | 13 | plugin_name = bb.data.expand('${PN}-plugin-%s', d) |
14 | do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, | 14 | do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, |
15 | '${PN} plugin for %s', extra_depends='', prepend=True, | 15 | '${PN} plugin for %s', extra_depends='', prepend=True, |
16 | aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop', | 16 | aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop', |
17 | '${sysconfdir}/xdg/xfce/panel/%s-*', | 17 | '${sysconfdir}/xdg/xfce/panel/%s-*', |
18 | '${datadir}/icons/hicolor/48x48/apps/*-%s.png', | 18 | '${datadir}/icons/hicolor/48x48/apps/*-%s.png', |
19 | '${bindir}/*%s*']) | 19 | '${bindir}/*%s*']) |
20 | } | 20 | } |
21 | do_install_append () { | 21 | do_install_append () { |
22 | find "${D}/${libdir}/xfce4/panel/plugins" -name '*.a' -exec rm -f {} + | 22 | find "${D}/${libdir}/xfce4/panel/plugins" -name '*.a' -exec rm -f {} + |
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.8.3.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.8.3.bb index e2dc4abf9..299c7ad6b 100644 --- a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.8.3.bb +++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.8.3.bb | |||
@@ -12,8 +12,8 @@ SRC_URI[sha256sum] = "0b0e8bea0b257958ad416ab5678cf0cdd7e909943d4d5ab32afc35295a | |||
12 | EXTRA_OECONF += " --enable-startup-notification" | 12 | EXTRA_OECONF += " --enable-startup-notification" |
13 | 13 | ||
14 | python populate_packages_prepend () { | 14 | python populate_packages_prepend () { |
15 | themedir = bb.data.expand('${datadir}/themes', d) | 15 | themedir = bb.data.expand('${datadir}/themes', d) |
16 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True) | 16 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True) |
17 | } | 17 | } |
18 | 18 | ||
19 | PACKAGES_DYNAMIC += "xfwm4-theme-*" | 19 | PACKAGES_DYNAMIC += "xfwm4-theme-*" |