diff options
-rw-r--r-- | meta-oe/recipes-support/mcelog/mcelog/0001-Add-Kabylake-client-support.patch | 96 | ||||
-rw-r--r-- | meta-oe/recipes-support/mcelog/mcelog_1.40.bb | 1 |
2 files changed, 97 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog/0001-Add-Kabylake-client-support.patch b/meta-oe/recipes-support/mcelog/mcelog/0001-Add-Kabylake-client-support.patch new file mode 100644 index 000000000..f9dfbcab5 --- /dev/null +++ b/meta-oe/recipes-support/mcelog/mcelog/0001-Add-Kabylake-client-support.patch | |||
@@ -0,0 +1,96 @@ | |||
1 | From 11bfbb446116c8313728157148a6bb15625031e8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tony Luck <tony.luck@intel.com> | ||
3 | Date: Tue, 30 Aug 2016 09:37:02 -0700 | ||
4 | Subject: [PATCH] Add Kabylake client support | ||
5 | |||
6 | CPU models 0x8E and 0x9E denote kabylake client processor | ||
7 | |||
8 | Upstream-Status: Backport [A little modification on context] | ||
9 | https://github.com/andikleen/mcelog/commit/11bfbb446116c8313728157148a6bb15625031e8 | ||
10 | |||
11 | Signed-off-by: Tony Luck <tony.luck@intel.com> | ||
12 | Signed-off-by: Andi Kleen <ak@linux.intel.com> | ||
13 | Signed-off-by: Quanyang Wang <quanyang.wang@windriver.com> | ||
14 | --- | ||
15 | intel.c | 5 ++++- | ||
16 | intel.h | 3 ++- | ||
17 | mcelog.c | 4 +++- | ||
18 | mcelog.h | 1 + | ||
19 | 4 files changed, 10 insertions(+), 3 deletions(-) | ||
20 | |||
21 | diff --git a/intel.c b/intel.c | ||
22 | index f4ef9f6..33a99a8 100644 | ||
23 | --- a/intel.c | ||
24 | +++ b/intel.c | ||
25 | @@ -35,7 +35,8 @@ void intel_cpu_init(enum cputype cpu) | ||
26 | cpu == CPU_IVY_BRIDGE || cpu == CPU_IVY_BRIDGE_EPEX || | ||
27 | cpu == CPU_HASWELL || cpu == CPU_HASWELL_EPEX || cpu == CPU_BROADWELL || | ||
28 | cpu == CPU_BROADWELL_DE || cpu == CPU_BROADWELL_EPEX || | ||
29 | - cpu == CPU_KNIGHTS_LANDING || cpu == CPU_SKYLAKE || cpu == CPU_SKYLAKE_XEON) | ||
30 | + cpu == CPU_KNIGHTS_LANDING || cpu == CPU_SKYLAKE || cpu == CPU_SKYLAKE_XEON || | ||
31 | + cpu == CPU_KABYLAKE) | ||
32 | memory_error_support = 1; | ||
33 | } | ||
34 | |||
35 | @@ -90,6 +91,8 @@ enum cputype select_intel_cputype(int family, int model) | ||
36 | return CPU_SKYLAKE; | ||
37 | else if (model == 0x55) | ||
38 | return CPU_SKYLAKE_XEON; | ||
39 | + else if (model == 0x8E || model == 0x9E) | ||
40 | + return CPU_KABYLAKE; | ||
41 | if (model > 0x1a) { | ||
42 | Eprintf("Family 6 Model %u CPU: only decoding architectural errors\n", | ||
43 | model); | ||
44 | diff --git a/intel.h b/intel.h | ||
45 | index d22895b..c231925 100644 | ||
46 | --- a/intel.h | ||
47 | +++ b/intel.h | ||
48 | @@ -26,5 +26,6 @@ extern int memory_error_support; | ||
49 | case CPU_ATOM: \ | ||
50 | case CPU_KNIGHTS_LANDING: \ | ||
51 | case CPU_SKYLAKE: \ | ||
52 | - case CPU_SKYLAKE_XEON | ||
53 | + case CPU_SKYLAKE_XEON: \ | ||
54 | + case CPU_KABYLAKE | ||
55 | |||
56 | diff --git a/mcelog.c b/mcelog.c | ||
57 | index 1d79fa1..7214a0d 100644 | ||
58 | --- a/mcelog.c | ||
59 | +++ b/mcelog.c | ||
60 | @@ -238,6 +238,7 @@ static char *cputype_name[] = { | ||
61 | [CPU_ATOM] = "ATOM", | ||
62 | [CPU_SKYLAKE] = "Skylake", | ||
63 | [CPU_SKYLAKE_XEON] = "Skylake server", | ||
64 | + [CPU_KABYLAKE] = "Kabylake", | ||
65 | }; | ||
66 | |||
67 | static struct config_choice cpu_choices[] = { | ||
68 | @@ -287,6 +288,7 @@ static struct config_choice cpu_choices[] = { | ||
69 | { "atom", CPU_ATOM }, | ||
70 | { "skylake", CPU_SKYLAKE }, | ||
71 | { "skylake_server", CPU_SKYLAKE_XEON }, | ||
72 | + { "kabylake", CPU_KABYLAKE }, | ||
73 | { NULL } | ||
74 | }; | ||
75 | |||
76 | @@ -451,7 +453,7 @@ static void dump_mce(struct mce *m, unsigned recordlen) | ||
77 | cputype != CPU_HASWELL_EPEX && cputype != CPU_BROADWELL && | ||
78 | cputype != CPU_BROADWELL_DE && cputype != CPU_BROADWELL_EPEX && | ||
79 | cputype != CPU_KNIGHTS_LANDING && cputype != CPU_SKYLAKE && | ||
80 | - cputype != CPU_SKYLAKE_XEON) | ||
81 | + cputype != CPU_SKYLAKE_XEON && cputype != CPU_KABYLAKE) | ||
82 | resolveaddr(m->addr); | ||
83 | if (!ascii_mode && ismemerr && (m->status & MCI_STATUS_ADDRV)) { | ||
84 | diskdb_resolve_addr(m->addr); | ||
85 | diff --git a/mcelog.h b/mcelog.h | ||
86 | index abc8bc9..254b3a0 100644 | ||
87 | --- a/mcelog.h | ||
88 | +++ b/mcelog.h | ||
89 | @@ -130,6 +130,7 @@ enum cputype { | ||
90 | CPU_ATOM, | ||
91 | CPU_SKYLAKE, | ||
92 | CPU_SKYLAKE_XEON, | ||
93 | + CPU_KABYLAKE, | ||
94 | }; | ||
95 | |||
96 | enum option_ranges { | ||
diff --git a/meta-oe/recipes-support/mcelog/mcelog_1.40.bb b/meta-oe/recipes-support/mcelog/mcelog_1.40.bb index 9aebbd571..0d359fc4b 100644 --- a/meta-oe/recipes-support/mcelog/mcelog_1.40.bb +++ b/meta-oe/recipes-support/mcelog/mcelog_1.40.bb | |||
@@ -7,6 +7,7 @@ SECTION = "System Environment/Base" | |||
7 | 7 | ||
8 | SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \ | 8 | SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \ |
9 | file://mcelog-debash.patch \ | 9 | file://mcelog-debash.patch \ |
10 | file://0001-Add-Kabylake-client-support.patch \ | ||
10 | file://run-ptest \ | 11 | file://run-ptest \ |
11 | " | 12 | " |
12 | 13 | ||