diff options
-rw-r--r-- | meta-oe/recipes-devtools/perl/ipc-run_0.94.bb | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perl/ipc-run_0.94.bb b/meta-oe/recipes-devtools/perl/ipc-run_0.94.bb new file mode 100644 index 000000000..66054a257 --- /dev/null +++ b/meta-oe/recipes-devtools/perl/ipc-run_0.94.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "\ | ||
2 | IPC::Run allows you run and interact with child processes \ | ||
3 | using files, pipes, and pseudo-ttys. Both system()-style and scripted \ | ||
4 | usages are supported and may be mixed. Likewise, functional and OO API \ | ||
5 | styles are both supported and may be mixed." | ||
6 | SECTION = "libs" | ||
7 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e" | ||
9 | DEPENDS = "perl" | ||
10 | |||
11 | SRC_URI = "git://github.com/toddr/IPC-Run.git" | ||
12 | SRCREV = "6bdf41e276e06d23e140783b13a6eaef4745c216" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | inherit cpan | ||
17 | |||
18 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" | ||
19 | |||
20 | do_compile() { | ||
21 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" | ||
22 | cpan_do_compile | ||
23 | } | ||