summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch19
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl_svn.bb11
2 files changed, 2 insertions, 28 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch b/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch
deleted file mode 100644
index 966a977ee..000000000
--- a/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1see https://bugs.webkit.org/show_bug.cgi?id=50762
2fixed by:
3http://trac.webkit.org/changeset/78047/trunk/Source/WebCore/CMakeLists.txt
4fix reverted by:
5http://trac.webkit.org/changeset/78057/trunk/Source/WebCore/CMakeLists.txt
6
7so revert revert as we care about webkit-efl and don't care about WinCE
8
9Index: Source/WebCore/CMakeLists.txt
10===================================================================
11--- Source/WebCore/CMakeLists.txt (revision 78042)
12+++ Source/WebCore/CMakeLists.txt (revision 78047)
13@@ -1157,6 +1157,4 @@
14
15 platform/Arena.cpp
16- platform/ContextMenu.cpp
17- platform/ContextMenuItem.cpp
18 platform/ContentType.cpp
19 platform/CrossThreadCopier.cpp
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
index bffded788..9f02a595e 100644
--- a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
+++ b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
@@ -9,27 +9,20 @@ DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \
9 libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \ 9 libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \
10 libxml2 pango eina ecore evas edje" 10 libxml2 pango eina ecore evas edje"
11 11
12SRCREV = "79192" 12SRCREV = "97724"
13PV = "1.3.11+svnr${SRCPV}" 13PV = "1.6.1+svnr${SRCPV}"
14 14
15SRCREV_FORMAT = "source" 15SRCREV_FORMAT = "source"
16 16
17SRC_URI = "\ 17SRC_URI = "\
18 svn://svn.webkit.org/repository/webkit/trunk;module=Source;name=source;proto=http;subdir=src \ 18 svn://svn.webkit.org/repository/webkit/trunk;module=Source;name=source;proto=http;subdir=src \
19 svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \ 19 svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \
20 file://revert.r78057.patch \
21 " 20 "
22 21
23S = "${WORKDIR}/src/Source" 22S = "${WORKDIR}/src/Source"
24 23
25inherit cmake lib_package pkgconfig perlnative 24inherit cmake lib_package pkgconfig perlnative
26 25
27# Wants to jump too far for THUMB on armv4t
28# in WebCore::DocTypeStringsHash::doctype_hash_function(char const*, unsigned int)':
29# DocTypeStrings.cpp:(.text._ZN7WebCore18DocTypeStringsHash21doctype_hash_functionEPKcj[WebCore::DocTypeStringsHash::doctype_hash_function(char const*, unsigned int)]+0x12): relocation truncated to fit: R_ARM_THM_CALL against symbol `__gnu_thumb1_case_uhi' defined in .text section in x86_64-linux/usr/armv4t/lib/gcc/arm-oe-linux-gnueabi/4.5.2/libgcc.a(_thumb1_case_uhi.o)
30# the same in WebCore::CSSValueKeywordsHash::value_hash_function(char const*, unsigned int)':
31# WebCore::CSSPropertyNamesHash::propery_hash_function(char const*, unsigned int)':
32# WebCore::ColorDataHash::colordata_hash_function(char const*, unsigned int)':
33ARM_INSTRUCTION_SET = "arm" 26ARM_INSTRUCTION_SET = "arm"
34 27
35EXTRA_OECMAKE = "-DPORT=Efl -DSHARED_CORE=ON" 28EXTRA_OECMAKE = "-DPORT=Efl -DSHARED_CORE=ON"