summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb b/meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb
new file mode 100644
index 000000000..798673035
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-power-manager/gnome-power-manager_2.32.0.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "Power management daemon"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
4
5DEPENDS = "glib-2.0 gtk+ gconf gnome-keyring dbus dbus-glib libnotify libwnck cairo libunique gnome-panel xrandr virtual/libx11 libxrender libcanberra upower"
6
7inherit gnome
8SRC_URI[archive.md5sum] = "9a08e85dce3ffb90775f15e3bda4adda"
9SRC_URI[archive.sha256sum] = "17fa301bf7e133285c0e054ae3be2b0f690c48f59b09f67e04d6ed339b330476"
10
11EXTRA_OECONF = " --disable-scrollkeeper \
12 --disable-keyring \
13 --x-includes=${STAGING_INCDIR} \
14 --x-libraries=${STAGING_LIBDIR} \
15 --with-dpms-ext=${STAGING_INCDIR}/.. \
16 --enable-compile-warnings=no \
17 ac_cv_header_X11_extensions_dpms_h=yes \
18 "
19
20do_configure_prepend() {
21 sed -i -e 's: man ::g' ${S}/Makefile.am
22}
23
24do_configure_append() {
25 rm config.log
26 # Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
27 for i in $(find ${S} -name "Makefile") ; do
28 sed -i -e s:-Werror::g $i
29 done
30 sed -e "s/libtool --/${TARGET_SYS}-libtool --/" -i ${S}/src/Makefile
31}
32
33PACKAGES =+ "${PN}-applets"
34
35FILES_${PN}-applets = "${bindir}/*applet* \
36 ${libdir}/bonobo/servers \
37 ${datadir}/gnome-2.0/ui"
38
39FILES_${PN} += "${datadir}/icons \
40 ${datadir}/dbus-1 \
41 ${datadir}/gnome/autostart \
42 "
43
44FILES_${PN}-doc += "${datadir}/omf \
45 ${datadir}/gnome/help "
46