summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb b/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb
new file mode 100644
index 000000000..ae7887d3c
--- /dev/null
+++ b/meta-oe/recipes-benchmark/tinymembench/tinymembench_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A simple memory benchmark program, which tries to measure the \
2peak bandwidth of sequential memory accesses and the latency of random memory \
3accesses. Bandwidth is measured by running different assembly code for the \
4aligned memory blocks and attempting different prefetch strategies"
5HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345"
8
9PV = "0.3.9+git${SRCPV}"
10
11SRCREV = "95e68477588d41187b2d2e52ecf6be0e7eb06b8d"
12SRC_URI = "git://github.com/ssvb/tinymembench.git"
13
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m755 tinymembench ${D}${bindir}/
19}