summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/mtr/files/no-gtk.patch31
-rw-r--r--meta-networking/recipes-support/mtr/mtr_0.82.bb19
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/mtr/files/no-gtk.patch b/meta-networking/recipes-support/mtr/files/no-gtk.patch
new file mode 100644
index 000000000..0dbeb7a29
--- /dev/null
+++ b/meta-networking/recipes-support/mtr/files/no-gtk.patch
@@ -0,0 +1,31 @@
1Disable gtk check that breaks with current autotools
2
3Ideally we would have a proper fix for this and send that upstream instead.
4
5Upstream-Status: Pending
6
7Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
8
9diff --git a/configure.in b/configure.in
10index 8474543..5118565 100644
11--- a/configure.in
12+++ b/configure.in
13@@ -48,16 +48,8 @@ AC_ARG_ENABLE(ipv6,
14 [ --disable-ipv6 Do not enable IPv6],
15 WANTS_IPV6=$enableval, WANTS_IPV6=yes)
16
17-if test "x$WANTS_GTK" = "xyes"; then
18- AM_PATH_GTK_2_0(2.6.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
19- LIBS="$LIBS $GTK_LIBS -lm",
20- AC_MSG_WARN(Building without GTK2 display support)
21- AC_DEFINE(NO_GTK, 1, [Define if you don't have the GTK+ libraries available.])
22- GTK_OBJ="")
23-else
24- AC_DEFINE(NO_GTK)
25- GTK_OBJ=""
26-fi
27+AC_DEFINE(NO_GTK, 1, [Define if you don't have the GTK+ libraries available.])
28+GTK_OBJ=""
29
30 AC_CHECK_FUNC(socket, ,
31 AC_CHECK_LIB(socket, socket, , AC_MSG_ERROR(No socket library found)))
diff --git a/meta-networking/recipes-support/mtr/mtr_0.82.bb b/meta-networking/recipes-support/mtr/mtr_0.82.bb
new file mode 100644
index 000000000..c6d515214
--- /dev/null
+++ b/meta-networking/recipes-support/mtr/mtr_0.82.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Combined traceroute and ping utility"
2DESCRIPTION = "mtr combines the functionality of the 'traceroute' and 'ping' programs in a single network diagnostic tool."
3HOMEPAGE = "http://www.bitwizard.nl/mtr/"
4DEPENDS = "ncurses"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
8 file://mtr.c;startline=5;endline=16;md5=87105f8fe9675e897e074869afaafa6f"
9
10SRC_URI = "ftp://ftp.bitwizard.nl/mtr/mtr-${PV}.tar.gz \
11 file://no-gtk.patch"
12
13SRC_URI[md5sum] = "10601ea543fda3e51545c4bce195b64c"
14SRC_URI[sha256sum] = "f3b457c9623ae03565688a7ffd49d4843a5e2505ccaf3ba8d9fbd86e3ce9b6a0"
15
16inherit autotools
17
18EXTRA_OECONF = "--without-gtk"
19