diff options
-rw-r--r-- | meta-networking/recipes-daemons/atftp/atftp/0001-argz.h-fix-musl-compile-add-missing-defines.patch | 45 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/atftp/atftp/0002-tftp.h-tftpd.h-fix-musl-compile-missing-include.patch | 43 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/atftp/atftp_0.7.4.bb (renamed from meta-networking/recipes-daemons/atftp/atftp_0.7.2.bb) | 5 |
3 files changed, 1 insertions, 92 deletions
diff --git a/meta-networking/recipes-daemons/atftp/atftp/0001-argz.h-fix-musl-compile-add-missing-defines.patch b/meta-networking/recipes-daemons/atftp/atftp/0001-argz.h-fix-musl-compile-add-missing-defines.patch deleted file mode 100644 index cfa8a7325..000000000 --- a/meta-networking/recipes-daemons/atftp/atftp/0001-argz.h-fix-musl-compile-add-missing-defines.patch +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | From 543e67919f5cacf309ac88ab091331e41af4224b Mon Sep 17 00:00:00 2001 | ||
2 | From: Peter Seiderer <ps.report@gmx.net> | ||
3 | Date: Thu, 16 Apr 2015 22:41:57 +0200 | ||
4 | Subject: [PATCH] argz.h: fix musl compile (add missing defines) | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Add __THROW, __BEGIN_DECLS, __END_DECLS and __attribute_pure__ defines. | ||
9 | |||
10 | Signed-off-by: Peter Seiderer <ps.report@gmx.net> | ||
11 | Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> | ||
12 | --- | ||
13 | argz.h | 16 ++++++++++++++++ | ||
14 | 1 file changed, 16 insertions(+) | ||
15 | |||
16 | diff --git a/argz.h b/argz.h | ||
17 | index 582be55..bdf9f62 100644 | ||
18 | --- a/argz.h | ||
19 | +++ b/argz.h | ||
20 | @@ -48,6 +48,22 @@ | ||
21 | # define __const const | ||
22 | #endif | ||
23 | |||
24 | +#ifndef __THROW | ||
25 | +# define __THROW | ||
26 | +#endif | ||
27 | + | ||
28 | +#ifndef __BEGIN_DECLS | ||
29 | +# define __BEGIN_DECLS | ||
30 | +#endif | ||
31 | + | ||
32 | +#ifndef __END_DECLS | ||
33 | +# define __END_DECLS | ||
34 | +#endif | ||
35 | + | ||
36 | +#ifndef __attribute_pure__ | ||
37 | +# define __attribute_pure__ | ||
38 | +#endif | ||
39 | + | ||
40 | #ifndef __error_t_defined | ||
41 | typedef int error_t; | ||
42 | #endif | ||
43 | -- | ||
44 | 2.1.4 | ||
45 | |||
diff --git a/meta-networking/recipes-daemons/atftp/atftp/0002-tftp.h-tftpd.h-fix-musl-compile-missing-include.patch b/meta-networking/recipes-daemons/atftp/atftp/0002-tftp.h-tftpd.h-fix-musl-compile-missing-include.patch deleted file mode 100644 index 093054ce8..000000000 --- a/meta-networking/recipes-daemons/atftp/atftp/0002-tftp.h-tftpd.h-fix-musl-compile-missing-include.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From 77e399899d9d7297d23c321811b628febdf0fd92 Mon Sep 17 00:00:00 2001 | ||
2 | From: Peter Seiderer <ps.report@gmx.net> | ||
3 | Date: Thu, 16 Apr 2015 22:43:49 +0200 | ||
4 | Subject: [PATCH] tftp.h/tftpd.h: fix musl compile (missing include) | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Add sys/types.h include for u_char typedef. | ||
9 | |||
10 | Signed-off-by: Peter Seiderer <ps.report@gmx.net> | ||
11 | Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> | ||
12 | --- | ||
13 | tftp.h | 1 + | ||
14 | tftpd.h | 1 + | ||
15 | 2 files changed, 2 insertions(+) | ||
16 | |||
17 | diff --git a/tftp.h b/tftp.h | ||
18 | index 12bd6aa..32a3f63 100644 | ||
19 | --- a/tftp.h | ||
20 | +++ b/tftp.h | ||
21 | @@ -19,6 +19,7 @@ | ||
22 | |||
23 | #include <sys/time.h> | ||
24 | #include <sys/times.h> | ||
25 | +#include <sys/types.h> | ||
26 | #include "tftp_def.h" | ||
27 | #include "config.h" | ||
28 | |||
29 | diff --git a/tftpd.h b/tftpd.h | ||
30 | index 945065e..60d3a49 100644 | ||
31 | --- a/tftpd.h | ||
32 | +++ b/tftpd.h | ||
33 | @@ -20,6 +20,7 @@ | ||
34 | #include <pthread.h> | ||
35 | #include <arpa/tftp.h> | ||
36 | #include <arpa/inet.h> | ||
37 | +#include <sys/types.h> | ||
38 | #include "tftp_io.h" | ||
39 | |||
40 | /* | ||
41 | -- | ||
42 | 2.1.4 | ||
43 | |||
diff --git a/meta-networking/recipes-daemons/atftp/atftp_0.7.2.bb b/meta-networking/recipes-daemons/atftp/atftp_0.7.4.bb index ff9084dbf..936fc723f 100644 --- a/meta-networking/recipes-daemons/atftp/atftp_0.7.2.bb +++ b/meta-networking/recipes-daemons/atftp/atftp_0.7.4.bb | |||
@@ -4,15 +4,12 @@ HOMEPAGE = "http://packages.debian.org/atftp" | |||
4 | LICENSE = "GPLv2" | 4 | LICENSE = "GPLv2" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f" |
6 | 6 | ||
7 | SRCREV = "52b71f0831dcbde508bd3a961d84abb80a62480f" | 7 | SRCREV = "e56e8845f1070e89a4a6e509396b681688d03793" |
8 | 8 | ||
9 | SRC_URI = "git://git.code.sf.net/p/atftp/code \ | 9 | SRC_URI = "git://git.code.sf.net/p/atftp/code \ |
10 | file://atftpd.init \ | 10 | file://atftpd.init \ |
11 | file://atftpd.service \ | 11 | file://atftpd.service \ |
12 | " | 12 | " |
13 | SRC_URI_append_libc-musl = " file://0001-argz.h-fix-musl-compile-add-missing-defines.patch \ | ||
14 | file://0002-tftp.h-tftpd.h-fix-musl-compile-missing-include.patch \ | ||
15 | " | ||
16 | 13 | ||
17 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
18 | 15 | ||