diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb | 5 |
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest b/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest index 7110f6bc4..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest +++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO test_umsgpack.py| sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb index 8baedcb95..6cde243fe 100644 --- a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb +++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb | |||
@@ -12,7 +12,8 @@ SRC_URI += " \ | |||
12 | " | 12 | " |
13 | 13 | ||
14 | RDEPENDS:${PN}-ptest += " \ | 14 | RDEPENDS:${PN}-ptest += " \ |
15 | ${PYTHON_PN}-pytest \ | 15 | python3-pytest \ |
16 | python3-unittest-automake-output \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | do_install_ptest() { | 19 | do_install_ptest() { |
@@ -20,7 +21,7 @@ do_install_ptest() { | |||
20 | } | 21 | } |
21 | 22 | ||
22 | RDEPENDS:${PN} += " \ | 23 | RDEPENDS:${PN} += " \ |
23 | ${PYTHON_PN}-datetime \ | 24 | python3-datetime \ |
24 | " | 25 | " |
25 | 26 | ||
26 | BBCLASSEXTEND = "native nativesdk" | 27 | BBCLASSEXTEND = "native nativesdk" |