diff options
-rw-r--r-- | meta-oe/recipes-connectivity/hostapd/hostapd/hostapd-CVE-2018-14526.patch | 44 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb | 1 |
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd/hostapd-CVE-2018-14526.patch b/meta-oe/recipes-connectivity/hostapd/hostapd/hostapd-CVE-2018-14526.patch new file mode 100644 index 000000000..522fc394b --- /dev/null +++ b/meta-oe/recipes-connectivity/hostapd/hostapd/hostapd-CVE-2018-14526.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | hostapd-2.6: Fix CVE-2018-14526 | ||
2 | |||
3 | [No upstream tracking] -- https://w1.fi/security/2018-1/unauthenticated-eapol-key-decryption.txt | ||
4 | |||
5 | wpa: Ignore unauthenticated encrypted EAPOL-Key data | ||
6 | |||
7 | Ignore unauthenticated encrypted EAPOL-Key data in supplicant | ||
8 | processing. When using WPA2, these are frames that have the Encrypted | ||
9 | flag set, but not the MIC flag. | ||
10 | |||
11 | When using WPA2, EAPOL-Key frames that had the Encrypted flag set but | ||
12 | not the MIC flag, had their data field decrypted without first verifying | ||
13 | the MIC. In case the data field was encrypted using RC4 (i.e., when | ||
14 | negotiating TKIP as the pairwise cipher), this meant that | ||
15 | unauthenticated but decrypted data would then be processed. An adversary | ||
16 | could abuse this as a decryption oracle to recover sensitive information | ||
17 | in the data field of EAPOL-Key messages (e.g., the group key). | ||
18 | |||
19 | Upstream-Status: Backport [https://w1.fi/cgit/hostap/commit/src/rsn_supp/wpa.c?id=3e34cfdff6b192fe337c6fb3f487f73e96582961] | ||
20 | CVE: CVE-2018-14526 | ||
21 | Signed-off-by: Andrej Valek <andrej.valek@siemens.com> | ||
22 | |||
23 | diff --git a/src/rsn_supp/wpa.c b/src/rsn_supp/wpa.c | ||
24 | index 3c47879..6bdf923 100644 | ||
25 | --- a/src/rsn_supp/wpa.c | ||
26 | +++ b/src/rsn_supp/wpa.c | ||
27 | @@ -2016,6 +2016,17 @@ int wpa_sm_rx_eapol(struct wpa_sm *sm, const u8 *src_addr, | ||
28 | |||
29 | if ((sm->proto == WPA_PROTO_RSN || sm->proto == WPA_PROTO_OSEN) && | ||
30 | (key_info & WPA_KEY_INFO_ENCR_KEY_DATA)) { | ||
31 | + /* | ||
32 | + * Only decrypt the Key Data field if the frame's authenticity | ||
33 | + * was verified. When using AES-SIV (FILS), the MIC flag is not | ||
34 | + * set, so this check should only be performed if mic_len != 0 | ||
35 | + * which is the case in this code branch. | ||
36 | + */ | ||
37 | + if (!(key_info & WPA_KEY_INFO_MIC)) { | ||
38 | + wpa_msg(sm->ctx->msg_ctx, MSG_WARNING, | ||
39 | + "WPA: Ignore EAPOL-Key with encrypted but unauthenticated data"); | ||
40 | + goto out; | ||
41 | + } | ||
42 | if (wpa_supplicant_decrypt_key_data(sm, key, ver, key_data, | ||
43 | &key_data_len)) | ||
44 | goto out; | ||
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb index 250add875..42aae4279 100644 --- a/meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb +++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.6.bb | |||
@@ -18,6 +18,7 @@ SRC_URI = " \ | |||
18 | file://0005-Fix-PTK-rekeying-to-generate-a-new-ANonce.patch \ | 18 | file://0005-Fix-PTK-rekeying-to-generate-a-new-ANonce.patch \ |
19 | file://0006-TDLS-Reject-TPK-TK-reconfiguration.patch \ | 19 | file://0006-TDLS-Reject-TPK-TK-reconfiguration.patch \ |
20 | file://0007-FT-Do-not-allow-multiple-Reassociation-Response-fram.patch \ | 20 | file://0007-FT-Do-not-allow-multiple-Reassociation-Response-fram.patch \ |
21 | file://hostapd-CVE-2018-14526.patch \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | SRC_URI[md5sum] = "eaa56dce9bd8f1d195eb62596eab34c7" | 24 | SRC_URI[md5sum] = "eaa56dce9bd8f1d195eb62596eab34c7" |