diff options
-rw-r--r-- | meta-oe/recipes-extended/acpica/acpica_20130626.bb | 37 | ||||
-rw-r--r-- | meta-oe/recipes-extended/acpica/files/cross-compile.patch | 19 | ||||
-rw-r--r-- | meta-oe/recipes-extended/acpica/files/no-werror.patch | 36 |
3 files changed, 92 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/acpica/acpica_20130626.bb b/meta-oe/recipes-extended/acpica/acpica_20130626.bb new file mode 100644 index 000000000..65eadac0d --- /dev/null +++ b/meta-oe/recipes-extended/acpica/acpica_20130626.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ | ||
2 | OS-independent reference implementation of the Advanced Configuration and \ | ||
3 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ | ||
4 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ | ||
5 | subsystem, and a small set of tools to assist in developing and debugging \ | ||
6 | ACPI tables." | ||
7 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" | ||
8 | HOMEPAGE = "http://www.acpica.org/" | ||
9 | SECTION = "console/tools" | ||
10 | LICENSE = "BSD | GPLv2" | ||
11 | LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c6280c3aa" | ||
12 | DEPENDS="bison \ | ||
13 | flex" | ||
14 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | ||
15 | |||
16 | PR="r1" | ||
17 | |||
18 | SRC_URI="https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \ | ||
19 | file://cross-compile.patch \ | ||
20 | file://no-werror.patch" | ||
21 | |||
22 | SRC_URI[md5sum] = "b7112b3deffef8fe25aac7810cc419a9" | ||
23 | SRC_URI[sha256sum] = "888dda6227265c396a686624f971c51693c2bba84f24c634536234c8dca7b465" | ||
24 | |||
25 | S="${WORKDIR}/acpica-unix2-${PV}" | ||
26 | |||
27 | EXTRA_OEMAKE = "'OPT_CFLAGS=-Wall'" | ||
28 | |||
29 | do_install() { | ||
30 | install -D -p -m0755 generate/unix/bin*/iasl ${D}${bindir}/iasl | ||
31 | install -D -p -m0755 generate/unix/bin*/acpibin ${D}${bindir}/acpibin | ||
32 | install -D -p -m0755 generate/unix/bin*/acpiexec ${D}${bindir}/acpiexec | ||
33 | install -D -p -m0755 generate/unix/bin*/acpihelp ${D}${bindir}/acpihelp | ||
34 | install -D -p -m0755 generate/unix/bin*/acpinames ${D}${bindir}/acpinames | ||
35 | install -D -p -m0755 generate/unix/bin*/acpisrc ${D}${bindir}/acpisrc | ||
36 | install -D -p -m0755 generate/unix/bin*/acpixtract ${D}${bindir}/acpixtract | ||
37 | } | ||
diff --git a/meta-oe/recipes-extended/acpica/files/cross-compile.patch b/meta-oe/recipes-extended/acpica/files/cross-compile.patch new file mode 100644 index 000000000..f2917ca99 --- /dev/null +++ b/meta-oe/recipes-extended/acpica/files/cross-compile.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | Description: add cross compile support | ||
2 | Forwarded: not-needed | ||
3 | Author: Fathi Boudra <fathi.boudra@linaro.org> | ||
4 | |||
5 | --- | ||
6 | generate/unix/Makefile.config | 2 +- | ||
7 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
8 | |||
9 | --- a/generate/unix/Makefile.config | ||
10 | +++ b/generate/unix/Makefile.config | ||
11 | @@ -35,7 +35,7 @@ | ||
12 | .SUFFIXES : | ||
13 | PROGS = acpibin acpidump acpiexec acpihelp acpinames acpisrc acpixtract iasl | ||
14 | HOST ?= _CYGWIN | ||
15 | -CC = gcc | ||
16 | +CC ?= $(CROSS_COMPILE)gcc | ||
17 | |||
18 | # | ||
19 | # Common defines | ||
diff --git a/meta-oe/recipes-extended/acpica/files/no-werror.patch b/meta-oe/recipes-extended/acpica/files/no-werror.patch new file mode 100644 index 000000000..9f96552fd --- /dev/null +++ b/meta-oe/recipes-extended/acpica/files/no-werror.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | Description: remove -Werror flag | ||
2 | Forwarded: not-needed | ||
3 | Author: Fathi Boudra <fathi.boudra@linaro.org> | ||
4 | |||
5 | --- | ||
6 | generate/unix/iasl/Makefile | 12 ++++++------ | ||
7 | 1 file changed, 6 insertions(+), 6 deletions(-) | ||
8 | |||
9 | --- a/generate/unix/iasl/Makefile | ||
10 | +++ b/generate/unix/iasl/Makefile | ||
11 | @@ -279,19 +279,19 @@ $(OBJDIR)/prparser.y.h: $(OBJDIR)/prpars | ||
12 | # by the utilities above and they are not necessarily ANSI C, etc. | ||
13 | # | ||
14 | $(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c | ||
15 | - $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $? | ||
16 | + $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
17 | |||
18 | $(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c | ||
19 | - $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $? | ||
20 | + $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
21 | |||
22 | $(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c | ||
23 | - $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $? | ||
24 | + $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
25 | |||
26 | $(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c | ||
27 | - $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $? | ||
28 | + $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
29 | |||
30 | $(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c | ||
31 | - $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $? | ||
32 | + $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||
33 | |||
34 | $(OBJDIR)/prparserparse.o : $(OBJDIR)/prparserparse.c | ||
35 | - $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $? | ||
36 | + $(CC) -c $(CFLAGS) -Wall -o$@ $? | ||