summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-daemons/ippool/ippool_1.3.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
index 7947ffe45..90e7814a0 100644
--- a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
+++ b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
@@ -42,7 +42,7 @@ inherit systemd
42DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc" 42DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc"
43RDEPENDS:${PN} = "rpcbind" 43RDEPENDS:${PN} = "rpcbind"
44 44
45EXTRA_OEMAKE = "CC='${CC}' AS='${AS}' LD='${LD}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'" 45EXTRA_OEMAKE = "CC='${CC} ${CFLAGS}' AS='${AS}' LD='${LD} ${LDFLAGS}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'"
46EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}" 46EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}"
47# enable self tests 47# enable self tests
48EXTRA_OEMAKE += "IPPOOL_TEST=y" 48EXTRA_OEMAKE += "IPPOOL_TEST=y"
@@ -52,12 +52,7 @@ CPPFLAGS += "${SELECTED_OPTIMIZATION} -I${STAGING_INCDIR}/tirpc"
52SYSTEMD_SERVICE:${PN} = "ippool.service" 52SYSTEMD_SERVICE:${PN} = "ippool.service"
53 53
54do_compile:prepend() { 54do_compile:prepend() {
55 # fix the CFLAGS= and CPPFLAGS= in main Makefile, to have the extra CFLAGS in env
56 sed -i -e "s/^CFLAGS=/CFLAGS+=/" ${S}/Makefile
57 sed -i -e "s/^CPPFLAGS=/CPPFLAGS+=/" ${S}/Makefile
58
59 sed -i -e "s:-I/usr/include/pppd:-I=/usr/include/pppd:" ${S}/pppd/Makefile 55 sed -i -e "s:-I/usr/include/pppd:-I=/usr/include/pppd:" ${S}/pppd/Makefile
60
61} 56}
62 57
63 58