diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-jdcal/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb | 14 |
2 files changed, 16 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jdcal/run-ptest b/meta-python/recipes-devtools/python/python3-jdcal/run-ptest new file mode 100644 index 000000000..5cec71169 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-jdcal/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb index c8b5c953b..46deeae15 100644 --- a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb +++ b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb | |||
@@ -7,9 +7,21 @@ HOMEPAGE = "https://github.com/phn/jdcal" | |||
7 | LICENSE = "BSD" | 7 | LICENSE = "BSD" |
8 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46" | 8 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 ptest |
11 | 11 | ||
12 | SRC_URI[md5sum] = "e05bdb60fa80f25bc60e73e0c6b7c5dc" | 12 | SRC_URI[md5sum] = "e05bdb60fa80f25bc60e73e0c6b7c5dc" |
13 | SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8" | 13 | SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8" |
14 | 14 | ||
15 | RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell" | 15 | RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell" |
16 | |||
17 | SRC_URI += " \ | ||
18 | file://run-ptest \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS_${PN}-ptest += " \ | ||
22 | ${PYTHON_PN}-pytest \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | cp -f ${S}/test_jdcal.py ${D}${PTEST_PATH}/ | ||
27 | } | ||