diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python-pycrypto.inc | 21 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pycrypto/CVE-2013-7459.patch (renamed from meta-python/recipes-devtools/python/python-pycrypto/CVE-2013-7459.patch) | 0 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch (renamed from meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch) | 0 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb | 24 |
4 files changed, 21 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycrypto.inc b/meta-python/recipes-devtools/python/python-pycrypto.inc deleted file mode 100644 index 232cdb711..000000000 --- a/meta-python/recipes-devtools/python/python-pycrypto.inc +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | DESCRIPTION = "Cryptographic modules for Python." | ||
2 | HOMEPAGE = "http://www.pycrypto.org/" | ||
3 | LICENSE = "PSFv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d" | ||
5 | |||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pycrypto:" | ||
7 | |||
8 | DEPENDS += " gmp" | ||
9 | |||
10 | inherit pypi autotools-brokensep | ||
11 | |||
12 | SRC_URI += "file://cross-compiling.patch \ | ||
13 | file://CVE-2013-7459.patch \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda" | ||
17 | SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c" | ||
18 | |||
19 | do_compile[noexec] = "1" | ||
20 | |||
21 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-pycrypto/CVE-2013-7459.patch b/meta-python/recipes-devtools/python/python3-pycrypto/CVE-2013-7459.patch index 9006c5c35..9006c5c35 100644 --- a/meta-python/recipes-devtools/python/python-pycrypto/CVE-2013-7459.patch +++ b/meta-python/recipes-devtools/python/python3-pycrypto/CVE-2013-7459.patch | |||
diff --git a/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch index 712f3e8dd..712f3e8dd 100644 --- a/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch +++ b/meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch | |||
diff --git a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb index a20eafec4..78a1ef2ac 100644 --- a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb +++ b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb | |||
@@ -1,7 +1,23 @@ | |||
1 | inherit distutils3 | 1 | DESCRIPTION = "Cryptographic modules for Python." |
2 | require python-pycrypto.inc | 2 | HOMEPAGE = "http://www.pycrypto.org/" |
3 | LICENSE = "PSFv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d" | ||
3 | 5 | ||
4 | SRC_URI += "file://0001-Replace-time.clock-with-time.process_time.patch" | 6 | DEPENDS += " gmp" |
7 | |||
8 | export HOST_SYS | ||
9 | |||
10 | inherit pypi autotools-brokensep distutils3 | ||
11 | |||
12 | SRC_URI += "file://cross-compiling.patch \ | ||
13 | file://CVE-2013-7459.patch \ | ||
14 | file://0001-Replace-time.clock-with-time.process_time.patch \ | ||
15 | " | ||
16 | |||
17 | SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda" | ||
18 | SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c" | ||
19 | |||
20 | do_compile[noexec] = "1" | ||
5 | 21 | ||
6 | # We explicitly call distutils_do_install, since we want it to run, but | 22 | # We explicitly call distutils_do_install, since we want it to run, but |
7 | # *don't* want the autotools install to run, since this package doesn't | 23 | # *don't* want the autotools install to run, since this package doesn't |
@@ -9,3 +25,5 @@ SRC_URI += "file://0001-Replace-time.clock-with-time.process_time.patch" | |||
9 | do_install() { | 25 | do_install() { |
10 | distutils3_do_install | 26 | distutils3_do_install |
11 | } | 27 | } |
28 | |||
29 | BBCLASSEXTEND = "native nativesdk" | ||