summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb b/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
index a93ddc823..f70f774bf 100644
--- a/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
+++ b/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
@@ -16,13 +16,17 @@ SRC_URI = " \
16inherit autotools 16inherit autotools
17 17
18PACKAGECONFIG ??= "" 18PACKAGECONFIG ??= ""
19PACKAGECONFIG[testapp] = "--enable-kcapi-test,,," 19PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
20PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,," 20PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
21 21
22do_install_append() { 22do_install_append() {
23 # bindir contains testapp and apps. However it is always created, even 23 # bindir contains testapp and apps. However it is always created, even
24 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am), 24 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
25 rmdir --ignore-fail-on-non-empty ${D}${bindir} 25 rmdir --ignore-fail-on-non-empty ${D}${bindir}
26
27 # Remove the generated binary checksum files
28 rm -f ${D}${bindir}/.*.hmac
29 rm -f ${D}${libdir}/.*.hmac
26} 30}
27 31
28CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare" 32CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"