diff options
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb.inc | 1 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/mysql/mariadb/0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch | 26 |
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mariadb.inc b/meta-oe/recipes-dbs/mysql/mariadb.inc index ae6581ec7..39c9f4c9d 100644 --- a/meta-oe/recipes-dbs/mysql/mariadb.inc +++ b/meta-oe/recipes-dbs/mysql/mariadb.inc | |||
@@ -23,6 +23,7 @@ SRC_URI = "https://archive.mariadb.org/${BP}/source/${BP}.tar.gz \ | |||
23 | file://0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch \ | 23 | file://0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch \ |
24 | file://lfs64.patch \ | 24 | file://lfs64.patch \ |
25 | file://0001-Add-missing-includes-cstdint-and-cstdio.patch \ | 25 | file://0001-Add-missing-includes-cstdint-and-cstdio.patch \ |
26 | file://0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch \ | ||
26 | " | 27 | " |
27 | SRC_URI:append:libc-musl = " file://ppc-remove-glibc-dep.patch" | 28 | SRC_URI:append:libc-musl = " file://ppc-remove-glibc-dep.patch" |
28 | SRC_URI[sha256sum] = "0a00180864cd016187c986faab8010de23a117b9a75f91d6456421f894e48d20" | 29 | SRC_URI[sha256sum] = "0a00180864cd016187c986faab8010de23a117b9a75f91d6456421f894e48d20" |
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch new file mode 100644 index 000000000..416b17ba2 --- /dev/null +++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 713c21880e25108bf0703433432acca58377cc7b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 27 Sep 2024 11:55:53 -0700 | ||
4 | Subject: [PATCH] Use a lambda function as deleter prototype in unique_ptr | ||
5 | |||
6 | Fixes build with clang/libc++ 20+ | ||
7 | |||
8 | Upstream-Status: Submitted [https://jira.mariadb.org/browse/MDEV-35040] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | extra/mariabackup/backup_copy.cc | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/extra/mariabackup/backup_copy.cc b/extra/mariabackup/backup_copy.cc | ||
15 | index a328f5e0ec7..2ab04b78bce 100644 | ||
16 | --- a/extra/mariabackup/backup_copy.cc | ||
17 | +++ b/extra/mariabackup/backup_copy.cc | ||
18 | @@ -1641,7 +1641,7 @@ is_aria_log_dir_file(const datadir_node_t &node) | ||
19 | bool | ||
20 | copy_back_aria_logs(const char *dstdir) | ||
21 | { | ||
22 | - std::unique_ptr<ds_ctxt_t, void (&)(ds_ctxt_t*)> | ||
23 | + std::unique_ptr<ds_ctxt_t, std::function<void(ds_ctxt_t*)>> | ||
24 | ds_ctxt_aria_log_dir_path(ds_create(dstdir, DS_TYPE_LOCAL), ds_destroy); | ||
25 | |||
26 | datadir_node_t node; | ||