diff options
-rw-r--r-- | meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch | 33 | ||||
-rw-r--r-- | meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb | 4 |
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch new file mode 100644 index 000000000..d5238d00f --- /dev/null +++ b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | Fix build with -fno-common | ||
2 | |||
3 | Part of Patch from https://src.fedoraproject.org/rpms/xfce4-cpufreq-plugin/raw/master/f/xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch | ||
4 | |||
5 | Upstream-Status: Pending | ||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | |||
8 | --- a/panel-plugin/xfce4-cpufreq-plugin.c | ||
9 | +++ b/panel-plugin/xfce4-cpufreq-plugin.c | ||
10 | @@ -37,7 +37,8 @@ | ||
11 | #include "xfce4-cpufreq-linux.h" | ||
12 | #endif /* __linux__ */ | ||
13 | |||
14 | - | ||
15 | +CpuFreqPlugin *cpuFreq; | ||
16 | +GtkCssProvider *currentProvider; | ||
17 | |||
18 | void | ||
19 | cpufreq_label_set_font (void) | ||
20 | --- a/panel-plugin/xfce4-cpufreq-plugin.h | ||
21 | +++ b/panel-plugin/xfce4-cpufreq-plugin.h | ||
22 | @@ -93,9 +93,9 @@ typedef struct | ||
23 | gint timeoutHandle; | ||
24 | } CpuFreqPlugin; | ||
25 | |||
26 | -CpuFreqPlugin *cpuFreq; | ||
27 | +extern CpuFreqPlugin *cpuFreq; | ||
28 | |||
29 | -GtkCssProvider *currentProvider; | ||
30 | +extern GtkCssProvider *currentProvider; | ||
31 | |||
32 | G_BEGIN_DECLS | ||
33 | |||
diff --git a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb index 6addc3b65..5dce51b92 100644 --- a/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb +++ b/meta-xfce/recipes-panel-plugins/cpufreq/xfce4-cpufreq-plugin_1.2.1.bb | |||
@@ -7,4 +7,6 @@ inherit xfce-panel-plugin | |||
7 | 7 | ||
8 | SRC_URI[md5sum] = "ccd8f0f7aef51bc4caf1049986d9614f" | 8 | SRC_URI[md5sum] = "ccd8f0f7aef51bc4caf1049986d9614f" |
9 | SRC_URI[sha256sum] = "c5e044c0dc401d2066f208a3df82a588b3e51ff01425f155d0a1d0f8fce8f5b5" | 9 | SRC_URI[sha256sum] = "c5e044c0dc401d2066f208a3df82a588b3e51ff01425f155d0a1d0f8fce8f5b5" |
10 | SRC_URI += "file://0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch" | 10 | SRC_URI += "file://0001-Fix-memory-leak-and-reduce-cpu-load-slightly.patch \ |
11 | file://xfce4-cpufreq-plugin-1.2.1-gcc10-common.patch \ | ||
12 | " | ||