summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/conf/layer.conf1
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-liberation-sans-narrow/30-0-liberation-sans-narrow.conf18
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-liberation-sans-narrow_1.07.4.bb32
3 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
index a67cc1a19..898398d32 100644
--- a/meta-oe/conf/layer.conf
+++ b/meta-oe/conf/layer.conf
@@ -57,6 +57,7 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
57 ttf-hunkyfonts->fontconfig \ 57 ttf-hunkyfonts->fontconfig \
58 ttf-inconsolata->fontconfig \ 58 ttf-inconsolata->fontconfig \
59 ttf-liberation->fontconfig \ 59 ttf-liberation->fontconfig \
60 ttf-liberation-sans-narrow->fontconfig \
60 ttf-pt-sans->fontconfig \ 61 ttf-pt-sans->fontconfig \
61 ttf-mplus->fontconfig \ 62 ttf-mplus->fontconfig \
62 ttf-sazanami->fontconfig \ 63 ttf-sazanami->fontconfig \
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation-sans-narrow/30-0-liberation-sans-narrow.conf b/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation-sans-narrow/30-0-liberation-sans-narrow.conf
new file mode 100644
index 000000000..a4f4da7e3
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation-sans-narrow/30-0-liberation-sans-narrow.conf
@@ -0,0 +1,18 @@
1<?xml version="1.0" encoding="UTF-8"?>
2<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
3<fontconfig>
4 <!-- Microsoft -->
5 <alias binding="same">
6 <family>Arial Narrow</family>
7 <accept>
8 <family>Liberation Sans Narrow</family>
9 </accept>
10 </alias>
11 <alias binding="same">
12 <family>Liberation Sans Narrow</family>
13 <default>
14 <family>Arial Narrow</family>
15 </default>
16 </alias>
17</fontconfig>
18
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation-sans-narrow_1.07.4.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation-sans-narrow_1.07.4.bb
new file mode 100644
index 000000000..f36cf4b18
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-liberation-sans-narrow_1.07.4.bb
@@ -0,0 +1,32 @@
1require ttf.inc
2
3SUMMARY = "Liberation(tm) Fonts"
4DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
5created by Ascender(c) which aims at metric compatibility with \
6Arial, Times New Roman, Courier New."
7
8HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
11
12SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \
13 file://30-0-liberation-sans-narrow.conf \
14"
15
16SRC_URI[md5sum] = "134d8262145fc793c6af494dcace3e71"
17SRC_URI[sha256sum] = "61a7e2b6742a43c73e8762cdfeaf6dfcf9abdd2cfa0b099a9854d69bc4cfee5c"
18
19S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
20
21do_install_append () {
22 install -d ${D}${datadir}/fonts/TTF/
23 install -d ${D}${sysconfdir}/fonts/conf.d/
24 install -m 0644 LiberationSansNarrow*.ttf ${D}${datadir}/fonts/TTF/
25 install -D -m 0644 ${WORKDIR}/30-0-liberation-sans-narrow.conf ${D}${sysconfdir}/conf.avail/30-${PN}-sans.conf
26 install -D -m 0644 ${S}/License.txt ${D}${datadir}/licenses/${PN}/LICENSE
27}
28
29PACKAGES = "${PN}"
30FONT_PACKAGES = "${PN}"
31
32FILES_${PN} = "${datadir}/fonts ${sysconfdir} ${datadir}/licenses"