summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch32
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb11
2 files changed, 42 insertions, 1 deletions
diff --git a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
new file mode 100644
index 000000000..b616b3fad
--- /dev/null
+++ b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
@@ -0,0 +1,32 @@
1From 034ac41561409ffc7836683331b6b94a641436e4 Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Mon, 28 Feb 2022 09:41:02 -0800
4Subject: [PATCH] setup.py: switch from distutils to setuptools
5
6In Python 3.10 'distutils' is deprecated with removal slated for Python
73.12. Switch from 'distutils.core' to 'setuptools'.
8
9This also allows for a 'wheel' binary archive format to be built with
10'setup.py bdist_wheel'.
11
12Upstream-Status: Submitted
13[https://github.com/rhinstaller/python-meh/pull/37]
14
15Signed-off-by: Tim Orling <tim.orling@konsulko.com>
16
17---
18 setup.py | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/setup.py b/setup.py
22index 9c12180..3ba5195 100644
23--- a/setup.py
24+++ b/setup.py
25@@ -1,6 +1,6 @@
26 #!/usr/bin/python3
27
28-from distutils.core import setup
29+from setuptools import setup
30
31 setup(name='python-meh', version='0.50.1',
32 description='Python module for handling exceptions',
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
index bf0df021a..96dba9612 100644
--- a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
+++ b/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb
@@ -9,8 +9,17 @@ inherit setuptools3
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=rhel9-branch" 12SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=rhel9-branch \
13 file://0001-setup.py-switch-from-distutils-to-setuptools.patch \
14 "
13SRCREV = "c321ce22950aff76611a3c6beffa02b5ea3adbed" 15SRCREV = "c321ce22950aff76611a3c6beffa02b5ea3adbed"
14 16
17PIP_INSTALL_PACKAGE = "python_meh"
18
19do_install:append () {
20 install -d ${D}/${datadir}/python-meh
21 mv ${D}${PYTHON_SITEPACKAGES_DIR}${datadir}/python-meh/* ${D}/${datadir}/python-meh/
22}
23
15FILES:${PN} += "${datadir}/*" 24FILES:${PN} += "${datadir}/*"
16 25