summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb19
2 files changed, 11 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-whoosh/run-ptest b/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
index 3385d6893..8d2017d39 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index ed2a6d423..38d3e1cec 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -16,13 +16,13 @@ PYPI_PACKAGE_EXT = "zip"
16inherit ptest pypi setuptools3 16inherit ptest pypi setuptools3
17 17
18RDEPENDS:${PN} += " \ 18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-email \ 19 python3-email \
20 ${PYTHON_PN}-multiprocessing \ 20 python3-multiprocessing \
21 ${PYTHON_PN}-netclient \ 21 python3-netclient \
22 ${PYTHON_PN}-numbers \ 22 python3-numbers \
23 ${PYTHON_PN}-pickle \ 23 python3-pickle \
24 ${PYTHON_PN}-shell \ 24 python3-shell \
25 ${PYTHON_PN}-stringold \ 25 python3-stringold \
26" 26"
27 27
28SRC_URI += " \ 28SRC_URI += " \
@@ -30,8 +30,9 @@ SRC_URI += " \
30" 30"
31 31
32RDEPENDS:${PN}-ptest += " \ 32RDEPENDS:${PN}-ptest += " \
33 ${PYTHON_PN}-pytest \ 33 python3-fcntl \
34 ${PYTHON_PN}-fcntl \ 34 python3-pytest \
35 python3-unittest-automake-output \
35" 36"
36 37
37do_install_ptest() { 38do_install_ptest() {