summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb24
-rw-r--r--meta-webserver/recipes-httpd/apache-mod/mod-dnssd_0.6.bb20
3 files changed, 45 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
index a691b8d3f..fe9f1efbc 100644
--- a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
@@ -69,4 +69,4 @@ FILES:${PN} += " \
69 69
70FILES:${PN}-dev += "${datadir}/gettext" 70FILES:${PN}-dev += "${datadir}/gettext"
71 71
72RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper" 72RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'gnome-user-share', '' , d)}"
diff --git a/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb b/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
new file mode 100644
index 000000000..3ff8f938a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "This is gnome-user-share 43.0, a system for easy sharing of user files."
2LICENSE="GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
4
5
6DEPENDS = " \
7 glib-2.0-native \
8 glib-2.0 \
9 systemd \
10"
11
12inherit gnomebase gsettings features_check
13
14REQUIRED_DISTRO_FEATURES = "systemd"
15
16SRC_URI = "git://gitlab.gnome.org/GNOME/gnome-user-share.git;protocol=https;branch=master"
17SRCREV = "a0e790aa9494db9d1b1f48b4fc0d2f78e112044d"
18S = "${WORKDIR}/git"
19
20PACKAGECONFIG ??= "modules"
21PACKAGECONFIG[httpd] = "-Dhttpd=/usr/sbin/httpd,,,apache2 mod-dnssd"
22PACKAGECONFIG[modules] = "-Dmodules_path=/usr/libexec/apache2/modules"
23
24FILES:${PN} += "${systemd_user_unitdir}"
diff --git a/meta-webserver/recipes-httpd/apache-mod/mod-dnssd_0.6.bb b/meta-webserver/recipes-httpd/apache-mod/mod-dnssd_0.6.bb
new file mode 100644
index 000000000..5fac0a6ed
--- /dev/null
+++ b/meta-webserver/recipes-httpd/apache-mod/mod-dnssd_0.6.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Avahi Module for Apache2."
2HOMEPAGE = "https://0pointer.de/lennart/projects/mod_dnssd/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS = "apache2 avahi"
7
8SRC_URI = "git://git.0pointer.de/mod_dnssd;protocol=git;branch=master"
9SRCREV = "be2fb9f6158f800685de7a1bc01c39b6cf1fa12c"
10
11S = "${WORKDIR}/git"
12
13EXTRA_OECONF = "--disable-lynx"
14
15inherit autotools pkgconfig
16
17do_install() {
18 install -Dm755 ${S}/src/.libs/mod_dnssd.so ${D}${libexecdir}/apache2/modules/mod_dnssd.so
19}
20