summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/tcsh/files/07_nls.patch14
-rw-r--r--meta-oe/recipes-extended/tcsh/files/cross-compile.patch12
-rw-r--r--meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch27
-rw-r--r--meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch18
-rw-r--r--meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb (renamed from meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb)16
5 files changed, 16 insertions, 71 deletions
diff --git a/meta-oe/recipes-extended/tcsh/files/07_nls.patch b/meta-oe/recipes-extended/tcsh/files/07_nls.patch
deleted file mode 100644
index fe7845f43..000000000
--- a/meta-oe/recipes-extended/tcsh/files/07_nls.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1Author: Franz Pletz <fpletz@franz-pletz.org>
2Description: Fixes NLS build bug
3
4--- a/nls/Makefile.in
5+++ b/nls/Makefile.in
6@@ -2,7 +2,7 @@
7
8 LOCALES= C et finnish french german greek italian ja pl russian \
9 spanish ukrainian
10-GENCAT= gencat
11+GENCAT= gencat --new
12 INSTALL= ginstall
13
14 datarootdir=@datarootdir@
diff --git a/meta-oe/recipes-extended/tcsh/files/cross-compile.patch b/meta-oe/recipes-extended/tcsh/files/cross-compile.patch
deleted file mode 100644
index 06dcfdae0..000000000
--- a/meta-oe/recipes-extended/tcsh/files/cross-compile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -git a/Makefile.in b/Makefile.in
2--- a/Makefile.in
3+++ b/Makefile.in
4@@ -446,7 +446,7 @@
5
6 gethost: gethost.c sh.err.h tc.const.h sh.h
7 rm -f gethost
8- ${CC} -o gethost ${LDFLAGS} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
9+ ${BUILD_CC} -o gethost ${BUILD_LDFLAGS} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
10
11 tc.defs.c: gethost host.defs
12 @rm -f $@.tmp
diff --git a/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch b/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch
deleted file mode 100644
index 43001f117..000000000
--- a/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1Author: christos <christos>
2Date: Thu May 13 18:39:02 2010 +0000
3
4 add a rule to make catalogs and propagate ${MAKE} instead of hard-coding make.
5
6--- a/Makefile.in
7+++ b/Makefile.in
8@@ -687,7 +687,7 @@ shar:
9 rm -rf tcsh-${VERSION}
10
11 catalogs:
12- @(cd nls; make catalogs)
13+ @(cd nls; ${MAKE})
14
15 tcsh-${VERSION}.tar.Z:
16 rm -rf tcsh-${VERSION}
17--- a/nls/Makefile.in
18+++ b/nls/Makefile.in
19@@ -18,7 +18,7 @@ install: $(INSTALLED)
20 $(INSTALL) $< $@
21
22 %.cat:
23- $(GENCAT) $@ $(@:%.cat=%)/*set*
24+ cat $(@:%.cat=%)/charset $(@:%.cat=%)/set* | $(GENCAT) $@
25
26 clean:
27 $(RM) $(CATALOGS)
diff --git a/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch
index 7f3e92624..3dd420a0e 100644
--- a/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch
+++ b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch
@@ -1,16 +1,18 @@
1Author: Jean-Luc Leger <reiga@dspnet.fr.eu.org> 1Author: Jean-Luc Leger <reiga@dspnet.fr.eu.org>
2Description: fix broken globbing expansion 2Description: fix broken globbing expansion
3Debian-Bug: #603545 3Debian-Bug: #603545
4--- a/tc.str.c 4Index: tcsh-6.18.01/tc.str.c
5+++ b/tc.str.c 5===================================================================
6@@ -104,8 +104,9 @@ rt_mbtowc(Char *pwc, const char *s, size_t n) 6--- tcsh-6.18.01.orig/tc.str.c 2012-01-10 13:34:31.000000000 -0800
7 7+++ tcsh-6.18.01/tc.str.c 2013-02-26 13:12:13.429153489 -0800
8 memset (&mb, 0, sizeof mb); 8@@ -122,8 +122,9 @@
9 ret = mbrtowc(&tmp, s, n, &mb); 9 #else
10 ret = mbtowc(&tmp, s, n);
11 #endif
10- if (ret > 0) { 12- if (ret > 0) {
11+ if (ret >= 0) 13+ if (ret >= 0)
12 *pwc = tmp; 14 *pwc = tmp;
13+ if (ret > 0) { 15+ if (ret >= 0) {
14 #ifdef UTF16_STRINGS 16 #if defined(UTF16_STRINGS) && defined(HAVE_MBRTOWC)
15 if (tmp >= 0xd800 && tmp <= 0xdbff) { 17 if (tmp >= 0xd800 && tmp <= 0xdbff) {
16 /* UTF-16 surrogate pair. Fetch second half and compute 18 /* UTF-16 surrogate pair. Fetch second half and compute
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
index c4c78f478..d85fba841 100644
--- a/meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb
+++ b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
@@ -9,22 +9,23 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=1cf29be62df2be1a3763118b25b4c780"
9SECTION = "base" 9SECTION = "base"
10 10
11SRC_URI = " \ 11SRC_URI = " \
12 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_6.17.02.orig.tar.gz;name=tarball \ 12 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}.orig.tar.gz;name=tarball \
13 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_6.17.02-4.diff.gz;name=diffs \ 13 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-2.diff.gz;name=diffs \
14 file://01_build.1.patch \ 14 file://01_build.1.patch \
15 file://01_build.2.patch \ 15 file://01_build.2.patch \
16 file://01_build.3.patch \ 16 file://01_build.3.patch \
17 file://07_nls.patch \
18 file://15_no-strip.patch \ 17 file://15_no-strip.patch \
19 file://disable-test-notty.patch \ 18 file://disable-test-notty.patch \
20 file://disable-test-nice.patch \ 19 file://disable-test-nice.patch \
21 file://fix-make-catalogs.patch \
22 file://disable-lexical.at-31.patch \ 20 file://disable-lexical.at-31.patch \
23 file://12_unknown_lscolors.patch \ 21 file://12_unknown_lscolors.patch \
24 file://tcsh-6.17.02-multibyte.patch \ 22 file://tcsh-6.17.02-multibyte.patch \
25 file://disable-broken-test.patch \ 23 file://disable-broken-test.patch \
26 file://cross-compile.patch \
27" 24"
25SRC_URI[tarball.md5sum] = "6eed09dbd4223ab5b6955378450d228a"
26SRC_URI[tarball.sha256sum] = "d81ca27851f3e8545666399b4bcf25433e602a195113b3f7c73886fef84c9fa8"
27SRC_URI[diffs.md5sum] = "ea39b818b624aca49ebf2cd2708d6ff9"
28SRC_URI[diffs.sha256sum] = "95b0c1a339b745c47c5d2f9d02c22a71597462e2e882b51614a9d1f75bd3d16c"
28 29
29inherit autotools 30inherit autotools
30 31
@@ -46,8 +47,3 @@ pkg_postinst_${PN} () {
46#!/bin/sh -e 47#!/bin/sh -e
47echo /usr/bin/tcsh >> $D/etc/shells 48echo /usr/bin/tcsh >> $D/etc/shells
48} 49}
49
50SRC_URI[tarball.md5sum] = "ad6e89ddb654972b4c2a8bad06778625"
51SRC_URI[tarball.sha256sum] = "8c675729810eb49102b68e09be4f3f592dfa0be2c238f0d0a58e5c1147da7dd8"
52SRC_URI[diffs.md5sum] = "735286c36a83a043015b30871c7ab6b6"
53SRC_URI[diffs.sha256sum] = "61c0b0f7ebbc07544551f56b66c6e78def702c2197307e960898182b340ffe67"