summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb13
1 files changed, 6 insertions, 7 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 08082ffb4..8fb69bb27 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -28,18 +28,17 @@ do_configure_prepend() {
28 cd ${S} 28 cd ${S}
29 29
30 # avoid bootstrap cloning gnulib on every configure 30 # avoid bootstrap cloning gnulib on every configure
31 cat >.gitmodules <<EOF 31 # the rmdir acts as a sentinel to let us know if the pkg ever changes
32[submodule "gnulib"] 32 # the path for GNUlib or populates the dir making it non-empty.
33 path = gnulib 33 rmdir ${S}/.gnulib
34 url = git://git.sv.gnu.org/gnulib 34 cp -rf ${STAGING_DATADIR}/gnulib ${S}/.gnulib
35EOF
36 cp -rf ${STAGING_DATADIR}/gnulib ${S}
37 35
38 # --force to avoid errors on reconfigure e.g if recipes changed we depend on 36 # --force to avoid errors on reconfigure e.g if recipes changed we depend on
39 # | bootstrap: running: libtoolize --quiet 37 # | bootstrap: running: libtoolize --quiet
40 # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite 38 # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite
41 # | ... 39 # | ...
42 ./bootstrap --force 40 ./bootstrap --force --no-git --gnulib-srcdir=.gnulib
41
43 cd $currdir 42 cd $currdir
44} 43}
45 44