diff options
3 files changed, 42 insertions, 131 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch b/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch new file mode 100644 index 000000000..24940c780 --- /dev/null +++ b/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 2649787d76cfe7d89abb1b5afab7cb7cd54b601b Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Sun, 2 Oct 2011 19:54:29 +0200 | ||
4 | Subject: [PATCH] docs: fix build without xsltproc | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | |||
9 | Upstream-status: Pending | ||
10 | |||
11 | Makefile.am | 2 ++ | ||
12 | 2 files changed, 2 insertions(+), 1 deletions(-) | ||
13 | |||
14 | diff --git a/Makefile.am b/Makefile.am | ||
15 | index f4a17aa..01240a5 100644 | ||
16 | --- a/Makefile.am | ||
17 | +++ b/Makefile.am | ||
18 | @@ -750,6 +750,7 @@ EXTRA_DIST += \ | ||
19 | src/dbus-loop.h \ | ||
20 | src/spawn-agent.h | ||
21 | |||
22 | +if HAVE_XSLTPROC | ||
23 | MANPAGES = \ | ||
24 | man/systemd.1 \ | ||
25 | man/systemctl.1 \ | ||
26 | @@ -844,6 +845,7 @@ EXTRA_DIST += \ | ||
27 | $(XML_IN_FILES) \ | ||
28 | ${nodist_man_MANS:=.in} \ | ||
29 | ${XML_IN_FILES:.xml.in=.html.in} | ||
30 | +endif | ||
31 | |||
32 | systemd_SOURCES = \ | ||
33 | src/main.c | ||
34 | -- | ||
35 | 1.6.6.1 | ||
36 | |||
diff --git a/meta-oe/recipes-core/systemd/systemd/0003-analyze-draw-kernel-boot-time-as-well.patch b/meta-oe/recipes-core/systemd/systemd/0003-analyze-draw-kernel-boot-time-as-well.patch deleted file mode 100644 index ef282aab3..000000000 --- a/meta-oe/recipes-core/systemd/systemd/0003-analyze-draw-kernel-boot-time-as-well.patch +++ /dev/null | |||
@@ -1,125 +0,0 @@ | |||
1 | From 958ae0d75176a65dc6694829667a5cc9fead8cbc Mon Sep 17 00:00:00 2001 | ||
2 | From: Kay Sievers <kay.sievers@vrfy.org> | ||
3 | Date: Tue, 27 Sep 2011 12:52:09 +0200 | ||
4 | Subject: [PATCH] analyze: always draw top kernel, initramfs, userspace bars | ||
5 | |||
6 | Based on Koen Kooi's patch. Renamed initrd to initramfs. | ||
7 | --- | ||
8 | src/systemd-analyze | 41 ++++++++++++++++++++++++++++++++--------- | ||
9 | 1 files changed, 32 insertions(+), 9 deletions(-) | ||
10 | |||
11 | diff --git a/src/systemd-analyze b/src/systemd-analyze | ||
12 | index ac64040..729aa05 100755 | ||
13 | --- a/src/systemd-analyze | ||
14 | +++ b/src/systemd-analyze | ||
15 | @@ -82,7 +82,7 @@ if len(sys.argv) <= 1 or sys.argv[1] == 'time': | ||
16 | initrd_time, start_time, finish_time = acquire_start_time() | ||
17 | |||
18 | if initrd_time > 0: | ||
19 | - print "Startup finished in %lums (kernel) + %lums (initrd) + %lums (userspace) = %lums" % ( \ | ||
20 | + print "Startup finished in %lums (kernel) + %lums (initramfs) + %lums (userspace) = %lums" % ( \ | ||
21 | initrd_time/1000, \ | ||
22 | (start_time - initrd_time)/1000, \ | ||
23 | (finish_time - start_time)/1000, \ | ||
24 | @@ -116,7 +116,11 @@ elif sys.argv[1] == 'plot': | ||
25 | data = acquire_time_data() | ||
26 | s = sorted(data, key = lambda i: i[1]) | ||
27 | |||
28 | - count = 0 | ||
29 | + # Account for kernel and initramfs bars if they exist | ||
30 | + if initrd_time > 0: | ||
31 | + count = 3 | ||
32 | + else: | ||
33 | + count = 2 | ||
34 | |||
35 | for name, ixt, aet, axt, iet in s: | ||
36 | |||
37 | @@ -130,7 +134,7 @@ elif sys.argv[1] == 'plot': | ||
38 | bar_space = bar_height * 0.1 | ||
39 | |||
40 | # 1000px = 10s, 1px = 10ms | ||
41 | - width = (finish_time - start_time)/10000 + border*2 | ||
42 | + width = finish_time/10000 + border*2 | ||
43 | height = count * (bar_height + bar_space) + border * 2 | ||
44 | |||
45 | if width < 1000: | ||
46 | @@ -147,7 +151,7 @@ elif sys.argv[1] == 'plot': | ||
47 | context.set_line_width(1) | ||
48 | context.set_source_rgb(0.7, 0.7, 0.7) | ||
49 | |||
50 | - for x in range(0, max((finish_time - start_time)/10000,110), 100): | ||
51 | + for x in range(0, finish_time/10000 + 100, 100): | ||
52 | context.move_to(x, 0) | ||
53 | context.line_to(x, height-border*2) | ||
54 | |||
55 | @@ -163,11 +167,30 @@ elif sys.argv[1] == 'plot': | ||
56 | banner = "Running on %s (%s %s) %s" % (os.uname()[1], os.uname()[2], os.uname()[3], os.uname()[4]) | ||
57 | draw_text(context, 0, -15, banner, hcenter = 0, vcenter = 1) | ||
58 | |||
59 | - for x in range(0, max((finish_time - start_time)/10000,110), 100): | ||
60 | + for x in range(0, finish_time/10000 + 100, 100): | ||
61 | draw_text(context, x, -5, "%lus" % (x/100), vcenter = 0, hcenter = 0) | ||
62 | |||
63 | y = 0 | ||
64 | |||
65 | + # draw boxes for kernel and initramfs boot time | ||
66 | + if initrd_time > 0: | ||
67 | + draw_box(context, 0, y, initrd_time/10000, bar_height, 0.7, 0.7, 0.7) | ||
68 | + draw_text(context, 10, y + bar_height/2, "kernel", hcenter = 0) | ||
69 | + y += bar_height + bar_space | ||
70 | + | ||
71 | + draw_box(context, initrd_time/10000, y, start_time/10000-initrd_time/10000, bar_height, 0.7, 0.7, 0.7) | ||
72 | + draw_text(context, initrd_time/10000 + 10, y + bar_height/2, "initramfs", hcenter = 0) | ||
73 | + y += bar_height + bar_space | ||
74 | + | ||
75 | + else: | ||
76 | + draw_box(context, 0, y, start_time/10000, bar_height, 0.6, 0.6, 0.6) | ||
77 | + draw_text(context, 10, y + bar_height/2, "kernel", hcenter = 0) | ||
78 | + y += bar_height + bar_space | ||
79 | + | ||
80 | + draw_box(context, start_time/10000, y, finish_time/10000-start_time/10000, bar_height, 0.7, 0.7, 0.7) | ||
81 | + draw_text(context, start_time/10000 + 10, y + bar_height/2, "userspace", hcenter = 0) | ||
82 | + y += bar_height + bar_space | ||
83 | + | ||
84 | for name, ixt, aet, axt, iet in s: | ||
85 | |||
86 | drawn = False | ||
87 | @@ -176,7 +199,7 @@ elif sys.argv[1] == 'plot': | ||
88 | if ixt >= start_time and ixt <= finish_time: | ||
89 | |||
90 | # Activating | ||
91 | - a = ixt - start_time | ||
92 | + a = ixt | ||
93 | b = min(filter(lambda x: x >= ixt, (aet, axt, iet, finish_time))) - ixt | ||
94 | |||
95 | draw_box(context, a/10000, y, b/10000, bar_height, 1, 0, 0) | ||
96 | @@ -188,7 +211,7 @@ elif sys.argv[1] == 'plot': | ||
97 | if aet >= start_time and aet <= finish_time: | ||
98 | |||
99 | # Active | ||
100 | - a = aet - start_time | ||
101 | + a = aet | ||
102 | b = min(filter(lambda x: x >= aet, (axt, iet, finish_time))) - aet | ||
103 | |||
104 | draw_box(context, a/10000, y, b/10000, bar_height, .8, .6, .6) | ||
105 | @@ -200,7 +223,7 @@ elif sys.argv[1] == 'plot': | ||
106 | if axt >= start_time and axt <= finish_time: | ||
107 | |||
108 | # Deactivating | ||
109 | - a = axt - start_time | ||
110 | + a = axt | ||
111 | b = min(filter(lambda x: x >= axt, (iet, finish_time))) - axt | ||
112 | |||
113 | draw_box(context, a/10000, y, b/10000, bar_height, .6, .4, .4) | ||
114 | @@ -222,7 +245,7 @@ elif sys.argv[1] == 'plot': | ||
115 | draw_text(context, 0, height-border*2, "Legend: Red = Activating; Pink = Active; Dark Pink = Deactivating", hcenter = 0, vcenter = -1) | ||
116 | |||
117 | if initrd_time > 0: | ||
118 | - draw_text(context, 0, height-border*2 + bar_height, "Startup finished in %lums (kernel) + %lums (initrd) + %lums (userspace) = %lums" % ( \ | ||
119 | + draw_text(context, 0, height-border*2 + bar_height, "Startup finished in %lums (kernel) + %lums (initramfs) + %lums (userspace) = %lums" % ( \ | ||
120 | initrd_time/1000, \ | ||
121 | (start_time - initrd_time)/1000, \ | ||
122 | (finish_time - start_time)/1000, \ | ||
123 | -- | ||
124 | 1.6.6.1 | ||
125 | |||
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb index b796411ea..336fff070 100644 --- a/meta-oe/recipes-core/systemd/systemd_git.bb +++ b/meta-oe/recipes-core/systemd/systemd_git.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd" | |||
3 | LICENSE = "GPLv2+" | 3 | LICENSE = "GPLv2+" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" |
5 | 5 | ||
6 | DEPENDS = "docbook-sgml-dtd-4.1-native gperf-native acl readline udev dbus libcap libcgroup" | 6 | DEPENDS = "docbook-sgml-dtd-4.1-native gperf-native acl readline udev dbus libcap libcgroup tcp-wrappers" |
7 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | 7 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
8 | 8 | ||
9 | SERIAL_CONSOLE ?= "115200 /dev/ttyS0" | 9 | SERIAL_CONSOLE ?= "115200 /dev/ttyS0" |
@@ -14,14 +14,14 @@ inherit gitpkgv | |||
14 | PKGV = "v${GITPKGVTAG}" | 14 | PKGV = "v${GITPKGVTAG}" |
15 | 15 | ||
16 | PV = "git" | 16 | PV = "git" |
17 | PR = "r1" | 17 | PR = "r4" |
18 | 18 | ||
19 | inherit autotools vala perlnative | 19 | inherit autotools vala perlnative |
20 | 20 | ||
21 | SRCREV = "7c83341a593160e2b4739bdb8a1ad76b21bbdf9e" | 21 | SRCREV = "798e258d301ac237cb1d72b5fc4b19ee900d6f7d" |
22 | 22 | ||
23 | SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ | 23 | SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ |
24 | file://0003-analyze-draw-kernel-boot-time-as-well.patch \ | 24 | file://0001-disable-xsltproc-completely.patch \ |
25 | ${UCLIBCPATCHES} \ | 25 | ${UCLIBCPATCHES} \ |
26 | " | 26 | " |
27 | UCLIBCPATCHES = "" | 27 | UCLIBCPATCHES = "" |
@@ -43,9 +43,9 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \ | |||
43 | --disable-gtk \ | 43 | --disable-gtk \ |
44 | " | 44 | " |
45 | 45 | ||
46 | # There's no docbook-xsl-native, so for the xsltproc check to false | ||
46 | do_configure_prepend() { | 47 | do_configure_prepend() { |
47 | # avoid network access | 48 | sed -i /xsltproc/d configure.ac |
48 | sed -i -e /nonet/d Makefile.am | ||
49 | } | 49 | } |
50 | 50 | ||
51 | do_install() { | 51 | do_install() { |