summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb b/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
new file mode 100644
index 000000000..fdc13eb11
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
@@ -0,0 +1,25 @@
1# Imported from git://git.yoctoproject.org/meta-cloud-services
2
3SUMMARY = "Python library for displaying tabular data in a ASCII table format"
4HOMEPAGE = "http://code.google.com/p/prettytable"
5SECTION = "devel/python"
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
8
9SRCNAME = "prettytable"
10
11SRC_URI = "http://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip"
12
13SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899"
14SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit setuptools
19
20do_install_append() {
21 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"`
22 for f in $perm_files; do
23 chmod 644 "${f}"
24 done
25}