summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-networkx.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-networkx_2.2.bb10
-rw-r--r--meta-python/recipes-devtools/python/python3-networkx_2.3.bb8
3 files changed, 21 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-networkx.inc b/meta-python/recipes-devtools/python/python-networkx.inc
new file mode 100644
index 000000000..a4c31b2b2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-networkx.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "Python package for creating and manipulating graphs and networks"
2LICENSE = "BSD-3-Clause"
3
4inherit pypi
5
6PYPI_PACKAGE_EXT = "zip"
7
8RDEPENDS_${PN} += "\
9 ${PYTHON_PN}-decorator \
10 "
diff --git a/meta-python/recipes-devtools/python/python-networkx_2.2.bb b/meta-python/recipes-devtools/python/python-networkx_2.2.bb
index a2381661c..648f0312f 100644
--- a/meta-python/recipes-devtools/python/python-networkx_2.2.bb
+++ b/meta-python/recipes-devtools/python/python-networkx_2.2.bb
@@ -1,12 +1,8 @@
1DESCRIPTION = "Python package for creating and manipulating graphs and networks" 1require python-networkx.inc
2LICENSE = "BSD-3-Clause" 2
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde"
4 4
5SRC_URI[md5sum] = "82608a3686fb3e61f20cf13bfd3c1b4a" 5SRC_URI[md5sum] = "82608a3686fb3e61f20cf13bfd3c1b4a"
6SRC_URI[sha256sum] = "45e56f7ab6fe81652fb4bc9f44faddb0e9025f469f602df14e3b2551c2ea5c8b" 6SRC_URI[sha256sum] = "45e56f7ab6fe81652fb4bc9f44faddb0e9025f469f602df14e3b2551c2ea5c8b"
7 7
8PYPI_PACKAGE_EXT = "zip" 8inherit setuptools
9
10inherit pypi setuptools
11
12RDEPENDS_${PN} += "python-2to3"
diff --git a/meta-python/recipes-devtools/python/python3-networkx_2.3.bb b/meta-python/recipes-devtools/python/python3-networkx_2.3.bb
new file mode 100644
index 000000000..8feb6daa3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-networkx_2.3.bb
@@ -0,0 +1,8 @@
1require python-networkx.inc
2
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b68290ee1026b204170a23bbdb27a4fd"
4
5SRC_URI[md5sum] = "320d3f6c7872732baa63cedafddadea9"
6SRC_URI[sha256sum] = "8311ddef63cf5c5c5e7c1d0212dd141d9a1fe3f474915281b73597ed5f1d4e3d"
7
8inherit setuptools3