diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python-websocket-client.inc | 18 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb | 2 |
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-websocket-client.inc b/meta-python/recipes-devtools/python/python-websocket-client.inc new file mode 100644 index 000000000..c4214b2fd --- /dev/null +++ b/meta-python/recipes-devtools/python/python-websocket-client.inc | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "websocket client for python" | ||
2 | DESCRIPTION = "\ | ||
3 | websocket-client module is WebSocket client for python. \ | ||
4 | This provide the low level APIs for WebSocket. All APIs \ | ||
5 | are the synchronous functions." | ||
6 | HOMEPAGE = "https://github.com/websocket-client/websocket-client" | ||
7 | LICENSE = "BSD-3-Clause" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c4c4a98fbc4836b81c8c64d6ecb01fc1" | ||
9 | |||
10 | SRC_URI[md5sum] = "89484bd5dac71123ae6a09b2f90fe62c" | ||
11 | SRC_URI[sha256sum] = "1fd5520878b68b84b5748bb30e592b10d0a91529d5383f74f4964e72b297fd3a" | ||
12 | |||
13 | PYPI_PACKAGE = "websocket_client" | ||
14 | inherit pypi | ||
15 | |||
16 | RDEPENDS_${PN} = "\ | ||
17 | ${PYTHON_PN}-six \ | ||
18 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb b/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb new file mode 100644 index 000000000..9b6696ead --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-websocket-client_0.56.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-websocket-client.inc | ||