summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-alembic.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-alembic_0.9.6.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-alembic_0.9.6.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-alembic.inc b/meta-python/recipes-devtools/python/python-alembic.inc
new file mode 100644
index 000000000..2ca60231b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-alembic.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "A database migration tool for SQLAlchemy"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=d07407716fd24408b5747b0fa2262775"
4
5SRC_URI[md5sum] = "fcb096bccc87c8770bd07a04606cb989"
6SRC_URI[sha256sum] = "042851ebe9efa07be6dc1395b1793b6c1d8964a39b73a0ce1649e2bcd41ea732"
7
8PYPI_PACKAGE = "alembic"
9
10RDEPENDS_${PN} += "\
11 ${PYTHON_PN}-editor \
12 ${PYTHON_PN}-sqlalchemy \
13 "
diff --git a/meta-python/recipes-devtools/python/python-alembic_0.9.6.bb b/meta-python/recipes-devtools/python/python-alembic_0.9.6.bb
new file mode 100644
index 000000000..efcb2b1de
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-alembic_0.9.6.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools
2require python-alembic.inc
diff --git a/meta-python/recipes-devtools/python/python3-alembic_0.9.6.bb b/meta-python/recipes-devtools/python/python3-alembic_0.9.6.bb
new file mode 100644
index 000000000..e248fe7ce
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-alembic_0.9.6.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools3
2require python-alembic.inc