summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pymisp.inc19
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.122.bb21
2 files changed, 20 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymisp.inc b/meta-python/recipes-devtools/python/python-pymisp.inc
deleted file mode 100644
index d2485ffbd..000000000
--- a/meta-python/recipes-devtools/python/python-pymisp.inc
+++ /dev/null
@@ -1,19 +0,0 @@
1DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI[md5sum] = "ef41185d4c2753dc2c1a9ab937e3614a"
7SRC_URI[sha256sum] = "ecdc362b4bb5dd500a5f0b9e795b35ed75037de64f8dcf39c24d029e7657ad7f"
8
9RDEPENDS_${PN} += " \
10 ${PYTHON_PN}-dateutil \
11 ${PYTHON_PN}-json \
12 ${PYTHON_PN}-jsonschema \
13 ${PYTHON_PN}-requests \
14 ${PYTHON_PN}-six \
15"
16
17# Fixes: python3-pymisp requires /bin/bash, but no
18# providers found in RDEPENDS_python3-pymisp? [file-rdep
19RDEPENDS_${PN} += "bash"
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.122.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.122.bb
index 4523d9e30..bf2da0066 100644
--- a/meta-python/recipes-devtools/python/python3-pymisp_2.4.122.bb
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.122.bb
@@ -1,2 +1,21 @@
1DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI[md5sum] = "ef41185d4c2753dc2c1a9ab937e3614a"
7SRC_URI[sha256sum] = "ecdc362b4bb5dd500a5f0b9e795b35ed75037de64f8dcf39c24d029e7657ad7f"
8
1inherit pypi setuptools3 9inherit pypi setuptools3
2require python-pymisp.inc 10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-dateutil \
13 ${PYTHON_PN}-json \
14 ${PYTHON_PN}-jsonschema \
15 ${PYTHON_PN}-requests \
16 ${PYTHON_PN}-six \
17"
18
19# Fixes: python3-pymisp requires /bin/bash, but no
20# providers found in RDEPENDS_python3-pymisp? [file-rdep
21RDEPENDS_${PN} += "bash"