diff options
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark/va_list-can-t-be-NULL-on-ARM.patch | 99 | ||||
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark_1.12.0.bb (renamed from meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb) | 10 |
2 files changed, 5 insertions, 104 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark/va_list-can-t-be-NULL-on-ARM.patch b/meta-networking/recipes-support/wireshark/wireshark/va_list-can-t-be-NULL-on-ARM.patch deleted file mode 100644 index 26a004cc3..000000000 --- a/meta-networking/recipes-support/wireshark/wireshark/va_list-can-t-be-NULL-on-ARM.patch +++ /dev/null | |||
@@ -1,99 +0,0 @@ | |||
1 | From 320c4f0d705a3ed94f710fb4b7b3eef897ff7bc4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Steev Klimaszewski <threeway@gmail.com> | ||
3 | Date: Thu, 19 Jun 2014 16:54:57 -0500 | ||
4 | Subject: [PATCH] va_list can't be NULL on ARM. | ||
5 | |||
6 | Bug: 10209 | ||
7 | Change-Id: Ibd63a530450b7d2d4ec244e91c77caa731ba63aa | ||
8 | Signed-off-by: Steev Klimaszewski <threeway@gmail.com> | ||
9 | Signed-off-by: Balint Reczey <balint@balintreczey.hu> | ||
10 | Reviewed-on: https://code.wireshark.org/review/2464 | ||
11 | Reviewed-by: Evan Huus <eapache@gmail.com> | ||
12 | Reviewed-by: Michael Mann <mmann78@netscape.net> | ||
13 | |||
14 | Upstream-Status: Backport | ||
15 | The patch was imported from the wireshark git server | ||
16 | (https://code.wireshark.org/review/p/wireshark.git) as of commit id | ||
17 | 320c4f0d705a3ed94f710fb4b7b3eef897ff7bc4. | ||
18 | |||
19 | Signed-off-by: Armin Kuster <akuster@mvista.com> | ||
20 | |||
21 | --- | ||
22 | epan/expert.c | 36 +++++++++++++++++++++++++++++------- | ||
23 | 1 file changed, 29 insertions(+), 7 deletions(-) | ||
24 | |||
25 | diff --git a/epan/expert.c b/epan/expert.c | ||
26 | index 46be838..a69566d 100644 | ||
27 | --- a/epan/expert.c | ||
28 | +++ b/epan/expert.c | ||
29 | @@ -381,15 +381,26 @@ expert_set_info_vformat(packet_info *pinfo, proto_item *pi, int group, int sever | ||
30 | tap_queue_packet(expert_tap, pinfo, ei); | ||
31 | } | ||
32 | |||
33 | -void | ||
34 | -expert_add_info(packet_info *pinfo, proto_item *pi, expert_field *expindex) | ||
35 | +/* Helper function for expert_add_info() to work around compiler's special needs on ARM*/ | ||
36 | +static inline void | ||
37 | +expert_add_info_internal(packet_info *pinfo, proto_item *pi, expert_field *expindex, ...) | ||
38 | { | ||
39 | + /* the va_list is ignored */ | ||
40 | + va_list unused; | ||
41 | expert_field_info* eiinfo; | ||
42 | |||
43 | /* Look up the item */ | ||
44 | EXPERT_REGISTRAR_GET_NTH(expindex->ei, eiinfo); | ||
45 | |||
46 | - expert_set_info_vformat(pinfo, pi, eiinfo->group, eiinfo->severity, *eiinfo->hf_info.p_id, FALSE, eiinfo->summary, NULL); | ||
47 | + va_start(unused, expindex); | ||
48 | + expert_set_info_vformat(pinfo, pi, eiinfo->group, eiinfo->severity, *eiinfo->hf_info.p_id, FALSE, eiinfo->summary, unused); | ||
49 | + va_end(unused); | ||
50 | +} | ||
51 | + | ||
52 | +void | ||
53 | +expert_add_info(packet_info *pinfo, proto_item *pi, expert_field *expindex) | ||
54 | +{ | ||
55 | + expert_add_info_internal(pinfo, pi, expindex); | ||
56 | } | ||
57 | |||
58 | void | ||
59 | @@ -406,22 +417,33 @@ expert_add_info_format(packet_info *pinfo, proto_item *pi, expert_field *expinde | ||
60 | va_end(ap); | ||
61 | } | ||
62 | |||
63 | -proto_item * | ||
64 | -proto_tree_add_expert(proto_tree *tree, packet_info *pinfo, expert_field* expindex, | ||
65 | - tvbuff_t *tvb, gint start, gint length) | ||
66 | +/* Helper function for expert_add_expert() to work around compiler's special needs on ARM*/ | ||
67 | +static inline proto_item * | ||
68 | +proto_tree_add_expert_internal(proto_tree *tree, packet_info *pinfo, expert_field* expindex, | ||
69 | + tvbuff_t *tvb, gint start, gint length, ...) | ||
70 | { | ||
71 | expert_field_info* eiinfo; | ||
72 | proto_item *ti; | ||
73 | + va_list unused; | ||
74 | |||
75 | /* Look up the item */ | ||
76 | EXPERT_REGISTRAR_GET_NTH(expindex->ei, eiinfo); | ||
77 | |||
78 | ti = proto_tree_add_text(tree, tvb, start, length, "%s", eiinfo->summary); | ||
79 | - expert_set_info_vformat(pinfo, ti, eiinfo->group, eiinfo->severity, *eiinfo->hf_info.p_id, FALSE, eiinfo->summary, NULL); | ||
80 | + va_start(unused, length); | ||
81 | + expert_set_info_vformat(pinfo, ti, eiinfo->group, eiinfo->severity, *eiinfo->hf_info.p_id, FALSE, eiinfo->summary, unused); | ||
82 | + va_end(unused); | ||
83 | return ti; | ||
84 | } | ||
85 | |||
86 | proto_item * | ||
87 | +proto_tree_add_expert(proto_tree *tree, packet_info *pinfo, expert_field* expindex, | ||
88 | + tvbuff_t *tvb, gint start, gint length) | ||
89 | +{ | ||
90 | + return proto_tree_add_expert_internal(tree, pinfo, expindex, tvb, start, length); | ||
91 | +} | ||
92 | + | ||
93 | +proto_item * | ||
94 | proto_tree_add_expert_format(proto_tree *tree, packet_info *pinfo, expert_field* expindex, | ||
95 | tvbuff_t *tvb, gint start, gint length, const char *format, ...) | ||
96 | { | ||
97 | -- | ||
98 | 1.9.1 | ||
99 | |||
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.0.bb index b965fdf32..449ac47e5 100644 --- a/meta-networking/recipes-support/wireshark/wireshark_1.12.0-rc2.bb +++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.0.bb | |||
@@ -26,12 +26,12 @@ PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt" | |||
26 | EXTRA_OECONF = "--with-qt=no --enable-usr-local=no -enable-tshark" | 26 | EXTRA_OECONF = "--with-qt=no --enable-usr-local=no -enable-tshark" |
27 | 27 | ||
28 | LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0" | 28 | LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0" |
29 | SRC_URI = "http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-1.12.0-rc2.tar.bz2 \ | 29 | SRC_URI = " \ |
30 | file://va_list-can-t-be-NULL-on-ARM.patch \ | 30 | http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-1.12.0.tar.bz2 \ |
31 | " | 31 | " |
32 | 32 | ||
33 | SRC_URI[md5sum] = "dc1149073066a29f91116c168558262e" | 33 | SRC_URI[md5sum] = "8dcfe451d8769901129809d2e19c1fb7" |
34 | SRC_URI[sha256sum]= "31009bb450126e9b12808267419f31016d14e6fde7b5e39c85ad37459908cffb" | 34 | SRC_URI[sha256sum]= "0f59fea1c5b35de90af681067e49113fee0dd7a901750a97fa25f4256dbf13c7" |
35 | 35 | ||
36 | do_configure_prepend() { | 36 | do_configure_prepend() { |
37 | # force to use fallback | 37 | # force to use fallback |