diff options
-rw-r--r-- | meta-multimedia/recipes-multimedia/openh264/openh264/0001-Makefile-Do-not-poke-at-host-gcc-for-target-options.patch | 25 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/openh264/openh264/0001-codec-Disable-asm-for-mips.patch | 70 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/openh264/openh264_2.1.0.bb (renamed from meta-multimedia/recipes-multimedia/openh264/openh264_2.0.0.bb) | 7 |
3 files changed, 3 insertions, 99 deletions
diff --git a/meta-multimedia/recipes-multimedia/openh264/openh264/0001-Makefile-Do-not-poke-at-host-gcc-for-target-options.patch b/meta-multimedia/recipes-multimedia/openh264/openh264/0001-Makefile-Do-not-poke-at-host-gcc-for-target-options.patch deleted file mode 100644 index 5f590596d..000000000 --- a/meta-multimedia/recipes-multimedia/openh264/openh264/0001-Makefile-Do-not-poke-at-host-gcc-for-target-options.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From af9bd9201c755e0b01251021f4e7642d3fec9c1c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 4 Mar 2020 08:38:46 -0800 | ||
4 | Subject: [PATCH] Makefile: Do not poke at host gcc for target options | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | build/arch.mk | 1 - | ||
9 | 1 file changed, 1 deletion(-) | ||
10 | |||
11 | diff --git a/build/arch.mk b/build/arch.mk | ||
12 | index 8ac3e70a..b80cee8c 100644 | ||
13 | --- a/build/arch.mk | ||
14 | +++ b/build/arch.mk | ||
15 | @@ -35,7 +35,6 @@ ifneq ($(filter mips mips64, $(ARCH)),) | ||
16 | ifeq ($(USE_ASM), Yes) | ||
17 | ASM_ARCH = mips | ||
18 | ASMFLAGS += -I$(SRC_PATH)codec/common/mips/ | ||
19 | -LOONGSON3A = $(shell g++ -dM -E - < /dev/null | grep '_MIPS_TUNE ' | cut -f 3 -d " ") | ||
20 | ifeq ($(LOONGSON3A), "loongson3a") | ||
21 | CFLAGS += -DHAVE_MMI | ||
22 | endif | ||
23 | -- | ||
24 | 2.25.1 | ||
25 | |||
diff --git a/meta-multimedia/recipes-multimedia/openh264/openh264/0001-codec-Disable-asm-for-mips.patch b/meta-multimedia/recipes-multimedia/openh264/openh264/0001-codec-Disable-asm-for-mips.patch deleted file mode 100644 index 60ea69dbc..000000000 --- a/meta-multimedia/recipes-multimedia/openh264/openh264/0001-codec-Disable-asm-for-mips.patch +++ /dev/null | |||
@@ -1,70 +0,0 @@ | |||
1 | From edb62d2518d87536290d00a11c78c311e3680914 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 4 Mar 2020 09:14:57 -0800 | ||
4 | Subject: [PATCH] codec: Disable asm for mips | ||
5 | |||
6 | It needs loongson support which qemumips is not targettin | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | codec/common/targets.mk | 2 +- | ||
11 | codec/decoder/targets.mk | 2 +- | ||
12 | codec/encoder/targets.mk | 2 +- | ||
13 | codec/processing/targets.mk | 2 +- | ||
14 | 4 files changed, 4 insertions(+), 4 deletions(-) | ||
15 | |||
16 | diff --git a/codec/common/targets.mk b/codec/common/targets.mk | ||
17 | index 96843cd9..e76cb2cb 100644 | ||
18 | --- a/codec/common/targets.mk | ||
19 | +++ b/codec/common/targets.mk | ||
20 | @@ -74,7 +74,7 @@ COMMON_ASM_MIPS_SRCS=\ | ||
21 | $(COMMON_SRCDIR)/mips/satd_sad_mmi.c\ | ||
22 | |||
23 | COMMON_OBJSMIPS += $(COMMON_ASM_MIPS_SRCS:.c=.$(OBJ)) | ||
24 | -ifeq ($(ASM_ARCH), mips) | ||
25 | +ifeq ($(ASM_ARCH), mips64) | ||
26 | COMMON_OBJS += $(COMMON_OBJSMIPS) | ||
27 | endif | ||
28 | OBJS += $(COMMON_OBJSMIPS) | ||
29 | diff --git a/codec/decoder/targets.mk b/codec/decoder/targets.mk | ||
30 | index eaf5d3c0..615d9216 100644 | ||
31 | --- a/codec/decoder/targets.mk | ||
32 | +++ b/codec/decoder/targets.mk | ||
33 | @@ -60,7 +60,7 @@ DECODER_ASM_MIPS_SRCS=\ | ||
34 | $(DECODER_SRCDIR)/core/mips/dct_mmi.c\ | ||
35 | |||
36 | DECODER_OBJSMIPS += $(DECODER_ASM_MIPS_SRCS:.c=.$(OBJ)) | ||
37 | -ifeq ($(ASM_ARCH), mips) | ||
38 | +ifeq ($(ASM_ARCH), mips64) | ||
39 | DECODER_OBJS += $(DECODER_OBJSMIPS) | ||
40 | endif | ||
41 | OBJS += $(DECODER_OBJSMIPS) | ||
42 | diff --git a/codec/encoder/targets.mk b/codec/encoder/targets.mk | ||
43 | index 1f053280..fd49c1fd 100644 | ||
44 | --- a/codec/encoder/targets.mk | ||
45 | +++ b/codec/encoder/targets.mk | ||
46 | @@ -88,7 +88,7 @@ ENCODER_ASM_MIPS_SRCS=\ | ||
47 | $(ENCODER_SRCDIR)/core/mips/score_mmi.c\ | ||
48 | |||
49 | ENCODER_OBJSMIPS += $(ENCODER_ASM_MIPS_SRCS:.c=.$(OBJ)) | ||
50 | -ifeq ($(ASM_ARCH), mips) | ||
51 | +ifeq ($(ASM_ARCH), mips64) | ||
52 | ENCODER_OBJS += $(ENCODER_OBJSMIPS) | ||
53 | endif | ||
54 | OBJS += $(ENCODER_OBJSMIPS) | ||
55 | diff --git a/codec/processing/targets.mk b/codec/processing/targets.mk | ||
56 | index 300de2d8..8451d66e 100644 | ||
57 | --- a/codec/processing/targets.mk | ||
58 | +++ b/codec/processing/targets.mk | ||
59 | @@ -62,7 +62,7 @@ PROCESSING_ASM_MIPS_SRCS=\ | ||
60 | $(PROCESSING_SRCDIR)/src/mips/vaa_mmi.c\ | ||
61 | |||
62 | PROCESSING_OBJSMIPS += $(PROCESSING_ASM_MIPS_SRCS:.c=.$(OBJ)) | ||
63 | -ifeq ($(ASM_ARCH), mips) | ||
64 | +ifeq ($(ASM_ARCH), mips64) | ||
65 | PROCESSING_OBJS += $(PROCESSING_OBJSMIPS) | ||
66 | endif | ||
67 | OBJS += $(PROCESSING_OBJSMIPS) | ||
68 | -- | ||
69 | 2.25.1 | ||
70 | |||
diff --git a/meta-multimedia/recipes-multimedia/openh264/openh264_2.0.0.bb b/meta-multimedia/recipes-multimedia/openh264/openh264_2.1.0.bb index 31b9da269..3c65ef247 100644 --- a/meta-multimedia/recipes-multimedia/openh264/openh264_2.0.0.bb +++ b/meta-multimedia/recipes-multimedia/openh264/openh264_2.1.0.bb | |||
@@ -11,12 +11,10 @@ LICENSE_FLAGS = "commercial" | |||
11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bb6d3771da6a07d33fd50d4d9aa73bcf" | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bb6d3771da6a07d33fd50d4d9aa73bcf" |
12 | 12 | ||
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | SRCREV = "71374015cdf13f7aab4bc2d820f77905b3becfb8" | 14 | SRCREV = "a60e28efe227ea8ea760b1e29a8943e371ebe4b3" |
15 | BRANCH = "openh264v2.0.0" | 15 | BRANCH = "openh264v2.1.0" |
16 | SRC_URI = "git://github.com/cisco/openh264.git;protocol=https;branch=${BRANCH} \ | 16 | SRC_URI = "git://github.com/cisco/openh264.git;protocol=https;branch=${BRANCH} \ |
17 | file://0001-Makefile-Use-cp-options-to-preserve-file-mode.patch \ | 17 | file://0001-Makefile-Use-cp-options-to-preserve-file-mode.patch \ |
18 | file://0001-Makefile-Do-not-poke-at-host-gcc-for-target-options.patch \ | ||
19 | file://0001-codec-Disable-asm-for-mips.patch \ | ||
20 | " | 18 | " |
21 | 19 | ||
22 | COMPATIBLE_MACHINE_armv7a = "(.*)" | 20 | COMPATIBLE_MACHINE_armv7a = "(.*)" |
@@ -33,6 +31,7 @@ EXTRA_OEMAKE_x86 = "ARCH=i386" | |||
33 | EXTRA_OEMAKE_x86-64 = "ARCH=x86_64" | 31 | EXTRA_OEMAKE_x86-64 = "ARCH=x86_64" |
34 | EXTRA_OEMAKE_mips = "ARCH=mips" | 32 | EXTRA_OEMAKE_mips = "ARCH=mips" |
35 | EXTRA_OEMAKE_mips64 = "ARCH=mips64" | 33 | EXTRA_OEMAKE_mips64 = "ARCH=mips64" |
34 | EXTRA_OEMAKE_riscv64 = "ARCH=riscv64" | ||
36 | 35 | ||
37 | EXTRA_OEMAKE_append = " ENABLEPIC=Yes" | 36 | EXTRA_OEMAKE_append = " ENABLEPIC=Yes" |
38 | do_configure() { | 37 | do_configure() { |