diff options
-rw-r--r-- | meta-oe/recipes-test/stress-ng/stress-ng/0003-stress-fcntl.c-fix-syntax-errors.patch | 47 | ||||
-rw-r--r-- | meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb (renamed from meta-oe/recipes-test/stress-ng/stress-ng_0.09.09.bb) | 9 |
2 files changed, 4 insertions, 52 deletions
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng/0003-stress-fcntl.c-fix-syntax-errors.patch b/meta-oe/recipes-test/stress-ng/stress-ng/0003-stress-fcntl.c-fix-syntax-errors.patch deleted file mode 100644 index 4b6a9b391..000000000 --- a/meta-oe/recipes-test/stress-ng/stress-ng/0003-stress-fcntl.c-fix-syntax-errors.patch +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | From 8537dcafb12be4d986b571f1e1d9f3ceecdc8e63 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <timothy.t.orling@linux.intel.com> | ||
3 | Date: Sun, 7 Jan 2018 21:29:12 -0800 | ||
4 | Subject: [PATCH] stress-fcntl.c: fix syntax errors | ||
5 | |||
6 | Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> | ||
7 | |||
8 | Upstream-status: Accepted | ||
9 | (commit 61d93d6857256cd49df6a6302caf6e7bb69b0f46) | ||
10 | --- | ||
11 | stress-fcntl.c | 6 +++--- | ||
12 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
13 | |||
14 | diff --git a/stress-fcntl.c b/stress-fcntl.c | ||
15 | index 7c15d28..b7eade2 100644 | ||
16 | --- a/stress-fcntl.c | ||
17 | +++ b/stress-fcntl.c | ||
18 | @@ -173,7 +173,7 @@ static int do_fcntl(const args_t *args, const int fd) | ||
19 | owner.pid = getpgrp(); | ||
20 | ret = fcntl(fd, F_SETOWN_EX, &owner); | ||
21 | check_return(args, ret, "F_SETOWN_EX, F_OWNER_PGRP"); | ||
22 | -#else if defined(HAVE_GETPGRP) && defined(F_OWNER_GID) | ||
23 | +#elif defined(HAVE_GETPGRP) && defined(F_OWNER_GID) | ||
24 | owner.type = F_OWNER_GID; | ||
25 | owner.pid = getpgrp(); | ||
26 | ret = fcntl(fd, F_SETOWN_EX, &owner); | ||
27 | @@ -202,7 +202,7 @@ static int do_fcntl(const args_t *args, const int fd) | ||
28 | owner.type = F_OWNER_PGRP; | ||
29 | ret = fcntl(fd, F_GETOWN_EX, &owner); | ||
30 | check_return(args, ret, "F_GETOWN_EX, F_OWNER_PGRP"); | ||
31 | -#ele if defined(F_OWNER_GID) | ||
32 | +#elif defined(F_OWNER_GID) | ||
33 | owner.type = F_OWNER_GID; | ||
34 | ret = fcntl(fd, F_GETOWN_EX, &owner); | ||
35 | check_return(args, ret, "F_GETOWN_EX, F_OWNER_GID"); | ||
36 | @@ -436,7 +436,7 @@ ofd_lock_abort: { /* Nowt */ } | ||
37 | #endif | ||
38 | }; | ||
39 | |||
40 | - ret = fcntl(fd, F_GET_FILE_RW_HINT, &hint) | ||
41 | + ret = fcntl(fd, F_GET_FILE_RW_HINT, &hint); | ||
42 | if (ret == 0) { | ||
43 | for (i = 0; i < SIZEOF_ARRAY(hints); i++) { | ||
44 | hint = hints[i]; | ||
45 | -- | ||
46 | 2.14.3 | ||
47 | |||
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.09.bb b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb index 24f55ada2..7fab43025 100644 --- a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.09.bb +++ b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.14.bb | |||
@@ -6,14 +6,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
6 | DEPENDS = "zlib libaio" | 6 | DEPENDS = "zlib libaio" |
7 | 7 | ||
8 | SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \ | 8 | SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \ |
9 | file://0002-stress-fcntl-fix-build-for-musl.patch \ | ||
9 | " | 10 | " |
10 | SRC_URI_append_libc-musl = " \ | 11 | SRC_URI_append_libc-musl = " \ |
11 | file://0001-Several-changes-to-fix-musl-build.patch \ | 12 | file://0001-Several-changes-to-fix-musl-build.patch \ |
12 | file://0002-stress-fcntl-fix-build-for-musl.patch \ | 13 | " |
13 | file://0003-stress-fcntl.c-fix-syntax-errors.patch" | 14 | SRC_URI[md5sum] = "1f8b6c2c2830704d2a2814c16082d48e" |
14 | 15 | SRC_URI[sha256sum] = "02cac34a5cb041197af60c1867844c6cbb089a6d10a38cdcf7b8f27bfaa6ef8f" | |
15 | SRC_URI[md5sum] = "6e4df71095e780654ccc0a713b8423fe" | ||
16 | SRC_URI[sha256sum] = "e993fddb1d990a0cdb23b2af6cf6c417a1c09e155ada7c558ad80eae8a5feed3" | ||
17 | 16 | ||
18 | UPSTREAM_CHECK_URI ?= "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/" | 17 | UPSTREAM_CHECK_URI ?= "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/" |
19 | UPSTREAM_CHECK_REGEX ?= "(?P<pver>\d+(\.\d+)+)\.tar" | 18 | UPSTREAM_CHECK_REGEX ?= "(?P<pver>\d+(\.\d+)+)\.tar" |