summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/eject/eject_2.1.5.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/eject/eject_2.1.5.bb b/meta-oe/recipes-support/eject/eject_2.1.5.bb
index c47c65344..95345776b 100644
--- a/meta-oe/recipes-support/eject/eject_2.1.5.bb
+++ b/meta-oe/recipes-support/eject/eject_2.1.5.bb
@@ -16,6 +16,14 @@ S = "${WORKDIR}/${BPN}"
16 16
17PR = "r1" 17PR = "r1"
18 18
19do_compile_prepend() {
20 # PO subdir must be in build directory
21 if [ ! ${S} = ${B} ]; then
22 mkdir -p ${B}/po
23 cp -r ${S}/po/* ${B}/po/
24 fi
25}
26
19ALTERNATIVE_${PN} = "volname eject" 27ALTERNATIVE_${PN} = "volname eject"
20ALTERNATIVE_LINK_NAME[volname] = "${bindir}/volname" 28ALTERNATIVE_LINK_NAME[volname] = "${bindir}/volname"
21ALTERNATIVE_LINK_NAME[eject] = "${bindir}/eject" 29ALTERNATIVE_LINK_NAME[eject] = "${bindir}/eject"