summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
index a953ebc28..4571b447f 100644
--- a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
+++ b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
@@ -4,13 +4,15 @@ LIC_FILES_CHKSUM = "file://dbus-daemon-proxy.c;endline=19;md5=41df6d21fe1c97d6a1
4DEPENDS = "dbus dbus-glib" 4DEPENDS = "dbus dbus-glib"
5SRCREV = "1226a0a1374628ff191f6d8a56000be5e53e7608" 5SRCREV = "1226a0a1374628ff191f6d8a56000be5e53e7608"
6PV = "0.0.0+gitr${SRCPV}" 6PV = "0.0.0+gitr${SRCPV}"
7PR = "r1" 7PR = "r1.59"
8 8
9ASNEEDED_pn-dbus-daemon-proxy = "" 9ASNEEDED_pn-dbus-daemon-proxy = ""
10 10
11SRC_URI = "git://git.collabora.co.uk/git/user/alban/dbus-daemon-proxy" 11SRC_URI = "git://git.collabora.co.uk/git/user/alban/dbus-daemon-proxy"
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14inherit pkgconfig
15
14do_compile() { 16do_compile() {
15 ${CC} ${LDFLAGS} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c 17 ${CC} ${LDFLAGS} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c
16} 18}
@@ -19,6 +21,3 @@ do_install() {
19 install -d ${D}${bindir} 21 install -d ${D}${bindir}
20 install -m 0755 dbus-daemon-proxy ${D}${bindir} 22 install -m 0755 dbus-daemon-proxy ${D}${bindir}
21} 23}
22
23
24PNBLACKLIST[dbus-daemon-proxy] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130613/ - the recipe will be removed on 2017-09-01 unless the issue is fixed"