summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/smem/smem_1.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/smem/smem_1.4.bb b/meta-oe/recipes-support/smem/smem_1.4.bb
new file mode 100644
index 0000000000..8d195d472b
--- /dev/null
+++ b/meta-oe/recipes-support/smem/smem_1.4.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Report application memory usage in a meaningful way"
2DESCRIPTION = "smem is a tool that can give numerous reports on memory usage on Linux \
3systems. Unlike existing tools, smem can report proportional set size (PSS), \
4which is a more meaningful representation of the amount of memory used by \
5libraries and applications in a virtual memory system."
6HOMEPAGE = "http://www.selenic.com/smem/"
7SECTION = "Applications/System"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "http://www.selenic.com/smem/download/${PN}-${PV}.tar.gz"
13SRC_URI[md5sum] = "fe79435c3930389bfdb560255c802162"
14SRC_URI[sha256sum] = "2ea9f878f4cf3c276774c3f7e2a41977a1f2d64f98d2dcb6a15f1f3d84df61ec"
15
16do_compile() {
17 ${CC} ${CFLAGS} ${LDFLAGS} smemcap.c -o smemcap
18}
19
20do_install() {
21 install -d ${D}/${bindir}/
22 install -d ${D}/${mandir}/man8
23 install -m 0755 ${S}/smem ${D}${bindir}/
24 install -m 0755 ${S}/smemcap ${D}${bindir}/
25 install -m 0644 ${S}/smem.8 ${D}/${mandir}/man8/
26}