diff options
-rw-r--r-- | meta-xfce/recipes-xfce/exo/exo/gnome-mount | 64 | ||||
-rw-r--r-- | meta-xfce/recipes-xfce/exo/exo_0.10.2.bb | 9 |
2 files changed, 1 insertions, 72 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo/gnome-mount b/meta-xfce/recipes-xfce/exo/exo/gnome-mount deleted file mode 100644 index 85fdb25e8d..0000000000 --- a/meta-xfce/recipes-xfce/exo/exo/gnome-mount +++ /dev/null | |||
@@ -1,64 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | # | ||
3 | # gnome-mount - wrapper script for use with exo-mount | ||
4 | # | ||
5 | # Copyright 2009 Enrico Tröger <enrico(at)xfce(dot)org> | ||
6 | # Licence: GPLv2 | ||
7 | # | ||
8 | # | ||
9 | # This script aims to be a wrapper script to provide the | ||
10 | # gnome-mount utility on envrionments which only have | ||
11 | # exo-mount (e.g. Xfce). It accepts all command line arguments | ||
12 | # which are passed but ignores all which are not supported by | ||
13 | # exo-mount. | ||
14 | # | ||
15 | # (This script was tested with Bash and Dash.) | ||
16 | # | ||
17 | # Possible use case is as a drop-in replacement to get mounting | ||
18 | # local resources with GVfs working, e.g. mounting disks in CD drives. | ||
19 | # | ||
20 | # Usage: | ||
21 | # Save this script as 'gnome-mount' in a directory in your path, | ||
22 | # e.g. /usr/local/bin or ~/bin and make it executable. | ||
23 | # | ||
24 | |||
25 | |||
26 | |||
27 | OPTS="" | ||
28 | |||
29 | # first catch all passed arguments and keep those exo-mount supports, | ||
30 | # ignore all other arguments | ||
31 | while [ -n "$*" ] | ||
32 | do | ||
33 | case $1 in | ||
34 | -\?|--help) | ||
35 | OPTS="$OPTS --help" | ||
36 | ;; | ||
37 | -e|--eject) | ||
38 | OPTS="$OPTS --eject" | ||
39 | ;; | ||
40 | -u|--unmount) | ||
41 | OPTS="$OPTS --unmount" | ||
42 | ;; | ||
43 | -h|--hal-udi) | ||
44 | OPTS="$OPTS --hal-udi" | ||
45 | shift | ||
46 | OPTS="$OPTS $1" | ||
47 | ;; | ||
48 | -d|--device) | ||
49 | OPTS="$OPTS --device" | ||
50 | shift | ||
51 | OPTS="$OPTS $1" | ||
52 | ;; | ||
53 | -n|--no-ui) | ||
54 | OPTS="$OPTS --no-ui" | ||
55 | ;; | ||
56 | -V|--version) | ||
57 | OPTS="$OPTS --version" | ||
58 | ;; | ||
59 | esac | ||
60 | shift | ||
61 | done | ||
62 | |||
63 | # now run exo-mount and hope things go well | ||
64 | exo-mount $OPTS | ||
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb index ff529dbbe1..5e6b5acdb1 100644 --- a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb +++ b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb | |||
@@ -4,7 +4,7 @@ LICENSE = "GPLv2" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
5 | DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo" | 5 | DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo" |
6 | DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native" | 6 | DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native" |
7 | PR = "r3" | 7 | PR = "r4" |
8 | 8 | ||
9 | inherit xfce pythonnative perlnative | 9 | inherit xfce pythonnative perlnative |
10 | 10 | ||
@@ -12,7 +12,6 @@ inherit xfce pythonnative perlnative | |||
12 | SRC_URI += " \ | 12 | SRC_URI += " \ |
13 | file://exo-no-tests-0.8.patch \ | 13 | file://exo-no-tests-0.8.patch \ |
14 | file://configure.patch \ | 14 | file://configure.patch \ |
15 | file://gnome-mount \ | ||
16 | " | 15 | " |
17 | 16 | ||
18 | SRC_URI_append_class-native = " \ | 17 | SRC_URI_append_class-native = " \ |
@@ -22,12 +21,6 @@ SRC_URI_append_class-native = " \ | |||
22 | SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748" | 21 | SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748" |
23 | SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce" | 22 | SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce" |
24 | 23 | ||
25 | # see http://wiki.xfce.org/gnomemount-replacement | ||
26 | do_install_append () { | ||
27 | install -m 755 -d ${D}${bindir}/exo-mount-wrapper | ||
28 | install -m 755 ${WORKDIR}//gnome-mount ${D}${bindir}/exo-mount-wrapper | ||
29 | } | ||
30 | |||
31 | PACKAGES =+ "exo-csource" | 24 | PACKAGES =+ "exo-csource" |
32 | 25 | ||
33 | # Note: python bindings did not work in oe-dev and are about to be moved to | 26 | # Note: python bindings did not work in oe-dev and are about to be moved to |