summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service (renamed from meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service)0
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb16
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend18
3 files changed, 13 insertions, 21 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
index a2d703185..a2d703185 100644
--- a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.service
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
index 84d6dce32..422ebdab4 100644
--- a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
@@ -5,16 +5,18 @@ SECTION = "network"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7 7
8PR = "r6" 8PR = "r9"
9 9
10DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 10DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
11 11
12SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \ 12SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \
13 file://cherokee.init" 13 file://cherokee.init \
14 file://cherokee.service \
15"
14SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb" 16SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
15SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d" 17SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
16 18
17inherit autotools pkgconfig binconfig update-rc.d 19inherit autotools pkgconfig binconfig update-rc.d systemd
18 20
19EXTRA_OECONF = "--disable-static \ 21EXTRA_OECONF = "--disable-static \
20 --disable-nls \ 22 --disable-nls \
@@ -27,6 +29,9 @@ do_install_append () {
27 29
28 # clean up .la files for plugins 30 # clean up .la files for plugins
29 rm -f ${D}${libdir}/cherokee/*.la 31 rm -f ${D}${libdir}/cherokee/*.la
32
33 install -d ${D}${systemd_unitdir}/system
34 install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
30} 35}
31 36
32# Put -dev near the front so we can move the .la files into it with a wildcard 37# Put -dev near the front so we can move the .la files into it with a wildcard
@@ -44,3 +49,8 @@ CONFFILES_${PN} = " \
44 49
45INITSCRIPT_NAME = "cherokee" 50INITSCRIPT_NAME = "cherokee"
46INITSCRIPT_PARAMS = "defaults 91 91" 51INITSCRIPT_PARAMS = "defaults 91 91"
52
53RPROVIDES_${PN} += "${PN}-systemd"
54RREPLACES_${PN} += "${PN}-systemd"
55RCONFLICTS_${PN} += "${PN}-systemd"
56SYSTEMD_SERVICE_${PN} = "cherokee.service"
diff --git a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend b/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend
deleted file mode 100644
index b792c621b..000000000
--- a/meta-systemd/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 2}"
4
5inherit systemd
6
7SRC_URI += "file://cherokee.service"
8
9RPROVIDES_${PN} += "${PN}-systemd"
10RREPLACES_${PN} += "${PN}-systemd"
11RCONFLICTS_${PN} += "${PN}-systemd"
12SYSTEMD_SERVICE_${PN} = "cherokee.service"
13
14do_install_append() {
15 install -d ${D}${systemd_unitdir}/system
16 install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
17}
18