summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-multimedia/x264/x264_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/x264/x264_git.bb b/meta-oe/recipes-multimedia/x264/x264_git.bb
new file mode 100644
index 000000000..7d7579f42
--- /dev/null
+++ b/meta-oe/recipes-multimedia/x264/x264_git.bb
@@ -0,0 +1,42 @@
1SUMMARY = "x264 is a free software library and application for encoding video streams into the H.264/MPEG-4 AVC format"
2HOMEPAGE = "http://www.videolan.org/developers/x264.html"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7DEPENDS = "yasm-native"
8
9SRC_URI = "git://git.videolan.org/x264.git"
10SRCREV = "1cffe9f406cc54f4759fc9eeb85598fb8cae66c7"
11
12PV = "r2230+git"
13
14S = "${WORKDIR}/git"
15
16inherit lib_package pkgconfig
17
18X264_DISABLE_ASM = ""
19X264_DISABLE_ASM_armv4 = "--disable-asm"
20X264_DISABLE_ASM_armv5 = "--disable-asm"
21
22EXTRA_OECONF = '--prefix=${prefix} \
23 --host=${HOST_SYS} \
24 --cross-prefix=${TARGET_PREFIX} \
25 --sysroot=${STAGING_DIR_TARGET} \
26 --enable-shared \
27 --enable-static \
28 --disable-lavf \
29 ${X264_DISABLE_ASM} \
30 '
31
32do_configure() {
33 ./configure ${EXTRA_OECONF}
34}
35
36# Get rid of -e
37EXTRA_OEMAKE = ""
38AS = "${TARGET_PREFIX}gcc"
39
40do_install() {
41 oe_runmake install DESTDIR=${D}
42}