summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer/gst-rtsp/0001-change-deprecated-INCLUDES-to-AM_CPPFLAGS-for-automa.patch34
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer/gst-rtsp_0.10.8.bb16
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer/gst-rtsp/0001-change-deprecated-INCLUDES-to-AM_CPPFLAGS-for-automa.patch b/meta-multimedia/recipes-multimedia/gstreamer/gst-rtsp/0001-change-deprecated-INCLUDES-to-AM_CPPFLAGS-for-automa.patch
new file mode 100644
index 000000000..3afca4ec9
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer/gst-rtsp/0001-change-deprecated-INCLUDES-to-AM_CPPFLAGS-for-automa.patch
@@ -0,0 +1,34 @@
1index gst-rtsp_0.10.8/bindings/python/Makefile.am
2--- gst-rtsp_0.10.8.orig/bindings/python/Makefile.am
3+++ gst-rtsp_0.10.8/bindings/python/Makefile.am
4@@ -14,7 +14,7 @@ defs_DATA = $(DEFS)
5 defsdir = $(pkgdatadir)/$(GST_MAJORMINOR)/defs
6 OVERRIDES = rtspserver.override
7
8-INCLUDES = -I$(top_srcdir) -I$(srcdir) $(PYTHON_INCLUDES)
9+AM_CPPFLAGS = -I$(top_srcdir) -I$(srcdir) $(PYTHON_INCLUDES)
10
11 rtspserver_la_CFLAGS = -I$(top_srcdir)/src \
12 $(PYGOBJECT_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
13index gst-rtsp_0.10.8/examples/Makefile.am
14--- gst-rtsp_0.10.8.orig/examples/Makefile.am
15+++ gst-rtsp_0.10.8/examples/Makefile.am
16@@ -1,6 +1,6 @@
17 noinst_PROGRAMS = test-video test-ogg test-mp4 test-readme test-launch test-sdp test-uri test-auth
18
19-INCLUDES = -I$(top_srcdir) -I$(srcdir)
20+AM_CPPFLAGS = -I$(top_srcdir) -I$(srcdir)
21
22 AM_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
23 AM_LDFLAGS = \
24index gst-rtsp_0.10.8/tests/Makefile.am
25--- gst-rtsp_0.10.8.orig/tests/Makefile.am
26+++ gst-rtsp_0.10.8/tests/Makefile.am
27@@ -1,6 +1,6 @@
28 noinst_PROGRAMS = test-cleanup
29
30-INCLUDES = -I$(top_srcdir) -I$(srcdir)
31+AM_CPPFLAGS = -I$(top_srcdir) -I$(srcdir)
32
33 AM_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
34 AM_LDFLAGS = \
diff --git a/meta-multimedia/recipes-multimedia/gstreamer/gst-rtsp_0.10.8.bb b/meta-multimedia/recipes-multimedia/gstreamer/gst-rtsp_0.10.8.bb
new file mode 100644
index 000000000..40872f5e3
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer/gst-rtsp_0.10.8.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "GStreamer RTSP server"
2LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
4
5SRC_URI = "http://gstreamer.freedesktop.org/src/${BPN}/${BPN}-${PV}.tar.bz2 \
6 file://0001-change-deprecated-INCLUDES-to-AM_CPPFLAGS-for-automa.patch"
7SRC_URI[md5sum] = "b511af07000595f63c3a705946221643"
8SRC_URI[sha256sum] = "9915887cf8515bda87462c69738646afb715b597613edc7340477ccab63a6617"
9
10DEPENDS = "gst-plugins-base gstreamer"
11
12# Configure always checks for Python so inherit pythonnative. Better solution
13# would be to disable the checks entirely.
14inherit autotools pythonnative gettext
15
16FILES_${PN}-dev += "${datadir}/vala/vapi/"