diff options
-rw-r--r-- | meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc47x.diff | 48 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb | 3 |
2 files changed, 50 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc47x.diff b/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc47x.diff new file mode 100644 index 000000000..11b726004 --- /dev/null +++ b/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc47x.diff | |||
@@ -0,0 +1,48 @@ | |||
1 | ../../../src/frontend/common/TemplateBuilder.hh:50:113: warning: 'linkerAssoc' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive] | ||
2 | ../../../src/frontend/common/TemplateBuilder.hh:50:113: note: declarations in dependent base 'custom_reader_Builder' are not found by unqualified lookup | ||
3 | ../../../src/frontend/common/TemplateBuilder.hh:50:113: note: use 'this->linkerAssoc' instead | ||
4 | ../../../src/frontend/common/TemplateBuilder.hh:54:111: error: redeclaration of 'SmartPtr<BoxMLDecorElement> elem' | ||
5 | ../../../src/frontend/common/TemplateBuilder.hh:50:49: error: 'SmartPtr<BoxMLDecorElement> elem' previously declared here | ||
6 | ../../../src/frontend/common/TemplateBuilder.hh:55:2: warning: 'linkerAdd' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive] | ||
7 | ../../../src/frontend/common/TemplateBuilder.hh:55:2: note: declarations in dependent base 'custom_reader_Builder' are not found by unqualified lookup | ||
8 | ../../../src/frontend/common/TemplateBuilder.hh:55:2: note: use 'this->linkerAdd' instead | ||
9 | |||
10 | --- gtkmathview-0.8.0.orig/src/frontend/common/TemplateBuilder.hh 2007-08-17 12:02:34.000000000 +0200 | ||
11 | +++ gtkmathview-0.8.0/src/frontend/common/TemplateBuilder.hh 2012-04-30 11:45:07.000000000 +0200 | ||
12 | @@ -47,12 +47,13 @@ | ||
13 | SmartPtr<typename ElementBuilder::type> | ||
14 | getElement(const typename Model::Element& el) const | ||
15 | { | ||
16 | - if (SmartPtr<typename ElementBuilder::type> elem = smart_cast<typename ElementBuilder::type>(linkerAssoc(el))) | ||
17 | + SmartPtr<typename ElementBuilder::type> elem = NULL; | ||
18 | + if (elem = smart_cast<typename ElementBuilder::type>(this->linkerAssoc(el))) | ||
19 | return elem; | ||
20 | else | ||
21 | { | ||
22 | - SmartPtr<typename ElementBuilder::type> elem = ElementBuilder::type::create(ElementBuilder::getContext(*this)); | ||
23 | - linkerAdd(el, elem); | ||
24 | + elem = ElementBuilder::type::create(ElementBuilder::getContext(*this)); | ||
25 | + this->linkerAdd(el, elem); | ||
26 | return elem; | ||
27 | } | ||
28 | } | ||
29 | --- gtkmathview-0.8.0.orig/mathmlsvg/main.cc 2012-04-30 11:35:19.000000000 +0200 | ||
30 | +++ gtkmathview-0.8.0/mathmlsvg/main.cc 2012-04-30 11:51:19.000000000 +0200 | ||
31 | @@ -20,6 +20,7 @@ | ||
32 | |||
33 | #include <cassert> | ||
34 | #include <fstream> | ||
35 | +#include <unistd.h> | ||
36 | #include <string.h> | ||
37 | #include <popt.h> | ||
38 | |||
39 | --- gtkmathview-0.8.0.orig/mathmlps/main.cc 2012-04-30 11:35:19.000000000 +0200 | ||
40 | +++ gtkmathview-0.8.0/mathmlps/main.cc 2012-04-30 11:50:57.000000000 +0200 | ||
41 | @@ -20,6 +20,7 @@ | ||
42 | |||
43 | #include <cassert> | ||
44 | #include <fstream> | ||
45 | +#include <unistd.h> | ||
46 | #include <string.h> | ||
47 | #include <popt.h> | ||
48 | |||
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb index c8e611a48..67cb32584 100644 --- a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb +++ b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb | |||
@@ -4,10 +4,11 @@ DEPENDS = "t1lib gtk+ popt libxslt libxml2" | |||
4 | LICENSE = "LGPLv3" | 4 | LICENSE = "LGPLv3" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6" |
6 | 6 | ||
7 | PR = "r1" | 7 | PR = "r2" |
8 | 8 | ||
9 | SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \ | 9 | SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \ |
10 | file://mathview-gcc43x.diff \ | 10 | file://mathview-gcc43x.diff \ |
11 | file://mathview-gcc47x.diff \ | ||
11 | " | 12 | " |
12 | SRC_URI[md5sum] = "b53564e553728d4b69f7d366dfeb5299" | 13 | SRC_URI[md5sum] = "b53564e553728d4b69f7d366dfeb5299" |
13 | SRC_URI[sha256sum] = "1dc30175da6a3c560a7d62d1abe1c2f9829d988e6f1a7c5e766544575c558c43" | 14 | SRC_URI[sha256sum] = "1dc30175da6a3c560a7d62d1abe1c2f9829d988e6f1a7c5e766544575c558c43" |