summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch39
-rw-r--r--meta-oe/recipes-navigation/geos/geos.inc22
-rw-r--r--meta-oe/recipes-navigation/geos/geos_3.3.2.bb7
-rw-r--r--meta-oe/recipes-navigation/geos/geos_3.4.2.bb6
4 files changed, 56 insertions, 18 deletions
diff --git a/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch b/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch
new file mode 100644
index 000000000..645e6f62a
--- /dev/null
+++ b/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch
@@ -0,0 +1,39 @@
1From 9d51027c228dafd7db2d0cffca1f0fc695e950fd Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Mon, 2 Dec 2013 11:33:26 -0200
4Subject: [PATCH] geos-config: Add includedir variable
5
6This fixes cross-compile as it is easier to mangle the includedir
7during sysroot generation.
8
9Upstream-Status: Pending
10
11Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
12---
13 tools/geos-config.in | 3 ++-
14 1 file changed, 2 insertions(+), 1 deletion(-)
15
16diff --git a/tools/geos-config.in b/tools/geos-config.in
17index 9b45b5f..1749892 100644
18--- a/tools/geos-config.in
19+++ b/tools/geos-config.in
20@@ -1,6 +1,7 @@
21 #!/bin/sh
22 prefix=@prefix@
23 exec_prefix=@exec_prefix@
24+includedir=@includedir@
25 libdir=@libdir@
26
27 usage()
28@@ -38,7 +39,7 @@ case $1 in
29 echo @VERSION@
30 ;;
31 --cflags)
32- echo -I${prefix}/include
33+ echo -I${includedir}
34 ;;
35 --libs)
36 # TODO: make an alias for --clibs
37--
381.7.10.4
39
diff --git a/meta-oe/recipes-navigation/geos/geos.inc b/meta-oe/recipes-navigation/geos/geos.inc
index e0c82bc97..2e308b488 100644
--- a/meta-oe/recipes-navigation/geos/geos.inc
+++ b/meta-oe/recipes-navigation/geos/geos.inc
@@ -2,20 +2,20 @@ DESCRIPTION = "GEOS - Geometry Engine, Open Source"
2HOMEPAGE = "http://trac.osgeo.org/geos/" 2HOMEPAGE = "http://trac.osgeo.org/geos/"
3SECTION = "libs" 3SECTION = "libs"
4 4
5INC_PR = "r1"
6
7LICENSE = "LGPLv2.1+" 5LICENSE = "LGPLv2.1+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" 6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
9 7
10SRC_URI = "http://download.osgeo.org/geos/geos-${PV}.tar.bz2" 8SRC_URI = "http://download.osgeo.org/geos/geos-${PV}.tar.bz2"
11 9
12inherit autotools pkgconfig 10inherit autotools pkgconfig binconfig
11
12PACKAGES =+ "geoslib ${PN}-c1"
13
14DESCRIPTION_${PN}lib = "Geometry engine for Geographic Information Systems - C++ Library"
15FILES_${PN}lib += "${libdir}/libgeos-${PV}.so"
16
17DESCRIPTION_${PN}-c1 = "Geometry engine for Geographic Information Systems - C Library"
18FILES_${PN}-c1 += "${libdir}/libgeos_c.so.*"
13 19
14# libgeos-${PV}.so is needed in PV 20ALLOW_EMPTY_${PN} = "1"
15FILES_SOLIBSDEV = "" 21RDEPENDS_${PN} += "geoslib ${PN}-c1"
16FILES_${PN}-dev = "${libdir}/*.la \
17 ${libdir}/libgeos.so \
18 ${libdir}/libgeos_c.so \
19 ${includedir}"
20FILES_${PN} += " ${libdir}/libgeos-${PV}.so"
21INSANE_SKIP_${PN} = "dev-so"
diff --git a/meta-oe/recipes-navigation/geos/geos_3.3.2.bb b/meta-oe/recipes-navigation/geos/geos_3.3.2.bb
deleted file mode 100644
index e57ca6bcb..000000000
--- a/meta-oe/recipes-navigation/geos/geos_3.3.2.bb
+++ /dev/null
@@ -1,7 +0,0 @@
1require geos.inc
2
3PR = "${INC_PR}.0"
4
5SRC_URI[md5sum] = "5b7270c73fd1c516f368af8fd1962323"
6SRC_URI[sha256sum] = "ec64d3a92540a1618aa3b91dc1235caae1c370ec23afd59a2734062bf182ed5b"
7
diff --git a/meta-oe/recipes-navigation/geos/geos_3.4.2.bb b/meta-oe/recipes-navigation/geos/geos_3.4.2.bb
new file mode 100644
index 000000000..3a9a028e8
--- /dev/null
+++ b/meta-oe/recipes-navigation/geos/geos_3.4.2.bb
@@ -0,0 +1,6 @@
1require geos.inc
2
3SRC_URI += "file://geos-config-Add-includedir-variable.patch"
4
5SRC_URI[md5sum] = "fc5df2d926eb7e67f988a43a92683bae"
6SRC_URI[sha256sum] = "15e8bfdf7e29087a957b56ac543ea9a80321481cef4d4f63a7b268953ad26c53"