summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools/racoonctl-build-fix.patch49
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools/with-flexdir.patch14
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb2
-rw-r--r--meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb2
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog/enable_tls_ptests.patch28
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb1
-rw-r--r--meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb2
-rw-r--r--meta-oe/recipes-support/numactl/numactl_2.0.9.bb2
8 files changed, 33 insertions, 67 deletions
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools/racoonctl-build-fix.patch b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/racoonctl-build-fix.patch
deleted file mode 100644
index f77fa8638..000000000
--- a/meta-networking/recipes-support/ipsec-tools/ipsec-tools/racoonctl-build-fix.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1Subject: [PATCH] ipsec-tools: racoonctl buildfix
2
3Upstream-Status: Pending
4
5building ipsec-tools failed building/linking racoonctl with some errors:
6 - missing "yylex" error
7 - some linking errors for variables defined in racoon but not racoonctl
8 - some symbols from nattraversal.c where not found as it wasn't linked
9 when building with NAT support.
10
11Signed-off-by: Liviu Gheorghisan <liviu.gheorghisan@enea.com>
12Signed-off-by: Daniel BORNAZ <daniel.bornaz@enea.com>
13---
14diff -rupN a/src/racoon/Makefile.am b/src/racoon/Makefile.am
15--- a/src/racoon/Makefile.am 2014-03-05 12:16:52.907101044 +0100
16+++ b/src/racoon/Makefile.am 2014-03-05 12:17:10.946320064 +0100
17@@ -44,7 +44,17 @@ racoon_DEPENDENCIES = \
18 $(CRYPTOBJS) $(HYBRID_OBJS) $(NATT_OBJS) $(FRAG_OBJS) $(SECCTX_OBJS) \
19 vmbuf.o sockmisc.o misc.o
20
21-racoonctl_SOURCES = racoonctl.c str2val.c
22+racoonctl_SOURCES = \
23+ session.c isakmp.c handler.c \
24+ isakmp_ident.c isakmp_agg.c isakmp_base.c \
25+ isakmp_quick.c isakmp_inf.c isakmp_newg.c \
26+ gssapi.c dnssec.c getcertsbyname.c privsep.c \
27+ pfkey.c admin.c evt.c ipsec_doi.c oakley.c grabmyaddr.c vendorid.c \
28+ policy.c localconf.c remoteconf.c crypto_openssl.c algorithm.c \
29+ proposal.c sainfo.c strnames.c nattraversal.c \
30+ plog.c logger.c schedule.c str2val.c \
31+ safefile.c backupsa.c genlist.c rsalist.c \
32+ cftoken.l cfparse.y prsa_tok.l prsa_par.y racoonctl.c
33 racoonctl_LDADD = libracoon.la ../libipsec/libipsec.la
34
35 libracoon_la_SOURCES = kmpstat.c vmbuf.c sockmisc.c misc.c
36
37diff -rupN a/src/racoon/racoonctl.c b/src/racoon/racoonctl.c
38--- a/src/racoon/racoonctl.c 2014-03-05 12:16:52.915100698 +0100
39+++ b/src/racoon/racoonctl.c 2014-03-05 12:17:17.906018754 +0100
40@@ -247,6 +247,9 @@ usage()
41 #error "Incompatible racoonctl interface"
42 #endif
43
44+int f_local = 0; /* local test mode. behave like a wall. */
45+int dump_config =0;
46+
47 int
48 main(ac, av)
49 int ac;
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools/with-flexdir.patch b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/with-flexdir.patch
deleted file mode 100644
index da1169218..000000000
--- a/meta-networking/recipes-support/ipsec-tools/ipsec-tools/with-flexdir.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1--- ipsec-tools-0.8.1.old/configure.ac 2014-03-04 16:24:57.431207664 +0100
2+++ ipsec-tools-0.8.1/configure.ac 2014-03-04 16:26:00.372461304 +0100
3@@ -171,9 +171,9 @@ if test $with_readline != "no"; then
4 fi
5
6
7-AC_MSG_CHECKING(if --with-flex option is specified)
8+AC_MSG_CHECKING(if --with-flexdir option is specified)
9 AC_ARG_WITH(flexdir,
10- [AC_HELP_STRING([--with-flex], [use directiory (default: no)])],
11+ [AC_HELP_STRING([--with-flexdir], [use directory (default: no)])],
12 [flexdir="$withval"])
13 AC_MSG_RESULT(${flexdir-dirdefault})
14
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb
index 0969af930..c526820aa 100644
--- a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb
+++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb
@@ -10,8 +10,6 @@ DEPENDS = "virtual/kernel openssl readline flex-native bison-native"
10SRC_URI = "ftp://ftp.netbsd.org/pub/NetBSD/misc/ipsec-tools/0.8/ipsec-tools-${PV}.tar.bz2 \ 10SRC_URI = "ftp://ftp.netbsd.org/pub/NetBSD/misc/ipsec-tools/0.8/ipsec-tools-${PV}.tar.bz2 \
11 file://0002-Don-t-link-against-libfl.patch \ 11 file://0002-Don-t-link-against-libfl.patch \
12 file://configure.patch \ 12 file://configure.patch \
13 file://racoonctl-build-fix.patch \
14 file://with-flexdir.patch \
15 file://0001-racoon-pfkey-avoid-potential-null-pointer-dereferenc.patch \ 13 file://0001-racoon-pfkey-avoid-potential-null-pointer-dereferenc.patch \
16 file://racoon-check-invalid-pointers.patch \ 14 file://racoon-check-invalid-pointers.patch \
17 file://racoon-check-invalid-ivm.patch \ 15 file://racoon-check-invalid-ivm.patch \
diff --git a/meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb b/meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb
index c6bedea09..ab15a7e7f 100644
--- a/meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb
+++ b/meta-oe/recipes-devtools/tclap/tclap_1.2.1.bb
@@ -11,4 +11,6 @@ SRC_URI = "git://git.code.sf.net/p/tclap/code \
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12inherit autotools 12inherit autotools
13 13
14ALLOW_EMPTY_${PN} = "1"
15
14BBCLASSEXTEND = "native nativesdk" 16BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog/enable_tls_ptests.patch b/meta-oe/recipes-extended/rsyslog/rsyslog/enable_tls_ptests.patch
new file mode 100644
index 000000000..32de32b57
--- /dev/null
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog/enable_tls_ptests.patch
@@ -0,0 +1,28 @@
1Enable tls ptest
2
3Signed-off-by: Tudor Florea <tudor.florea@enea.com>
4Upstream-Status: Pending
5
6--- rsyslog-7.4.4/tests/Makefile.am.orig 2013-08-30 18:30:41.000000000 +0200
7+++ rsyslog-7.4.4/tests/Makefile.am 2015-10-01 09:38:45.176289031 +0200
8@@ -118,15 +118,13 @@
9 endif
10
11 if ENABLE_GNUTLS
12-# TODO: re-enable in newer version
13-#TESTS += \
14- #sndrcv_tls_anon.sh \
15- #sndrcv_tls_anon_rebind.sh \
16- #imtcp-tls-basic.sh
17+TESTS += \
18+ imtcp-tls-basic.sh \
19+ imtcp_conndrop_tls.sh \
20+ manytcp-too-few-tls.sh
21 if HAVE_VALGRIND
22 TESTS += imtcp-tls-basic-vg.sh \
23- imtcp_conndrop_tls-vg.sh
24- manytcp-too-few-tls-vg.sh
25+ imtcp_conndrop_tls-vg.sh
26 endif
27 endif
28
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb
index db7900cf5..6f96c7bf2 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_7.4.4.bb
@@ -25,6 +25,7 @@ SRC_URI = "http://www.rsyslog.com/files/download/rsyslog/${BPN}-${PV}.tar.gz \
25 file://run-ptest \ 25 file://run-ptest \
26 file://rsyslog-fix-ptest-not-finish.patch \ 26 file://rsyslog-fix-ptest-not-finish.patch \
27 file://rsyslog-use-serial-tests-config-needed-by-ptest.patch \ 27 file://rsyslog-use-serial-tests-config-needed-by-ptest.patch \
28 file://enable_tls_ptests.patch \
28" 29"
29 30
30SRC_URI[md5sum] = "ebcc010a6205c28eb505c0fe862f32c6" 31SRC_URI[md5sum] = "ebcc010a6205c28eb505c0fe862f32c6"
diff --git a/meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb b/meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb
index 343971f1a..45781b433 100644
--- a/meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb
+++ b/meta-oe/recipes-support/lm_sensors/lmsensors-config_1.0.bb
@@ -45,7 +45,7 @@ PACKAGES =+ "${PN}-fancontrol"
45# sensord web cgi support 45# sensord web cgi support
46PACKAGES =+ "${PN}-cgi" 46PACKAGES =+ "${PN}-cgi"
47RRECOMMENDS_${PN}-cgi = "lighttpd lighttpd-module-cgi" 47RRECOMMENDS_${PN}-cgi = "lighttpd lighttpd-module-cgi"
48RDEPENDS_${PN}-cgi = "${PN}-sensord" 48RDEPENDS_${PN}-cgi = "${PN}-sensord rrdtool"
49FILES_${PN}-cgi = "/www/*" 49FILES_${PN}-cgi = "/www/*"
50 50
51# libsensors configuration file 51# libsensors configuration file
diff --git a/meta-oe/recipes-support/numactl/numactl_2.0.9.bb b/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
index 651277dab..69c695d68 100644
--- a/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
+++ b/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
@@ -18,7 +18,7 @@ SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
18 file://Makefile \ 18 file://Makefile \
19 file://run-ptest \ 19 file://run-ptest \
20 " 20 "
21 21RDEPENDS_${PN}-ptest = "bash"
22# ARM does not currently support NUMA 22# ARM does not currently support NUMA
23COMPATIBLE_HOST = "^((?!arm).*)$" 23COMPATIBLE_HOST = "^((?!arm).*)$"
24 24