summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/gcc/foo191
1 files changed, 0 insertions, 191 deletions
diff --git a/recipes-devtools/gcc/foo b/recipes-devtools/gcc/foo
deleted file mode 100644
index 3fe24131e..000000000
--- a/recipes-devtools/gcc/foo
+++ /dev/null
@@ -1,191 +0,0 @@
1From f13cb20ed19c41b9ff85ef1c9ec0883a21d1d5bf Mon Sep 17 00:00:00 2001
2From: Kevin Tian <kevin.tian@intel.com>
3Date: Thu, 30 Dec 2010 04:36:50 +0000
4Subject: gcc-4.5.1: make c++ include path relative to "--sysroot"
5
6So far c++ include path is not relative to "--sysroot", which brings
7trouble if we want to use the toolchain in a new environment where
8the original build directory generating that toolchain is not
9available. It's firstly exposed in multiple SDK sysroots support, and
10then in the case when sstate packages are used, where c++ standard
11headers are missing because gcc tries to search original build dir.
12
13This patch makes c++ include path now relative to "--sysroot", and
14then once "--sysroot" is assigned correctly in new environment, c++
15include paths can be searched as expected.
16
17Signed-off-by: Kevin Tian <kevin.tian@intel.com>
18---
19diff --git a/meta/recipes-devtools/gcc/gcc-4.5.1.inc b/meta/recipes-devtools/gcc/gcc-4.5.1.inc
20index 3edc4d4..1786d8a 100644
21--- a/meta/recipes-devtools/gcc/gcc-4.5.1.inc
22+++ b/meta/recipes-devtools/gcc/gcc-4.5.1.inc
23@@ -54,6 +54,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
24 file://optional_libstdc.patch \
25 file://disable_relax_pic_calls_flag.patch \
26 file://gcc-poison-parameters.patch \
27+ file://GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch \
28 "
29
30 SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
31diff --git a/meta/recipes-devtools/gcc/gcc-4.5.1/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch b/meta/recipes-devtools/gcc/gcc-4.5.1/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch
32new file mode 100644
33index 0000000..9ae01c3
34--- a/dev/null
35+++ b/meta/recipes-devtools/gcc/gcc-4.5.1/GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch
36@@ -0,0 +1,33 @@
37+# by default c++ include directories are not relative to "--sysroot"
38+# which brings one trouble when using the toolchain in an environment
39+# where the build directory generating that toolchain doesn't exist,
40+# e.g. in sstate, machine specific sysroot and relocatable SDK
41+# toolchain. This patch now enables c++ include paths under sysroot.
42+# This way it's enough as long as "--sysroot" is correctly enabled
43+# in the new environment.
44+#
45+# Signed-off-by Kevin Tian <kevin.tian@intel.com>, 2010-12-30
46+
47+diff --git a/gcc/cppdefault.c b/gcc/cppdefault.c
48+index 5024f48..9b47d1c 100644
49+--- a/gcc/cppdefault.c
50++++ b/gcc/cppdefault.c
51+@@ -48,15 +48,15 @@ const struct default_include cpp_include_defaults[]
52+ = {
53+ #ifdef GPLUSPLUS_INCLUDE_DIR
54+ /* Pick up GNU C++ generic include files. */
55+- { GPLUSPLUS_INCLUDE_DIR, "G++", 1, 1, 0, 0 },
56++ { GPLUSPLUS_INCLUDE_DIR, "G++", 1, 1, 1, 0 },
57+ #endif
58+ #ifdef GPLUSPLUS_TOOL_INCLUDE_DIR
59+ /* Pick up GNU C++ target-dependent include files. */
60+- { GPLUSPLUS_TOOL_INCLUDE_DIR, "G++", 1, 1, 0, 1 },
61++ { GPLUSPLUS_TOOL_INCLUDE_DIR, "G++", 1, 1, 1, 1 },
62+ #endif
63+ #ifdef GPLUSPLUS_BACKWARD_INCLUDE_DIR
64+ /* Pick up GNU C++ backward and deprecated include files. */
65+- { GPLUSPLUS_BACKWARD_INCLUDE_DIR, "G++", 1, 1, 0, 0 },
66++ { GPLUSPLUS_BACKWARD_INCLUDE_DIR, "G++", 1, 1, 1, 0 },
67+ #endif
68+ #ifdef LOCAL_INCLUDE_DIR
69+ /* /usr/local/include comes before the fixincluded header files. */
70diff --git a/meta/recipes-devtools/gcc/gcc-configure-cross.inc b/meta/recipes-devtools/gcc/gcc-configure-cross.inc
71index 3da92e2..04a8685 100644
72--- a/meta/recipes-devtools/gcc/gcc-configure-cross.inc
73+++ b/meta/recipes-devtools/gcc/gcc-configure-cross.inc
74@@ -5,7 +5,7 @@ USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
75 EXTRA_OECONF += " --enable-poison-system-directories "
76
77 EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${target_exec_prefix} \
78- --with-gxx-include-dir=${STAGING_DIR_TARGET}/${target_includedir}/c++ \
79+ --with-gxx-include-dir=${target_includedir}/c++ \
80 --with-sysroot=${STAGING_DIR_TARGET} \
81 --with-build-sysroot=${STAGING_DIR_TARGET}"
82
83diff --git a/meta/recipes-devtools/gcc/gcc-configure-sdk.inc b/meta/recipes-devtools/gcc/gcc-configure-sdk.inc
84index 0eb33ad..756e74e 100644
85--- a/meta/recipes-devtools/gcc/gcc-configure-sdk.inc
86+++ b/meta/recipes-devtools/gcc/gcc-configure-sdk.inc
87@@ -5,7 +5,7 @@ USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
88 USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}'
89
90 EXTRA_OECONF_PATHS = "--with-local-prefix=${SDKPATH}/sysroots/${TARGET_SYS}${target_exec_prefix} \
91- --with-gxx-include-dir=${SDKPATH}/sysroots/${TARGET_SYS}${target_includedir}/c++ \
92+ --with-gxx-include-dir=${target_includedir}/c++ \
93 --with-build-time-tools=${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin \
94 --with-sysroot=${SDKPATH}/sysroots/${TARGET_SYS} \
95 --with-build-sysroot=${STAGING_DIR_TARGET}"
96diff --git a/meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb
97index 98e239d..37c64fb 100644
98--- a/meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb
99+++ b/meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb
100@@ -5,7 +5,7 @@ require gcc-cross-canadian.inc
101 require gcc-configure-sdk.inc
102 require gcc-package-sdk.inc
103
104-PR = "r1"
105+PR = "r2"
106
107 DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
108 RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
109diff --git a/meta/recipes-devtools/gcc/gcc-cross-initial_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-cross-initial_4.5.1.bb
110index e3aea8b..a121782 100644
111--- a/meta/recipes-devtools/gcc/gcc-cross-initial_4.5.1.bb
112+++ b/meta/recipes-devtools/gcc/gcc-cross-initial_4.5.1.bb
113@@ -1,5 +1,5 @@
114 require gcc-cross_${PV}.bb
115 require gcc-cross-initial.inc
116
117-PR = "r0"
118+PR = "r1"
119
120diff --git a/meta/recipes-devtools/gcc/gcc-cross-intermediate_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-cross-intermediate_4.5.1.bb
121index 4cabe0e..7aaa5b0 100644
122--- a/meta/recipes-devtools/gcc/gcc-cross-intermediate_4.5.1.bb
123+++ b/meta/recipes-devtools/gcc/gcc-cross-intermediate_4.5.1.bb
124@@ -1,4 +1,4 @@
125 require gcc-cross_${PV}.bb
126 require gcc-cross-intermediate.inc
127-PR = "r0"
128+PR = "r1"
129
130diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-cross_4.5.1.bb
131index 445869d..b7e4328 100644
132--- a/meta/recipes-devtools/gcc/gcc-cross_4.5.1.bb
133+++ b/meta/recipes-devtools/gcc/gcc-cross_4.5.1.bb
134@@ -1,4 +1,4 @@
135-PR = "r0"
136+PR = "r1"
137
138 require gcc-${PV}.inc
139 require gcc-cross4.inc
140diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.1.bb
141index 22cb490..0fc5faa 100644
142--- a/meta/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.1.bb
143+++ b/meta/recipes-devtools/gcc/gcc-crosssdk-initial_4.5.1.bb
144@@ -1,4 +1,4 @@
145 require gcc-cross-initial_${PV}.bb
146 require gcc-crosssdk-initial.inc
147
148-PR = "r0"
149+PR = "r1"
150diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.1.bb
151index ba42ca0..4260c35 100644
152--- a/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.1.bb
153+++ b/meta/recipes-devtools/gcc/gcc-crosssdk-intermediate_4.5.1.bb
154@@ -1,4 +1,4 @@
155 require gcc-cross-intermediate_${PV}.bb
156 require gcc-crosssdk-intermediate.inc
157
158-PR = "r0"
159+PR = "r1"
160diff --git a/meta/recipes-devtools/gcc/gcc-crosssdk_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-crosssdk_4.5.1.bb
161index 6f0a540..a23a662 100644
162--- a/meta/recipes-devtools/gcc/gcc-crosssdk_4.5.1.bb
163+++ b/meta/recipes-devtools/gcc/gcc-crosssdk_4.5.1.bb
164@@ -1,4 +1,4 @@
165 require gcc-cross_${PV}.bb
166 require gcc-crosssdk.inc
167
168-PR = "r0"
169+PR = "r1"
170diff --git a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
171index 4d2302d..ca22e8b 100644
172--- a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
173+++ b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
174@@ -1,4 +1,4 @@
175-PR = "r0"
176+PR = "r1"
177
178 require gcc-${PV}.inc
179 require gcc-configure-runtime.inc
180diff --git a/meta/recipes-devtools/gcc/gcc_4.5.1.bb b/meta/recipes-devtools/gcc/gcc_4.5.1.bb
181index 81c1fa9..a21772f 100644
182--- a/meta/recipes-devtools/gcc/gcc_4.5.1.bb
183+++ b/meta/recipes-devtools/gcc/gcc_4.5.1.bb
184@@ -1,4 +1,4 @@
185-PR = "r0"
186+PR = "r1"
187 require gcc-${PV}.inc
188 require gcc-configure-target.inc
189 require gcc-package-target.inc
190--
191cgit v0.8.3.3-89-gbf82