diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /toolchain-layer | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'toolchain-layer')
-rw-r--r-- | toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc | 138 | ||||
-rw-r--r-- | toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb | 6 | ||||
-rw-r--r-- | toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb | 68 |
3 files changed, 106 insertions, 106 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc b/toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc index 20ceb4986..83e9a9f55 100644 --- a/toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc +++ b/toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc | |||
@@ -28,55 +28,55 @@ NATIVEDEPS = "mpfr-native gmp-native libmpc-native zlib-native" | |||
28 | LICENSE="GPL-3.0-with-GCC-exception & GPLv3" | 28 | LICENSE="GPL-3.0-with-GCC-exception & GPLv3" |
29 | 29 | ||
30 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | 30 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ |
31 | file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \ | 31 | file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \ |
32 | file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \ | 32 | file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \ |
33 | file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \ | 33 | file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
34 | file://COPYING.RUNTIME;md5=fe60d87048567d4fe8c8a0ed2448bcc8" | 34 | file://COPYING.RUNTIME;md5=fe60d87048567d4fe8c8a0ed2448bcc8" |
35 | 35 | ||
36 | SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH};protocol=http \ | 36 | SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH};protocol=http \ |
37 | file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \ | 37 | file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \ |
38 | file://100-uclibc-conf.patch \ | 38 | file://100-uclibc-conf.patch \ |
39 | file://gcc-uclibc-locale-ctype_touplow_t.patch \ | 39 | file://gcc-uclibc-locale-ctype_touplow_t.patch \ |
40 | file://cache-amnesia.patch \ | 40 | file://cache-amnesia.patch \ |
41 | file://gcc-flags-for-build.patch \ | 41 | file://gcc-flags-for-build.patch \ |
42 | file://103-uclibc-conf-noupstream.patch \ | 42 | file://103-uclibc-conf-noupstream.patch \ |
43 | file://200-uclibc-locale.patch \ | 43 | file://200-uclibc-locale.patch \ |
44 | file://203-uclibc-locale-no__x.patch; \ | 44 | file://203-uclibc-locale-no__x.patch; \ |
45 | file://204-uclibc-locale-wchar_fix.patch; \ | 45 | file://204-uclibc-locale-wchar_fix.patch; \ |
46 | file://205-uclibc-locale-update.patch; \ | 46 | file://205-uclibc-locale-update.patch; \ |
47 | file://301-missing-execinfo_h.patch \ | 47 | file://301-missing-execinfo_h.patch \ |
48 | file://302-c99-snprintf.patch \ | 48 | file://302-c99-snprintf.patch \ |
49 | file://303-c99-complex-ugly-hack.patch \ | 49 | file://303-c99-complex-ugly-hack.patch \ |
50 | file://304-index_macro.patch \ | 50 | file://304-index_macro.patch \ |
51 | file://305-libmudflap-susv3-legacy.patch \ | 51 | file://305-libmudflap-susv3-legacy.patch \ |
52 | file://306-libstdc++-namespace.patch \ | 52 | file://306-libstdc++-namespace.patch \ |
53 | file://740-sh-pr24836.patch \ | 53 | file://740-sh-pr24836.patch \ |
54 | file://800-arm-bigendian.patch \ | 54 | file://800-arm-bigendian.patch \ |
55 | file://904-flatten-switch-stmt-00.patch \ | 55 | file://904-flatten-switch-stmt-00.patch \ |
56 | file://arm-nolibfloat.patch \ | 56 | file://arm-nolibfloat.patch \ |
57 | file://arm-softfloat.patch \ | 57 | file://arm-softfloat.patch \ |
58 | file://zecke-xgcc-cpp.patch \ | 58 | file://zecke-xgcc-cpp.patch \ |
59 | file://gcc-poison-system-directories.patch \ | 59 | file://gcc-poison-system-directories.patch \ |
60 | file://gcc-poison-dir-extend.patch \ | 60 | file://gcc-poison-dir-extend.patch \ |
61 | file://gcc-4.3.3-SYSROOT_CFLAGS_FOR_TARGET.patch \ | 61 | file://gcc-4.3.3-SYSROOT_CFLAGS_FOR_TARGET.patch \ |
62 | file://64bithack.patch \ | 62 | file://64bithack.patch \ |
63 | file://optional_libstdc.patch \ | 63 | file://optional_libstdc.patch \ |
64 | file://disable_relax_pic_calls_flag.patch \ | 64 | file://disable_relax_pic_calls_flag.patch \ |
65 | file://COLLECT_GCC_OPTIONS.patch \ | 65 | file://COLLECT_GCC_OPTIONS.patch \ |
66 | file://use-defaults.h-and-t-oe-in-B.patch \ | 66 | file://use-defaults.h-and-t-oe-in-B.patch \ |
67 | file://powerpc-e5500.patch \ | 67 | file://powerpc-e5500.patch \ |
68 | file://fix-for-ice-50099.patch \ | 68 | file://fix-for-ice-50099.patch \ |
69 | file://gcc-with-linker-hash-style.patch \ | 69 | file://gcc-with-linker-hash-style.patch \ |
70 | file://pr46934.patch \ | 70 | file://pr46934.patch \ |
71 | file://pr32219.patch \ | 71 | file://pr32219.patch \ |
72 | file://pr47551.patch \ | 72 | file://pr47551.patch \ |
73 | file://gcc-arm-set-cost.patch \ | 73 | file://gcc-arm-set-cost.patch \ |
74 | file://GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch \ | 74 | file://GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch \ |
75 | file://fortran-cross-compile-hack.patch \ | 75 | file://fortran-cross-compile-hack.patch \ |
76 | file://cpp-honour-sysroot.patch \ | 76 | file://cpp-honour-sysroot.patch \ |
77 | file://mips64-default-n64.patch \ | 77 | file://mips64-default-n64.patch \ |
78 | file://gcc-argument-list-too-long.patch \ | 78 | file://gcc-argument-list-too-long.patch \ |
79 | " | 79 | " |
80 | 80 | ||
81 | SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch " | 81 | SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch " |
82 | 82 | ||
@@ -89,31 +89,31 @@ FORTRAN = "" | |||
89 | JAVA = "" | 89 | JAVA = "" |
90 | 90 | ||
91 | EXTRA_OECONF_BASE = " --enable-lto \ | 91 | EXTRA_OECONF_BASE = " --enable-lto \ |
92 | --enable-libssp \ | 92 | --enable-libssp \ |
93 | --disable-bootstrap \ | 93 | --disable-bootstrap \ |
94 | --disable-libgomp \ | 94 | --disable-libgomp \ |
95 | --disable-libmudflap \ | 95 | --disable-libmudflap \ |
96 | --with-system-zlib \ | 96 | --with-system-zlib \ |
97 | --with-linker-hash-style=${LINKER_HASH_STYLE} \ | 97 | --with-linker-hash-style=${LINKER_HASH_STYLE} \ |
98 | --with-ppl=no \ | 98 | --with-ppl=no \ |
99 | --with-cloog=no \ | 99 | --with-cloog=no \ |
100 | --enable-cheaders=c_global " | 100 | --enable-cheaders=c_global " |
101 | 101 | ||
102 | EXTRA_OECONF_INITIAL = "--disable-libmudflap \ | 102 | EXTRA_OECONF_INITIAL = "--disable-libmudflap \ |
103 | --disable-libgomp \ | 103 | --disable-libgomp \ |
104 | --disable-libssp \ | 104 | --disable-libssp \ |
105 | --disable-libquadmath \ | 105 | --disable-libquadmath \ |
106 | --with-system-zlib \ | 106 | --with-system-zlib \ |
107 | --disable-lto \ | 107 | --disable-lto \ |
108 | --disable-plugin \ | 108 | --disable-plugin \ |
109 | --enable-decimal-float=no" | 109 | --enable-decimal-float=no" |
110 | 110 | ||
111 | EXTRA_OECONF_INTERMEDIATE = "--disable-libmudflap \ | 111 | EXTRA_OECONF_INTERMEDIATE = "--disable-libmudflap \ |
112 | --disable-libgomp \ | 112 | --disable-libgomp \ |
113 | --disable-libquadmath \ | 113 | --disable-libquadmath \ |
114 | --with-system-zlib \ | 114 | --with-system-zlib \ |
115 | --disable-lto \ | 115 | --disable-lto \ |
116 | --disable-plugin \ | 116 | --disable-plugin \ |
117 | --disable-libssp" | 117 | --disable-libssp" |
118 | 118 | ||
119 | EXTRA_OECONF_append_libc-uclibc = " --disable-decimal-float " | 119 | EXTRA_OECONF_append_libc-uclibc = " --disable-decimal-float " |
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb index 788391a2e..5c2435fc9 100644 --- a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb +++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb | |||
@@ -13,9 +13,9 @@ SYSTEMLIBS = "/lib/" | |||
13 | SYSTEMLIBS1 = "/usr/lib/" | 13 | SYSTEMLIBS1 = "/usr/lib/" |
14 | 14 | ||
15 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ | 15 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ |
16 | --disable-libgomp --disable-libmudflap \ | 16 | --disable-libgomp --disable-libmudflap \ |
17 | --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \ | 17 | --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \ |
18 | --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}" | 18 | --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}" |
19 | 19 | ||
20 | # to find libmpfr | 20 | # to find libmpfr |
21 | # export LD_LIBRARY_PATH = "{STAGING_DIR_HOST}${layout_exec_prefix}" | 21 | # export LD_LIBRARY_PATH = "{STAGING_DIR_HOST}${layout_exec_prefix}" |
diff --git a/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb b/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb index 4dade0839..fc2c1e31a 100644 --- a/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb +++ b/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb | |||
@@ -8,56 +8,56 @@ PKGSUFFIX = "" | |||
8 | PKGSUFFIX_class-nativesdk = "-nativesdk" | 8 | PKGSUFFIX_class-nativesdk = "-nativesdk" |
9 | 9 | ||
10 | PACKAGES = "\ | 10 | PACKAGES = "\ |
11 | ${PN} \ | 11 | ${PN} \ |
12 | ${PN}-dev \ | 12 | ${PN}-dev \ |
13 | ${PN}-dbg \ | 13 | ${PN}-dbg \ |
14 | libgcov${PKGSUFFIX}-dev \ | 14 | libgcov${PKGSUFFIX}-dev \ |
15 | " | 15 | " |
16 | 16 | ||
17 | FILES_${PN} = "${base_libdir}/libgcc*.so.*" | 17 | FILES_${PN} = "${base_libdir}/libgcc*.so.*" |
18 | FILES_${PN}-dev = " \ | 18 | FILES_${PN}-dev = " \ |
19 | ${base_libdir}/libgcc*.so \ | 19 | ${base_libdir}/libgcc*.so \ |
20 | ${libdir}/${TARGET_SYS}/${BINV}/*crt* \ | 20 | ${libdir}/${TARGET_SYS}/${BINV}/*crt* \ |
21 | ${libdir}/${TARGET_SYS}/${BINV}/libgcc*" | 21 | ${libdir}/${TARGET_SYS}/${BINV}/libgcc*" |
22 | FILES_libgcov${PKGSUFFIX}-dev = " \ | 22 | FILES_libgcov${PKGSUFFIX}-dev = " \ |
23 | ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \ | 23 | ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \ |
24 | " | 24 | " |
25 | FILES_${PN}-dbg += "${base_libdir}/.debug/" | 25 | FILES_${PN}-dbg += "${base_libdir}/.debug/" |
26 | 26 | ||
27 | do_configure () { | 27 | do_configure () { |
28 | target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##` | 28 | target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##` |
29 | install -d ${D}${base_libdir} ${D}${libdir} | 29 | install -d ${D}${base_libdir} ${D}${libdir} |
30 | cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B} | 30 | cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B} |
31 | mkdir -p ${B}/${BPN} | 31 | mkdir -p ${B}/${BPN} |
32 | cd ${B}/${BPN} | 32 | cd ${B}/${BPN} |
33 | chmod a+x ${S}/${BPN}/configure | 33 | chmod a+x ${S}/${BPN}/configure |
34 | ${S}/${BPN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF} | 34 | ${S}/${BPN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF} |
35 | } | 35 | } |
36 | 36 | ||
37 | do_compile () { | 37 | do_compile () { |
38 | target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` | 38 | target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` |
39 | cd ${B}/${BPN} | 39 | cd ${B}/${BPN} |
40 | oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/ | 40 | oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/ |
41 | } | 41 | } |
42 | 42 | ||
43 | do_install () { | 43 | do_install () { |
44 | target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` | 44 | target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` |
45 | cd ${B}/${BPN} | 45 | cd ${B}/${BPN} |
46 | oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install | 46 | oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install |
47 | 47 | ||
48 | # Move libgcc_s into /lib | 48 | # Move libgcc_s into /lib |
49 | mkdir -p ${D}${base_libdir} | 49 | mkdir -p ${D}${base_libdir} |
50 | if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then | 50 | if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then |
51 | mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir} | 51 | mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir} |
52 | else | 52 | else |
53 | mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true | 53 | mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true |
54 | fi | 54 | fi |
55 | 55 | ||
56 | # install the runtime in /usr/lib/ not in /usr/lib/gcc on target | 56 | # install the runtime in /usr/lib/ not in /usr/lib/gcc on target |
57 | # so that cross-gcc can find it in the sysroot | 57 | # so that cross-gcc can find it in the sysroot |
58 | 58 | ||
59 | mv ${D}${libdir}/gcc/* ${D}${libdir} | 59 | mv ${D}${libdir}/gcc/* ${D}${libdir} |
60 | rm -rf ${D}${libdir}/gcc/ | 60 | rm -rf ${D}${libdir}/gcc/ |
61 | } | 61 | } |
62 | 62 | ||
63 | do_package_write_ipk[depends] += "virtual/${MLPREFIX}libc:do_package" | 63 | do_package_write_ipk[depends] += "virtual/${MLPREFIX}libc:do_package" |