diff options
author | Khem Raj <raj.khem@gmail.com> | 2012-04-30 20:51:04 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-05-02 11:43:49 +0200 |
commit | 23a111fe542bd8d5f2d12f9d9ae9890c31dddeed (patch) | |
tree | 11cb48128268c6766d408e2937da2918c1581ca7 /toolchain-layer | |
parent | 9daadb3f4985ade47193f2db44d31f2a2189c414 (diff) | |
download | meta-openembedded-23a111fe542bd8d5f2d12f9d9ae9890c31dddeed.tar.gz |
libgcc-4.5: Fix nativesdk build problem
We need to use BPN instead of PN so we
access libgcc and not libgcc-nativesdk
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Tested-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'toolchain-layer')
-rw-r--r-- | toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb | 32 |
1 files changed, 18 insertions, 14 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb b/toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb index ecef5e704..3f63931d8 100644 --- a/toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb +++ b/toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb | |||
@@ -4,11 +4,14 @@ INHIBIT_DEFAULT_DEPS = "1" | |||
4 | 4 | ||
5 | DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++" | 5 | DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++" |
6 | 6 | ||
7 | PKGSUFFIX = "" | ||
8 | PKGSUFFIX_virtclass-nativesdk = "-nativesdk" | ||
9 | |||
7 | PACKAGES = "\ | 10 | PACKAGES = "\ |
8 | ${PN} \ | 11 | ${PN} \ |
9 | ${PN}-dev \ | 12 | ${PN}-dev \ |
10 | ${PN}-dbg \ | 13 | ${PN}-dbg \ |
11 | libgcov-dev \ | 14 | libgcov${PKGSUFFIX}-dev \ |
12 | " | 15 | " |
13 | 16 | ||
14 | FILES_${PN} = "${base_libdir}/libgcc*.so.*" | 17 | FILES_${PN} = "${base_libdir}/libgcc*.so.*" |
@@ -16,31 +19,31 @@ FILES_${PN}-dev = " \ | |||
16 | ${base_libdir}/libgcc*.so \ | 19 | ${base_libdir}/libgcc*.so \ |
17 | ${libdir}/${TARGET_SYS}/${BINV}/crt* \ | 20 | ${libdir}/${TARGET_SYS}/${BINV}/crt* \ |
18 | ${libdir}/${TARGET_SYS}/${BINV}/libgcc*" | 21 | ${libdir}/${TARGET_SYS}/${BINV}/libgcc*" |
19 | FILES_libgcov-dev = " \ | 22 | FILES_libgcov${PKGSUFFIX}-dev = " \ |
20 | ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a" | 23 | ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \ |
21 | 24 | " | |
22 | FILES_${PN}-dbg += "${base_libdir}/.debug/" | 25 | FILES_${PN}-dbg += "${base_libdir}/.debug/" |
23 | 26 | ||
24 | do_configure () { | 27 | do_configure () { |
25 | target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##` | 28 | target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##` |
26 | install -d ${D}${base_libdir} ${D}${libdir} | 29 | install -d ${D}${base_libdir} ${D}${libdir} |
27 | cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B} | 30 | cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B} |
28 | mkdir -p ${B}/${PN} | 31 | mkdir -p ${B}/${BPN} |
29 | cd ${B}/${PN} | 32 | cd ${B}/${BPN} |
30 | chmod a+x ${S}/${PN}/configure | 33 | chmod a+x ${S}/${BPN}/configure |
31 | ${S}/${PN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF} | 34 | ${S}/${BPN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF} |
32 | } | 35 | } |
33 | 36 | ||
34 | do_compile () { | 37 | do_compile () { |
35 | target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` | 38 | target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` |
36 | cd ${B}/${PN} | 39 | cd ${B}/${BPN} |
37 | oe_runmake MULTIBUILDTOP=${B}/$target/${PN}/ | 40 | oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/ |
38 | } | 41 | } |
39 | 42 | ||
40 | do_install () { | 43 | do_install () { |
41 | target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` | 44 | target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` |
42 | cd ${B}/${PN} | 45 | cd ${B}/${BPN} |
43 | oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${PN}/ install | 46 | oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install |
44 | 47 | ||
45 | # Move libgcc_s into /lib | 48 | # Move libgcc_s into /lib |
46 | mkdir -p ${D}${base_libdir} | 49 | mkdir -p ${D}${base_libdir} |
@@ -63,5 +66,6 @@ do_package_write_rpm[depends] += "virtual/${MLPREFIX}libc:do_package" | |||
63 | 66 | ||
64 | BBCLASSEXTEND = "nativesdk" | 67 | BBCLASSEXTEND = "nativesdk" |
65 | 68 | ||
66 | INSANE_SKIP_libgcc-dev = "staticdev" | 69 | INSANE_SKIP_${PN}-dev = "staticdev" |
67 | INSANE_SKIP_libgcov-dev = "staticdev" | 70 | INSANE_SKIP_libgcov${PKGSUFFIX}-dev = "staticdev" |
71 | |||