summaryrefslogtreecommitdiffstats
path: root/toolchain-layer
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-08-28 06:34:10 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-03 19:56:52 +0200
commit9f26a42638fda6159bf2a68f1db32db1eb72c355 (patch)
tree5364fddfbc6f1498bdc32cff4aee95e651edbb17 /toolchain-layer
parent0879762ec4206333173d6a0abaa21f1398bac2a4 (diff)
downloadmeta-openembedded-9f26a42638fda6159bf2a68f1db32db1eb72c355.tar.gz
gcc-4.6: Update to match gcc restructing in OE-Core
The include file infra in gcc recipes recieved an overhaul on OE-Core. This patch matches the toolchain layer recipes to use the new include files Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'toolchain-layer')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb19
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb8
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb8
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb5
4 files changed, 3 insertions, 37 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
index 5c2435fc9..29ddd6773 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
@@ -2,22 +2,3 @@ inherit cross-canadian
2 2
3require recipes-devtools/gcc/gcc-${PV}.inc 3require recipes-devtools/gcc/gcc-${PV}.inc
4require recipes-devtools/gcc/gcc-cross-canadian.inc 4require recipes-devtools/gcc/gcc-cross-canadian.inc
5require recipes-devtools/gcc/gcc-configure-sdk.inc
6require recipes-devtools/gcc/gcc-package-sdk.inc
7
8DEPENDS += "nativesdk-gmp nativesdk-mpfr nativesdk-libmpc nativesdk-elfutils"
9RDEPENDS_${PN} += "nativesdk-mpfr nativesdk-libmpc nativesdk-elfutils"
10
11SYSTEMHEADERS = "/usr/include"
12SYSTEMLIBS = "/lib/"
13SYSTEMLIBS1 = "/usr/lib/"
14
15EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
16 --disable-libgomp --disable-libmudflap \
17 --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \
18 --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}"
19
20# to find libmpfr
21# export LD_LIBRARY_PATH = "{STAGING_DIR_HOST}${layout_exec_prefix}"
22
23PARALLEL_MAKE = ""
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb
index eb8896ca5..cdaa7e8cd 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb
@@ -1,8 +1,2 @@
1require recipes-devtools/gcc/gcc-${PV}.inc 1require recipes-devtools/gcc/gcc-${PV}.inc
2require recipes-devtools/gcc/gcc-cross4.inc 2require recipes-devtools/gcc/gcc-cross.inc
3
4EXTRA_OECONF += "--disable-libunwind-exceptions \
5 --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
6 --with-system-zlib "
7
8ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb
index 13431c8b6..b755f555e 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb
@@ -1,8 +1,2 @@
1require recipes-devtools/gcc/gcc-${PV}.inc 1require recipes-devtools/gcc/gcc-${PV}.inc
2require recipes-devtools/gcc/gcc-configure-runtime.inc 2require recipes-devtools/gcc/gcc-runtime.inc
3require recipes-devtools/gcc/gcc-package-runtime.inc
4
5ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
6
7EXTRA_OECONF += "--disable-libunwind-exceptions"
8EXTRA_OECONF_append_linuxstdbase = " --enable-clocale=gnu"
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb
index 97e6c324d..6ad8973b4 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb
@@ -1,5 +1,2 @@
1require recipes-devtools/gcc/gcc-${PV}.inc 1require recipes-devtools/gcc/gcc-${PV}.inc
2require recipes-devtools/gcc/gcc-configure-target.inc 2require recipes-devtools/gcc/gcc-target.inc
3require recipes-devtools/gcc/gcc-package-target.inc
4
5ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"