summaryrefslogtreecommitdiffstats
path: root/toolchain-layer
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-04-30 20:51:04 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-05-02 11:43:49 +0200
commit23a111fe542bd8d5f2d12f9d9ae9890c31dddeed (patch)
tree11cb48128268c6766d408e2937da2918c1581ca7 /toolchain-layer
parent9daadb3f4985ade47193f2db44d31f2a2189c414 (diff)
downloadmeta-openembedded-23a111fe542bd8d5f2d12f9d9ae9890c31dddeed.tar.gz
libgcc-4.5: Fix nativesdk build problem
We need to use BPN instead of PN so we access libgcc and not libgcc-nativesdk Signed-off-by: Khem Raj <raj.khem@gmail.com> Tested-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'toolchain-layer')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb32
1 files changed, 18 insertions, 14 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb b/toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb
index ecef5e704..3f63931d8 100644
--- a/toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb
+++ b/toolchain-layer/recipes-devtools/gcc/libgcc_4.5.bb
@@ -4,11 +4,14 @@ INHIBIT_DEFAULT_DEPS = "1"
4 4
5DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++" 5DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
6 6
7PKGSUFFIX = ""
8PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
9
7PACKAGES = "\ 10PACKAGES = "\
8 ${PN} \ 11 ${PN} \
9 ${PN}-dev \ 12 ${PN}-dev \
10 ${PN}-dbg \ 13 ${PN}-dbg \
11 libgcov-dev \ 14 libgcov${PKGSUFFIX}-dev \
12 " 15 "
13 16
14FILES_${PN} = "${base_libdir}/libgcc*.so.*" 17FILES_${PN} = "${base_libdir}/libgcc*.so.*"
@@ -16,31 +19,31 @@ FILES_${PN}-dev = " \
16 ${base_libdir}/libgcc*.so \ 19 ${base_libdir}/libgcc*.so \
17 ${libdir}/${TARGET_SYS}/${BINV}/crt* \ 20 ${libdir}/${TARGET_SYS}/${BINV}/crt* \
18 ${libdir}/${TARGET_SYS}/${BINV}/libgcc*" 21 ${libdir}/${TARGET_SYS}/${BINV}/libgcc*"
19FILES_libgcov-dev = " \ 22FILES_libgcov${PKGSUFFIX}-dev = " \
20 ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a" 23 ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \
21 24 "
22FILES_${PN}-dbg += "${base_libdir}/.debug/" 25FILES_${PN}-dbg += "${base_libdir}/.debug/"
23 26
24do_configure () { 27do_configure () {
25 target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##` 28 target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
26 install -d ${D}${base_libdir} ${D}${libdir} 29 install -d ${D}${base_libdir} ${D}${libdir}
27 cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B} 30 cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B}
28 mkdir -p ${B}/${PN} 31 mkdir -p ${B}/${BPN}
29 cd ${B}/${PN} 32 cd ${B}/${BPN}
30 chmod a+x ${S}/${PN}/configure 33 chmod a+x ${S}/${BPN}/configure
31 ${S}/${PN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF} 34 ${S}/${BPN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
32} 35}
33 36
34do_compile () { 37do_compile () {
35 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` 38 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
36 cd ${B}/${PN} 39 cd ${B}/${BPN}
37 oe_runmake MULTIBUILDTOP=${B}/$target/${PN}/ 40 oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/
38} 41}
39 42
40do_install () { 43do_install () {
41 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` 44 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
42 cd ${B}/${PN} 45 cd ${B}/${BPN}
43 oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${PN}/ install 46 oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install
44 47
45 # Move libgcc_s into /lib 48 # Move libgcc_s into /lib
46 mkdir -p ${D}${base_libdir} 49 mkdir -p ${D}${base_libdir}
@@ -63,5 +66,6 @@ do_package_write_rpm[depends] += "virtual/${MLPREFIX}libc:do_package"
63 66
64BBCLASSEXTEND = "nativesdk" 67BBCLASSEXTEND = "nativesdk"
65 68
66INSANE_SKIP_libgcc-dev = "staticdev" 69INSANE_SKIP_${PN}-dev = "staticdev"
67INSANE_SKIP_libgcov-dev = "staticdev" 70INSANE_SKIP_libgcov${PKGSUFFIX}-dev = "staticdev"
71