diff options
author | Khem Raj <raj.khem@gmail.com> | 2012-03-28 01:54:22 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-03-29 16:14:38 +0200 |
commit | 444c13d1f114c59c7ff568f0313cacc8e67362a1 (patch) | |
tree | 3c480be8070db8d34f5a2cce723888893ad3de09 /toolchain-layer/recipes-devtools | |
parent | d110784db8e78f9b1aa877e3e9228792d34f4583 (diff) | |
download | meta-openembedded-444c13d1f114c59c7ff568f0313cacc8e67362a1.tar.gz |
gcc-4.5: Fix meta-toolchain builds with gcc 4.5
Correct a typo
Make license parsable by license manage
Fixes messages like
WARNING: libgcc-nativesdk: No generic license file exists for: RUNTIME
in any provider
WARNING: libgcc-nativesdk: No generic license file exists for: LIBRARY
in any provider
WARNING: libgcc-nativesdk: No generic license file exists for: EXCEPTION
in any provider
NOTE: package libgcc-nativesdk-4.5-r48+svnr184907: task do_populate_lic:
Succeeded
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'toolchain-layer/recipes-devtools')
-rw-r--r-- | toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc | 4 | ||||
-rw-r--r-- | toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb | 2 |
2 files changed, 3 insertions, 3 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc b/toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc index b23b3224b..ee4a43407 100644 --- a/toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc +++ b/toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc | |||
@@ -4,7 +4,7 @@ ARM_INSTRUCTION_SET = "arm" | |||
4 | DEPENDS =+ "mpfr gmp libmpc elfutils" | 4 | DEPENDS =+ "mpfr gmp libmpc elfutils" |
5 | NATIVEDEPS = "mpfr-native gmp-native gettext-native libmpc-native elfutils-native" | 5 | NATIVEDEPS = "mpfr-native gmp-native gettext-native libmpc-native elfutils-native" |
6 | 6 | ||
7 | LICENSE="GCC RUNTIME LIBRARY EXCEPTION & GPLv2 & GPLv3 & LGPLv2.1 & LGPLv3" | 7 | LICENSE="GPL-3.0-with-GCC-exception & GPLv2 & GPLv3 & LGPLv2.1 & LGPLv3" |
8 | 8 | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ |
10 | file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \ | 10 | file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \ |
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | |||
14 | 14 | ||
15 | 15 | ||
16 | PV = "4.5" | 16 | PV = "4.5" |
17 | PR = "r47" | 17 | PR = "r48" |
18 | 18 | ||
19 | # BINV should be incremented after updating to a revision | 19 | # BINV should be incremented after updating to a revision |
20 | # after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made | 20 | # after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made |
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb index 97e1a2bcb..0afc90735 100644 --- a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb +++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb | |||
@@ -11,7 +11,7 @@ RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk" | |||
11 | 11 | ||
12 | SYSTEMHEADERS = "/usr/include" | 12 | SYSTEMHEADERS = "/usr/include" |
13 | SYSTEMLIBS = "/lib/" | 13 | SYSTEMLIBS = "/lib/" |
14 | SYSTEMLIB. = "/usr/lib/" | 14 | SYSTEMLIBS1 = "/usr/lib/" |
15 | 15 | ||
16 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ | 16 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ |
17 | --disable-libgomp --disable-libmudflap \ | 17 | --disable-libgomp --disable-libmudflap \ |