summaryrefslogtreecommitdiffstats
path: root/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb68
1 files changed, 34 insertions, 34 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb b/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb
index 4dade0839..fc2c1e31a 100644
--- a/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb
@@ -8,56 +8,56 @@ PKGSUFFIX = ""
8PKGSUFFIX_class-nativesdk = "-nativesdk" 8PKGSUFFIX_class-nativesdk = "-nativesdk"
9 9
10PACKAGES = "\ 10PACKAGES = "\
11 ${PN} \ 11 ${PN} \
12 ${PN}-dev \ 12 ${PN}-dev \
13 ${PN}-dbg \ 13 ${PN}-dbg \
14 libgcov${PKGSUFFIX}-dev \ 14 libgcov${PKGSUFFIX}-dev \
15 " 15"
16 16
17FILES_${PN} = "${base_libdir}/libgcc*.so.*" 17FILES_${PN} = "${base_libdir}/libgcc*.so.*"
18FILES_${PN}-dev = " \ 18FILES_${PN}-dev = " \
19 ${base_libdir}/libgcc*.so \ 19 ${base_libdir}/libgcc*.so \
20 ${libdir}/${TARGET_SYS}/${BINV}/*crt* \ 20 ${libdir}/${TARGET_SYS}/${BINV}/*crt* \
21 ${libdir}/${TARGET_SYS}/${BINV}/libgcc*" 21 ${libdir}/${TARGET_SYS}/${BINV}/libgcc*"
22FILES_libgcov${PKGSUFFIX}-dev = " \ 22FILES_libgcov${PKGSUFFIX}-dev = " \
23 ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \ 23 ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \
24 " 24"
25FILES_${PN}-dbg += "${base_libdir}/.debug/" 25FILES_${PN}-dbg += "${base_libdir}/.debug/"
26 26
27do_configure () { 27do_configure () {
28 target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##` 28 target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
29 install -d ${D}${base_libdir} ${D}${libdir} 29 install -d ${D}${base_libdir} ${D}${libdir}
30 cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B} 30 cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B}
31 mkdir -p ${B}/${BPN} 31 mkdir -p ${B}/${BPN}
32 cd ${B}/${BPN} 32 cd ${B}/${BPN}
33 chmod a+x ${S}/${BPN}/configure 33 chmod a+x ${S}/${BPN}/configure
34 ${S}/${BPN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF} 34 ${S}/${BPN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
35} 35}
36 36
37do_compile () { 37do_compile () {
38 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` 38 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
39 cd ${B}/${BPN} 39 cd ${B}/${BPN}
40 oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/ 40 oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/
41} 41}
42 42
43do_install () { 43do_install () {
44 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` 44 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
45 cd ${B}/${BPN} 45 cd ${B}/${BPN}
46 oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install 46 oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install
47 47
48 # Move libgcc_s into /lib 48 # Move libgcc_s into /lib
49 mkdir -p ${D}${base_libdir} 49 mkdir -p ${D}${base_libdir}
50 if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then 50 if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then
51 mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir} 51 mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir}
52 else 52 else
53 mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true 53 mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true
54 fi 54 fi
55 55
56 # install the runtime in /usr/lib/ not in /usr/lib/gcc on target 56 # install the runtime in /usr/lib/ not in /usr/lib/gcc on target
57 # so that cross-gcc can find it in the sysroot 57 # so that cross-gcc can find it in the sysroot
58 58
59 mv ${D}${libdir}/gcc/* ${D}${libdir} 59 mv ${D}${libdir}/gcc/* ${D}${libdir}
60 rm -rf ${D}${libdir}/gcc/ 60 rm -rf ${D}${libdir}/gcc/
61} 61}
62 62
63do_package_write_ipk[depends] += "virtual/${MLPREFIX}libc:do_package" 63do_package_write_ipk[depends] += "virtual/${MLPREFIX}libc:do_package"